LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 01-14-2021, 11:08 AM   #76
sndwvs
Member
 
Registered: Aug 2014
Posts: 942

Rep: Reputation: Disabled

the list is the same for me

bluez-5.55-aarch64-2.txz
 
1 members found this post helpful.
Old 01-14-2021, 11:22 AM   #77
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 702

Original Poster
Rep: Reputation: Disabled
So why on earth doesn't it compile here?

Did you compile with -fPIC? Your earlier message suggests not. I don't think that would make a difference, but I'm clutching at straws!

Have you had a look at the patches?

--
Pete
 
Old 01-14-2021, 11:24 AM   #78
sndwvs
Member
 
Registered: Aug 2014
Posts: 942

Rep: Reputation: Disabled
I compiled with patches, -fPIC does not affect the error here
 
1 members found this post helpful.
Old 01-14-2021, 11:48 AM   #79
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 702

Original Poster
Rep: Reputation: Disabled
Ah! Sorry! Didn't realise that the package you sent had the patches!

I will try it now!

--
Pete
 
Old 01-14-2021, 12:01 PM   #80
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 702

Original Poster
Rep: Reputation: Disabled
YES! It now finds the adapter, and finds local bluetooth devices!

Brilliant!

Thank you for your help and support in this!

--
Pete
 
Old 01-15-2021, 11:08 AM   #81
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 702

Original Poster
Rep: Reputation: Disabled
Still having issues compiling stuff (see #71), which appear to be pkg-config related.

Back on post #71, my system complained about missing GLib - even though it was installed! Having now got X265 to compile, I need to recompile ffmpeg:

Code:
<snip>
ffmpeg-4.3.1/fftools/cmdutils.h
ffmpeg-4.3.1/fftools/ffplay.c
ffmpeg-4.3.1/CONTRIBUTING.md
ffmpeg-4.3.1/README.md
ERROR: gnutls not found using pkg-config

locate gnutls | more
/usr/bin/gnutls-cli
/usr/bin/gnutls-cli-debug
/usr/bin/gnutls-serv
/usr/doc/gnutls-3.6.15
<snip>

locate gnutls.pc
/usr/lib64/pkgconfig/gnutls.pc
If I set gnutls to "no" in the slackbuild, it then borks at libbluray (also installed), and so on!

The search paths for the .pc files looks OK (/usr/lib64/pkgconfig is in the list), so what on earth is going on?

TIA

--
Pete

Last edited by pchristy; 01-15-2021 at 11:13 AM. Reason: minor update
 
Old 01-15-2021, 11:14 AM   #82
sndwvs
Member
 
Registered: Aug 2014
Posts: 942

Rep: Reputation: Disabled
which outputs
Code:
pkg-config --print-provides gnutls
gnutls = 3.6.15
pkg-config --print-provides libbluray
libbluray = 1.2.1
 
Old 01-15-2021, 01:36 PM   #83
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 702

Original Poster
Rep: Reputation: Disabled
Code:
pkg-config --print-provides gnutls
gnutls = 3.6.15 

pkg-config --print-provides libbluray
libbluray = 1.2.1
Curioser and curioser!

--
Pete
 
Old 01-17-2021, 11:07 AM   #84
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 702

Original Poster
Rep: Reputation: Disabled
Finally got to the bottom of this, and it was a case of "dependency hell"! The problem was not actually gnutls, but another library that gnutls depends on! The error message was actually misleading!

As a result, I've installed every library from the "l" series, and now ffmpeg compiles without complaint!

I've still got bluetooth issues, though. Although bluetooth now works, and I can connect audio devices, it crashes at irregular intervals. VLC will usually play one item right through, but crashes on the second. The combination of Firefox and YouTube causes it to crash almost instantly. Once crashed, the on-board adapter disappears and can only be restored by re-booting.

The Pi 400 does not have any audio jacks. It will send audio over hdmi, however my monitor does not have audio, so bluetooth is the only way to get audio from the Pi.

Now that compiling is working again, I'm going to try recompiling bluez on this machine, and see if this solves the problem!

Onwards and upwards!

--
Pete
 
  


Reply

Tags
pi 400


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pi 400 slarm64-current not booting pchristy Slackware - ARM 18 12-29-2020 12:16 PM
[SOLVED] Slarm64 / Xfce / Blueman / PyGObject - GUI seems broken? shelldweller Slackware - ARM 9 02-20-2020 10:25 AM
Installing slarm64 on a Raspberry PI 4 akschu Slackware - ARM 0 01-04-2020 09:44 PM
slarm64 no wifi kermitdafrog8 Slackware - ARM 45 09-27-2019 10:33 AM
[VPS] 4 load page = 100 MB RAM loaded? do i need 100x 400 mb ram for next 400 page? vaporizel Linux - Server 1 03-14-2011 08:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 09:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration