LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 03-17-2018, 12:47 PM   #1
dreadbit
LQ Newbie
 
Registered: Aug 2016
Posts: 9

Rep: Reputation: Disabled
go - working?


Hello,

I'm learning golang using both i586 and arm (mostly-current)Slacks, compiling some simple projects. No problems on i586.

On arm 'go build simple.go' freezes like that:

futex(0x1041fbec, FUTEX_WAKE, 1) = 1
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
futex(0x1041fbec, FUTEX_WAKE, 1) = 1
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
futex(0x1041fbec, FUTEX_WAKE, 1) = 1
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0

(and hangs)
When I call gccgo, it compiles some tiny programs.

Did someone notice smth like that? Some tip or workaround? How to diagnose that?
 
Old 03-17-2018, 07:49 PM   #2
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 614

Rep: Reputation: 119Reputation: 119
I know nothing about go language.

Found this page, did everything on my slackware current rpi3 and got everything same as the page.

gccgo hello-world.go produced a.out.

Maybe post your simple.go script.
 
Old 03-22-2018, 06:33 AM   #3
dreadbit
LQ Newbie
 
Registered: Aug 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by glorsplitz View Post
gccgo hello-world.go produced a.out.
Well, looks like compiler itself is working. To reproduce the problem, try to

go get -v github.com/ziutek/mymysql/...

- this is suspected to be an installation of go-mysql driver in ~/go , taken from https://github.com/ziutek/mymysql .
It actually says "creating ~/go" and even downloads some stuff there.
I've spend 80 mins waiting it to complete - but it does not, eating 100% of one core on Banana PI.

So that's not a problem in the compiler, but in golang infrastructure. I cannot advise anything, because as I said I'm learning golang and still do no know much about 'go' command (except that it does all the infrastructure work)
 
Old 03-22-2018, 12:35 PM   #4
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 684

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
Quote:
Originally Posted by dreadbit View Post
So that's not a problem in the compiler, but in golang infrastructure. I cannot advise anything, because as I said I'm learning golang and still do no know much about 'go' command (except that it does all the infrastructure work)
Same here. I ran in to issues like this when go first appeared on ARM, but it was intermittent.
I didn't see any patches floating around, so I assumed that perhaps it works on other distributions, or that it doesn't and nobody noticed who cared to report it, or it's only a Slackware ARM problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wifi not working in Eee PPC 1000HE (Debian Squeeze), but ethernet is working someshpr Linux - Laptop and Netbook 8 10-10-2011 03:59 PM
media problem with .avi --- audio only in vlc working rest amarock ,etc. not working fedex Linux - Newbie 1 12-22-2007 08:06 AM
SED - minor changes work - Larger doesn't (working and non working code included) Nimoy Programming 17 09-22-2007 04:34 PM
Fortemedia FM801 card not working under FC5 on Intel 845 but working with windows morningkiran Linux - Hardware 0 11-30-2006 07:57 AM
acpi nearly working IBM thinkpad R40e 2684HVG no Fn key working, throttling OK Emmanuel_uk Linux - Laptop and Netbook 2 05-31-2006 01:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration