-   Slackware - ARM (
-   -   FUSE - SlackwareARM - Cannot mount (

AlvaroG 04-07-2014 08:32 PM

FUSE - SlackwareARM - Cannot mount
I'm trying to setup a Raspberry Pi as a file server using ddumbfs to reduce the storage requirements.
The compilation and install goes just fine, but when I get to mount the filesystem I get nothing.

When I run the ddumbfs command to mount the FS, I get normal output from the program but the filesystem is not mounted. If I run 'mount' after that, I see 'fusectl' is in the list, but no ddumbfs. Even after stopping fuse (via rc.fuse stop) I can run the command without failures, so that makes me thing it is a problem with my FUSE setup.
I even had the same issue with lessfs, and dmesg is not being particularily helpful (only showing the fuse init/fuse exit messages)

I'm running SlackwareARM 14.0, updated a few days back with the latest patches.

I honestly don't know what to do here, I don't know where to get more information to debug.

AlvaroG 04-08-2014 06:51 PM

I did some research with strace and was able to find a bug, or incompatibility with the Raspberry Pi in ddumbfs.

In src/ddfslib.c, there is code to find the processor count, that basically counts the number of lines starting with "processor". Since the Pi's cpuinfo file uses "Processor" instead of "processor", the final count is 0, and the program exits immediately.

My solution was to change the comparison to be case-insensitive (use strcasecmp instead of strcmp). I re-compiled and it worked just fine. I also posted the bug to the ddumbfs developers.

I know the Pi is not appropriate for this task given its low RAM (256MB in my ModelB), but still I'd like to try how it behaves.


All times are GMT -5. The time now is 03:32 AM.