LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 08-09-2017, 02:16 PM   #1
njathan
LQ Newbie
 
Registered: Aug 2017
Posts: 11

Rep: Reputation: Disabled
Enable "monitor mode" for wireless interface in RPi3


I am running my RPi3 on slackware-current (14.2 at the moment).
While trying to enable monitor mode (using airmon-ng start wlan0), it gave me an error which ultimately lead me to a post saying monitor mode is not supported on the broadcom provided drivers of BCN43438 chipset... later talking about the nexmon project which can make it happen.

The instructions in the nexmon rpi project are mostly for raspbian, with (thankfully) a section talking about "Creating your own firmware patch"

Now i am mostly conversant with basics of linux (mostly admin-ish work), but have only made the most basic SlackBuild.. Can someone guide me (1) if one can create a slackbuild out of the instructions there? and does one already exist? (2) which is the slackware arm/sarpi equivalent of "raspberrypi-kernel-headers"? (3) which package provides libgmp3-dev ?

edit: I also need to know how to confirm mine is BCM43438.. 'coz after running "airmod-ng start" i remember seeing BCM43430

Last edited by njathan; 08-09-2017 at 02:18 PM.
 
Old 08-20-2017, 02:50 PM   #2
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware x86 & ARM
Posts: 111

Rep: Reputation: 29
@njathan

I don't own a Pi3, as I'm considering it a flawed product - CPU overheating & throttling & unable to hardware disable Wifi&BT wich both are flawed due to the Broadpwn exploit (they got an official patch some days ago), so I'm not sure I could help you with the BCM chip id.

Compiling a kernel module is always tricky, it's like in electronics, everyone has a schematic that doesn't work - in this respect, everyone has a howto that will break the compilation/module/kernel. Additionally, in order to compile only one module/driver you'll need at least the Raspberry kernel headers and the kernel .config file. Having this said and assuming you are using the latest Raspberry official kernel on your Slack ARM, I'd strongly suggest you to get a Raspbian image (the complete/big one), boot it on your Pi and follow the instructions from nexmon - as they are working& tested. After you finish the compilation&modules installation, archive the results by running:

cd /
tar -czvpf kernel-WiFi-patched-kernel-version.tgz /lib/modules /lib/firmware

- backup the resulted archive on an external stick/HDD
- boot with your Slack-ARM SDCard
- backup your Slack-ARM by running:
cd /
tar -czvpf kernel-Slack-ARM-Backup-kernel-version.tgz /lib/modules /lib/firmware
- copy your kernel-WiFi-patched-kernel-version.tgz in /
- run:
cd /
rm -rf /lib/modules
rm -rf /lib/firmware
tar -xzvpf kernel-WiFi-patched-kernel-version.tgz
/sbin/depmod -a kernel-version

- reboot your Pi and you should be good
- in all the above instructions you should make sure that you have the same kernel-version on both Raspbian & Slack ARM
and check it with uname -a. In the instructions substitute kernel-version with the output from uname -a - for example 4.9.28-v7+

If you're not familiar with dd and backing up your SDCard under Linux, then you can go for the Windows solution - works well!
https://sourceforge.net/projects/win32diskimager/

Have fun!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
Why my wireless card "atheros" run only as an acces point in "Master" mode. jardiamj Linux - Wireless Networking 3 11-11-2007 01:12 AM
iwconfig mode monitor Error: "Set Mode" (8B06) WOP1337 Linux - Wireless Networking 2 04-03-2007 09:13 AM
ADSL Problems: "cannot enable interface ppp0" funkymunky Linux - Networking 3 05-24-2005 07:19 AM
How to enable "laptop mode" on 2.6.5 Slackware 9.1 ming0 Linux - Laptop and Netbook 0 06-06-2004 03:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration