LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 09-10-2023, 06:34 AM   #1
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 879

Rep: Reputation: 120Reputation: 120
current 08/09/23 will not reboot after install


Last October I successfully installed aarch64 current on a RockPro64 and a PineBookPro purchased in last September. I never did much with the PBP as I couldn't get sound to work but today a had a go at installing aarch64 current as of 08/09/23. No problem installing but I could not get the PBP to boot after exiting setup and rebooting. The two images below indicate the problem though I'm a bit too thick to understand why this was happening. My first thought was bad SD card so I tried with another SD card and then another but the same errors on reboot. Out of curiosity I put the RockPro64 SD card in the PBP and it booted up.

OK, so I used dd to copy the RP64 SD card to one of those other SD cards then copied the contents of /boot from the current (6.1.52-armV8) to that SD card from last October's RP64 install. The PBP booted up just fine but when I ran reboot I had the same errors as before. I tried a couple more times and if I close with the shutdown command I can then boot without errors on the PBP but if I use the reboot command I will get those errors and fail to boot.
Attached Thumbnails
Click image for larger version

Name:	error-01.jpg
Views:	19
Size:	183.5 KB
ID:	41608   Click image for larger version

Name:	error-02.jpg
Views:	17
Size:	147.9 KB
ID:	41609  
 
Old 09-10-2023, 11:35 PM   #2
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,906

Rep: Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059
I see the same behavior on a very recent hardware revision of the Pinebook Pro. I received a new unit a few weeks ago. It doesn't reboot error free and cannot find my storage. If I shut down completely and turn it back on with the power button it boots fine.

I have a Kingston A2000 NVMe that was in my previous Pinebook Pro hardware revision. Same NVMe ribbon adapter from Pine64. I also use decent SD cards, varying between SanDisk, Kingston, and Gigastone. It could be a configuration in U-boot that needs to be tweaked.
 
1 members found this post helpful.
Old 09-11-2023, 12:57 AM   #3
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 879

Original Poster
Rep: Reputation: 120Reputation: 120
I've installed onto a Kingston SNVS500G. Yeah shutdown -h and boot is OK. No problemo ... but for an install, if one exits setup and does a reboot they might (like me) think it was a bad install or sd card. Getting sound was my major reason to try Sept current. I haven't figured out sound yet and I have lost my ability to use my bluetooth mouse which previously worked in my install last October. Still some things to sort out methinks.
 
Old 09-11-2023, 07:38 AM   #4
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,906

Rep: Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059
Sound needs to be enabled by executing alsamixer as your normal user. Make sure your user is in the audio group.

Code:
F6: Select Sound Card (Analog) --> F3: Playback --> Right Arrow all the way over --> Hit "M" on all four "Headphone Mixer" settings
The speakers on the Pinebook Pro should work now without any changes. The headphones on the Pinebook Pro and RockPro need to be unmuted (same menu as "Headphone Mixer"). That should get you a working headphone jack on both. Sound is sketchy and you may need to turn the volume down a bit to eliminate static noise. The HDMI connection seems to produce better audio and should be adjusted with the audio controls on your monitor. Once you unmute the "Headphone Mixer" setting, the volume controls in KDE and XFCE should work as normal.

Last edited by mralk3; 09-11-2023 at 07:38 AM. Reason: added analog notation
 
1 members found this post helpful.
Old 09-11-2023, 04:15 PM   #5
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 879

Original Poster
Rep: Reputation: 120Reputation: 120
It seems that you have more options presented in the cli alsamixer than I do. Are you using aarch64 vanilla pulse and alsa?

F6 no, choice set to default, default:0 rockchip,es8316-codec
F3 Playback, Nothing there but Master, no Playback
Nothing for Headphone Mixer settings
 
Old 09-11-2023, 06:20 PM   #6
glorsplitz
Senior Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 1,353

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
F6 default:0 rockchip,es8316-codec, did you select that?

I'm presented with more than I know what to do with, YMMV, right now for me
first slider Headphone is 100
Headphone Mixer is 0
Speaker is On
slide to the right
DAC 25
slide to the right
DAC Soft Ramp Rate 20, this also adjust volume level
slide to the right
Left Headphone Mixer LLIN
Left Headphone Mixer Left DAC
Right Headphone Mixer RLIN
Right Headphone Mixer Right DAC
all these are on, using M on keyboard

everything else is 0 on slider or off
 
Old 09-11-2023, 06:48 PM   #7
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,906

Rep: Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059
Quote:
Left Headphone Mixer LLIN
Left Headphone Mixer Left DAC
Right Headphone Mixer RLIN
Right Headphone Mixer Right DAC
Those are the settings that need to be enabled. Use the "M" key to unmute or mute them. The headphone mixer bar needs to be raised up too if it is at 0.

I think this configuration can be saved with:
Code:
alsactl store <device>
I last checked this out at the beginning of the Aarch64 port. Alsamixer is just a front end and works with pulse audio. I use it because its faster than trying to figure out the kde or xfce specific sound settings.
 
Old 09-12-2023, 05:14 PM   #8
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 879

Original Poster
Rep: Reputation: 120Reputation: 120
I've just returned to this ... when I change settings in alsamixer they are not persistent. For example, I can set the sound card to 'rockchip, es8316-codec' which gives me the full range of settings options but after closing and re-opening I am back to 'default' and only an option named Master is presented. Neither my aarch64 or slackware64 system has the command 'alsactl'.
 
Old 09-12-2023, 06:28 PM   #9
glorsplitz
Senior Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 1,353

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
Quote:
# which alsactl
/usr/sbin/alsactl
this will save what you set when you select 'rockchip, es8316-codec' and will carry over rebooting, rockpro64 also
Quote:
# /usr/sbin/alsactl store
# ls -la /var/lib/alsa/asound.state
-rw-r--r-- 1 root root 6816 Apr 6 21:20 /var/lib/alsa/asound.state
Quote:
re-opening I am back to 'default' and only an option named Master
it always does that, just switch to 'rockchip, es8316-codec' if you want to change something, then alsactl store as #
 
Old 09-13-2023, 04:06 AM   #10
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,906

Rep: Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059
Quote:
Originally Posted by glorsplitz View Post
this will save what you set when you select 'rockchip, es8316-codec' and will carry over rebooting, rockpro64 also




it always does that, just switch to 'rockchip, es8316-codec' if you want to change something, then alsactl store as #
Exactly! The pulse audio (pavucontrol) utility or the Kmix utility (kde) work fine, once you adjust the settings in alsamixer, and save them with alsactl. It is a minor annoyance on every fresh install.
 
Old 09-13-2023, 04:08 AM   #11
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,906

Rep: Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059
Quote:
Originally Posted by justwantin View Post
Neither my aarch64 or slackware64 system has the command 'alsactl'.
You have to log in as root to use the alsactl command.
 
Old 09-14-2023, 03:44 PM   #12
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 879

Original Poster
Rep: Reputation: 120Reputation: 120
Yeah ... sound is working ... seems it alsa wouldn't restore asound.state settings at boot so I restore the settings withe good ole' rc.local with the command '/usr/sbin/alsactl restore'. Now to get rid of the background noise and popping.

Last edited by justwantin; 09-14-2023 at 03:45 PM. Reason: tyop
 
Old 09-14-2023, 10:25 PM   #13
mralk3
Slackware Contributor
 
Registered: May 2015
Distribution: Slackware
Posts: 1,906

Rep: Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059Reputation: 1059
Unfortunately the crackling and popping are always present if you turn your volume up higher than about 70% on either the RockPro64 or the Pinebook Pro. The speakers do the job, but aren't that clear. I use headphones without too much issue. It may be a hardware limitation or possibly another configuration in alsamixer that needs to be tweaked. The sound via HDMI on the RockPro64 is excellent with the speakers on my monitor.
 
Old 09-15-2023, 03:27 PM   #14
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 879

Original Poster
Rep: Reputation: 120Reputation: 120
@mralk3 ... thanks for help and info on sound out of RockPro64 ...I haven't done much with mine yet but've been thinking of setting it up in my shop for music and searches. Now incentisized I'll have to start saving up my lunch money for a small monitor and an IR keyboard. Cheers
@glorsplitz .... thanks for the help
Cheers

Last edited by justwantin; 09-15-2023 at 03:28 PM. Reason: tyop
 
1 members found this post helpful.
Old 09-17-2023, 09:01 AM   #15
BGB
Member
 
Registered: Jan 2021
Distribution: Slackware
Posts: 34

Rep: Reputation: Disabled
scratchy sound (fix from x86 version)

FWIW, I had noise on a recent x86 install that I finally beat after weeks of annoyance. See if 'speech dispatcher' is on your pavucontrol interface. If so edit /etc/speech-dispatcher/speechd.conf

and uncomment DisableAutoSpawn

(assuming you don't need it)

May not make a difference, but given how long it took me to find this, I think it is worth noting.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware-current need a double reboot command to really reboot the system sardinha Slackware 11 09-12-2012 03:19 PM
reboot freezes after yast update run, reboot for kernel update sparkbot Linux - Software 2 11-15-2006 06:34 PM
FC4 hangs after reboot. Is it possible to manually reboot to find problem hathmann Fedora 5 08-13-2006 03:57 AM
No keyboard/mouse after reboot. Requires second reboot to work. rottie Linux - Hardware 6 01-16-2006 05:04 AM
Blank screen after "startx" after reboot after install cg from nvidia rozky Linux - Software 2 04-04-2005 08:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 02:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration