LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 10-08-2014, 03:51 PM   #1
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 30

Rep: Reputation: Disabled
A10-OLinuXino-Lime and rootfs on HDD


Hi all
I bought an A10-OLinuXino-Lime and installed SlackwareArm 14.1 following this link.
All went well but now I would like to have the rootfs on a SATA drive, instead of the SD card.
First of all I recompiled the kernel, to have sw_ahci_platform static, and not as a module. The HDD is correctly recognized at boot and I can mount its partitions without problems.
After that I tried to follow the steps from here but, when I reboot the board, something goes wrong and the boot process does not start, or so I suppose because I have not yet a connection to the debug serial port available.
Has anybody had success with such a challenge? Do you have any suggestion?

Thanks
 
Old 10-09-2014, 09:45 AM   #2
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 487
Blog Entries: 13

Rep: Reputation: 47
Have you had a go with any of the links on slackware docs
These might be intresting
  • Community OLinuXino A10 Lime
  • Community OLinuXino A10S Micro
  • Community XZPAD700 (works on most Axx-based boards)
My Axx devices all boot from uSD so I've no direct experience on booting off the sata drive with Allwinner SOC ... I suppose you could get the most reliable information from linux sunxi.
 
Old 10-09-2014, 09:55 AM   #3
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 487
Blog Entries: 13

Rep: Reputation: 47
This should be an intresting read: Boot_Process
In particula the section concerning other devices that states:
Quote:
That's also possible to boot system on other devices (SATA, USB, network using TFTP/NFS,...) but U-boot standing on NAND or SD card is needed as first boot step.
 
Old 10-09-2014, 11:05 AM   #4
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 30

Original Poster
Rep: Reputation: Disabled
Thank you louigi600
I already read and followed the instructions found at the links you provided.
In fact I have an A10 OLinuXino Lime running slackwarearm from the microSD card.
I think I have to investigate the messages from U-boot in order to check what's wrong with the uEnv.txt in the mmcblk0p1, as per this link.

Bye
 
Old 10-10-2014, 01:37 AM   #5
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 487
Blog Entries: 13

Rep: Reputation: 47
If you don't have the serial adapter you might like to load kernel and initrd from the SD and then have that mount the root on SATA drive.
If that fails too at least you can have a shell prompt to figure out what went wrong.
 
Old 10-10-2014, 02:47 AM   #6
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 30

Original Poster
Rep: Reputation: Disabled
Thanks lougi600
I'm waiting for a serial adapter and then I will test.
 
Old 10-10-2014, 02:35 PM   #7
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 30

Original Poster
Rep: Reputation: Disabled
OK, fixed
looking at the boot messages on the debug serial, I found the system was complaining about the root file system not mounted read-only and then waiting for a ENTER press via the debug port.
I modified the uEnv.txt adding the option ro after the root=/dev/sda2 and now I have the A10 running the rootfs on HDD.

Thanks louigi600
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Olimex OLinuXino and SlackwareARM andrixnet Slackware - ARM 7 03-24-2014 04:50 AM
LXer: Create a Mini PC or Server with Olimex's Olinuxino A13/A13Micro LXer Syndicated Linux News 0 12-30-2013 05:00 PM
LXer: Run ChromeOS with a Hint of Lime: ChromiumOS Lime Builds (Finally) Available LXer Syndicated Linux News 0 12-07-2011 08:30 AM
Lime WIre Kylesun Linux - Software 12 07-05-2004 02:54 AM
Lime wire iainvt Linux - Software 3 05-10-2004 10:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 12:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration