-   Slackware (
-   -   ZAxisMapping under Slackware 10.0 doesn't work (

KingofBLASH 09-09-2004 02:42 PM

ZAxisMapping under Slackware 10.0 doesn't work
I have tried using the line:

Option "ZAxisMapping" "4 5"
and then I tried
Option "ZAxisMapping" "Y"
(but never at the same time)

in the Section "InputDevice" of the following config files:

Currently I put those lines in all three, yet my scroll wheel still doesn't work. According to the log in /var/log/Xorg.0.log it's using the config file "/etc/X11/xorg.conf"

Anybody know how to get my scroll wheel working?

Also, anybody know how to change the screen resolution? I used xorgsetup to set up my card automatically, and all of a sudden I'm using 1600x1200 resolution versus my comfortable 1280x1024

Jaster150 09-09-2004 02:46 PM

you have a 7 button mouse I assume? that is, wheel and 2 side buttons. If so, add change your xorg.conf to read:

Option "Buttons" "7"
Option "ZAxisMapping "6 7"

save, restart x and you should be good. If not, in command line run xmodmap -e "pointer = 1 2 3 6 7 4 5"

to get the side buttons to work I use imwheel, I don't have the site offhand but you can google it. Check this forum for how to set that up.

kodon 09-09-2004 02:48 PM

make sure you are using the correct protocol

Jaster150 09-09-2004 02:49 PM


Originally posted by kodon
make sure you are using the correct protocol
Good point. I use an intellimouse explorer but I find that "ImPS/2" and "ExplorerPS/2" don't work too well for me so I just use "auto" and it works fine.

folkenfanel 09-09-2004 03:06 PM

change resolution

You can also modify the resolution manually by messing up with the config file:

in the section "screen" you should see (basically) resolutions for different color depths (e.g. for 8, 16, 24...). There you have to look for the depth you use, and delete the ugly part ("1600x1200"). The first one in the line is the "standard" one for that color depth so you can also put 1024x768 first and it will run first.


you can always run xorgconfig and modify it interactively (but i'm not sure whether after that you will need to reconfigure your mouse).

Dswissmiss 09-21-2004 09:17 PM

Has this been solved yet? I just switched back from gentoo, and I can't get my wheel to work either. I used to use IMPS/2, /dev/psaux, and ZAxisMapping 4 5 to get it to work.

any ideas?

gbonvehi 09-21-2004 09:29 PM

Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

That works for me (Microsoft 1.1a).
Read for a similar thread some days ago about a logitech mx mouse where he had 7 buttons.

Dswissmiss 09-21-2004 10:01 PM

Hey cool!
Thanx a lot

All times are GMT -5. The time now is 08:29 PM.