-   Slackware (
-   -   Yet another scrollwheel thread (

Seiken 01-14-2013 12:48 PM

Yet another scrollwheel thread
Running Slackware 14 in VirtualBox under Windows 7. Because of past issues, I am very familiar with needing ZAxisMapping setup in xorg.conf, so that is already done.

In VMs for Fedora (using KDE) and Mint (XFCE), the scrollwheel works fine, but in Slackware (using Fluxbox), my scrollwheel doesn't work. I've tried looking at the xorg.conf files from Fedora and Mint to compare (and see what they're doing to get the scrollwheel to work), but it seems they aren't using xorg.conf for this.

The mouse is a Microsoft USB optical mouse with no bells & whistles. No extra buttons aside from the scrollwheel. I have tried "auto" and "IMPS2", but both have the same results. Is there something else I'm missing? I haven't used Slackware since around version 11.


tronayne 01-14-2013 03:16 PM

I've never had any problem with a MS mouse (the only thing that blasted company makes that actually works, eh?) scrollwheel optical mouse, no matter what window manager I'm using (presently Xfce) through a number of Slackware versions.

During setup, I tell the GPM section that it's IMPS2 and, subsequently, it "just works." The relevant entries in /etc/rc.d/rc.gpm look like this:

# Start/stop/restart the GPM mouse server:

if [ "$1" = "stop" ]; then
  echo "Stopping gpm..."
  /usr/sbin/gpm -k
elif [ "$1" = "restart" ]; then
  echo "Restarting gpm..."
  /usr/sbin/gpm -k
  sleep 1
  /usr/sbin/gpm -m /dev/mouse -t imps2
else # assume $1 = start:
  echo "Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t imps2"
  /usr/sbin/gpm -m /dev/mouse -t imps2

I should note that since Slackware 12 (or so, might be 13.37, I don't remember), you don't need to run xorgsetup (there is no xorg.conf file in /etc/X11). X more or less self-configures. If you have an xorg.conf might be worth a try to move it to xorg.conf.bak, edit /etc/rc.d/rc.gpm as above and see what happens?

By the way, the mouse in Win7 in VirtualBox works just fine, too.

Hope this helps some.

dugan 01-14-2013 03:39 PM

If you're not using the proprietary binary NVidia or ATI drivers, then try removing xorg.conf entirely.

If you are, try removing from your xorg.conf all references to InputDevices. See here:

Woodsman 01-14-2013 08:46 PM

Does grep EE /var/log/Xorg.0.log reveal anything?

Erik_FL 01-15-2013 12:01 AM

If you don't find anything else that helps, here is another suggestion. I had problems with other versions of Slackware getting scroll wheels or side buttons to work due to a problem with the order that modules are loaded. The problem was only on a couple of laptops. The solution was to reload the "psmouse" module in "/etc/rc.d/rc.local".


if [[ -n "$(lsmod | cut -f 1 -d " " | grep psmouse)" ]] ; then
        echo "Found psmouse module"
        echo "Reloading psmouse module so that side mouse buttons will work"
        /sbin/rmmod psmouse
        /sbin/insmod /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko

Put the commands at the very end of "rc.local" after all the VirtualBox modules have been loaded and any other modules associated with pointing devices.

You can test this manually by unloading and reloading the "psmouse" module from a shell prompt. If that solves your problem then adding the commands to "rc.local" should work.

Seiken 01-15-2013 12:27 PM

Thanks for all the replies, everyone. Here are the results:

I am not using Nvidia or ATI drivers (since I'm running Slackware in VirtualBox), so I renamed xorg.conf to xorg.conf-bak. The scrollwheel still did not work after this (restarted X, and also rebooted system completely).

My /etc/rc.d/rc.gpm file already looks exactly the same as the one posted by tronayne.

I also took Erik_FL's suggestion and added the psmouse info to /etc/rc.d/rc.local, but this also did not get the scrollwheel to work.

Since the other distros were using different WMs, I decided to try KDE and Xfce in Slackware to rule out a Fluxbox config issue, but the wheel still doesn't work on them either.

Here is what "grep EE /var/log/Xorg.0.log" is showing:
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 213.645] (II) Loading extension MIT-SCREEN-SAVER
[ 213.674] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
[ 213.682] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 214.514] (II) XINPUT: Adding extended input device "VirtualBox USB Tablet" (type: TOUCHSCREEN, id 8)

tronayne 01-15-2013 12:56 PM

Have you installed the guest additions in the Slackware virtual machine?

Have you tried right-click on the USB icon at the bottom right 0f the screen and is the Microsoft 3-button mouse highlighted?

Seiken 01-15-2013 01:23 PM


Originally Posted by tronayne (Post 4870716)
Have you installed the guest additions in the Slackware virtual machine?

That was it! Thank you very much :) All is working now.

All times are GMT -5. The time now is 01:45 PM.