LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-19-2005, 10:04 PM   #1
legit
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
xwindows wont start


hey all,
so i finally got slackware installed, im incredibly excited as i've wanted to use this distro for a long time, however i ran into a small problem.
so i can log in as root but when i type:
startx
i encounter problems, first i see the text loading stuff, then i see a quick flash of the screen under xwindows and then my monitor goes blank and turns off.
I have an nvidia fx5200 installed but that doesn't seem to be the problem, im wondering if maybe when i chose the screen resolution and number of colors during installation maybe i chose a size that wouldn't work or something, other than that i have no clue. Any help would be appreciated, thanks,
- legit
btw, the computer still stays on its just the monitor that turns off.
 
Old 12-19-2005, 10:08 PM   #2
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,299

Rep: Reputation: 89
Check your xorg.conf file. It could be resolution, frequencies, and/or video driver.

Without you posting specifics, that's as good as it gets.
 
Old 12-19-2005, 10:44 PM   #3
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
also, make a user and don't log in as root
 
Old 12-20-2005, 04:09 AM   #4
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
I have an nvidia fx5200 installed but that doesn't seem to be the problem
this is the problem, nvidia driver yu have to install it first and if needed edit the xorg.conf file.

go to nvidias site, it is a good script it will even edit the /etc/X11/xorg.conf file (i have the thing but it is 11 mb, its name is NVIDIA-Linux-x86-1.0-8174-pkg1.run )and get the file it is an installer (*.run file) they r also giving a help file.
before runing u need the kernel source to installed in ur machine
(it wil b there in ur /usr/src/)

when u run the installer (#sh installer.run i think)from the root
it wil edit the conf file, so need to worry after that u can c ur X
 
Old 12-20-2005, 04:21 AM   #5
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
i managed to get the link now http://download.nvidia.com/XFree86/L...-8174-pkg1.run

what u want to do is
#wget -c http://download.nvidia.com/...(copy paste above link hi :^))
$cd /to/the/directory/where it is downloaded
# sh NVIDIA-Linux-x86-1.0-8174-pkg#.run

it will ask for editng the conf file press ok

this part is editing xorg.conf by hand if needed only from their site.(it will automatically edit xorg.conf file if not u do this.)
-------------------
If you have a working X config file for a different driver (such as the “nv” or “vesa” driver), then simply edit the file as follows.

Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the Module section of the file, add the line (if it does not already exist):

Load "glx"
------------------

i think after this only u could even use alsaconf ok
best of luck and regards

Last edited by rkrishna; 12-20-2005 at 04:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't start xwindows ust Linux - General 3 01-17-2005 09:05 AM
xwindows wont boot crealkiller175 Slackware - Installation 7 02-21-2004 08:02 AM
can't start xwindows ust Linux - Software 6 10-27-2003 08:16 PM
XWindows won't start !! netkepala Linux - Networking 5 08-31-2003 05:01 AM
start xwindows lakshman Linux - General 3 10-15-2002 11:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration