LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-18-2004, 07:00 PM   #1
greygoose80
LQ Newbie
 
Registered: Dec 2004
Location: St.louis
Distribution: Slackware 10
Posts: 25

Rep: Reputation: 15
Xwindows selection at boot


How can I boot (by default) into the XWindows selection.
Where its got the sunflower and "session" button at the bottom that allows me to boot into different window managers?

I use XCFE, GNOME and KDE for different reasons and switch between them alot, but have to change them to default when I want to boot them.
 
Old 12-18-2004, 07:08 PM   #2
atlesn
Member
 
Registered: Oct 2003
Location: Oslo, Norway
Distribution: RedHat 9.0, Fedora Core 1/2/3, Debian 3.0, Smoothwall
Posts: 110

Rep: Reputation: 15
Which desktop-manager are you using? kdm, xdm, gdm?
 
Old 12-18-2004, 10:58 PM   #3
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware 14.2
Posts: 1,267

Rep: Reputation: 56
edit /etc/inittab to change runlevel from 3 to 4

Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
 
Old 12-19-2004, 09:00 AM   #4
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 31
The sunflower is gdm, which rc.4 will launch first by default. Just change the runlevel to 4 in /etc/inittab. If you've got gnome installed, gdm will be there.

Code:
# Default runlevel. (Do not set to 0 or 6)
# id:3:initdefault:
id:4:initdefault:
Should be right up at the top. I commented the rl3 rather than changing it to 4 for some reason that I can't remember. I do, however, set the default RL to 3 every time I update the kernel, so maybe that's why.


And yes, I personally prefer gdm, even though I use kde mostly. It just looks better, and I prefer the way it handles logins.
 
Old 12-19-2004, 12:22 PM   #5
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware 14.2
Posts: 1,267

Rep: Reputation: 56
wish i had thought of that
 
Old 01-06-2005, 06:25 PM   #6
Ariel A.
LQ Newbie
 
Registered: Jan 2005
Location: Corrientes, Argentina
Distribution: Debian & Arch
Posts: 7

Rep: Reputation: 0
well. I had the same problem with slackware 10, but after switching run level 4 as default I couldn't enable tty1, tty 2,etc; except tty 7 (the GUI),
does anyone find the solution for this problem?
thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub or lilo bootloader selection during boot pcandpc Linux - Newbie 7 05-25-2005 04:38 PM
boot selection spidna Slackware 2 08-31-2004 07:36 PM
xwindows wont boot crealkiller175 Slackware - Installation 7 02-21-2004 07:02 AM
promise IDE controller boot disk selection Clansman Linux - Hardware 6 02-07-2004 03:28 PM
deleting os selection on dual boot In2Fords Linux - Newbie 4 12-22-2003 06:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration