LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-02-2018, 02:52 AM   #1
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 184

Rep: Reputation: 8
Xscreensaver stopped working and won't build


After the latest round of updates for Slack64-current I noticed that Xscreensaver stopped working. I tried to rebuild it but get the error -

ximage-loader.c:43:12: fatal error: 'gdk-pixbuf/gdk-pixbuf-xlib.h' file not found

I'm running Plasma 5 too with Eric's 24.10.18 build (haven't seen a Nov. build yet). Anyone else have this problem or a fix??

Note: I didn't post this to the SlackBuilds not building thread because this is not a fresh, new install of Slack64-current.


Edit: My bad. Back when graphite2 was added to -current, slackpkg wouldn't install it and I had forgotten to go back and build it. Just did that and it Xscreensaver works now.

Last edited by 3rensho; 12-02-2018 at 04:42 AM.
 
Old 12-04-2018, 03:53 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,555

Rep: Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997
Good work. I'm hoping to update ~Current (July 2018) to ~Current (Now). Please report back if the entire thing works for you there. I had it some time back, but Mesa was 17.11 or somesuch and everything X seemed to be compiled against Mesa-11.x so everything puked and I ran back to my 14.2 backup with my tail between my legs :-(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Linux 4.4 seems to refuse to build IPv6 for the 64-bit build - 32-bit build works fine GameCodingNinja Linux From Scratch 2 02-07-2016 07:40 PM
Three Mobile Broadband was configured and working but it has now stopped working and Tinabarma Linux - Newbie 0 10-20-2008 08:36 AM
LXer: Build 'em Right, Build 'em Strong, Build 'em Linux LXer Syndicated Linux News 0 10-01-2007 10:51 PM
Xscreensaver not using .xscreensaver psychobyte Fedora 4 04-07-2006 11:02 AM
xscreensaver installed, but no xscreensaver-demo command? dalesan Linux - Software 7 09-01-2004 02:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration