-   Slackware (
-   -   xsane/sane crashes ksmserver? (

JamesGT 02-11-2010 10:58 PM

xsane/sane crashes ksmserver?
I finally got around to connecting my Umax Powerlook 2100XL SCSI scanner to my PC with Slackware64, v13. It doesn't want to scan.

When I boot up, it finds the scanner and when I run "sane-find-scanner" it detects it properly.

found SCSI scanner "UMAX PowerLook 2100XL V1.4" at /dev/sg0

When I run xsane, or scanlite, I get the same issue. I try to preview, or just scan, and it initializes the scanner and just when it's ready to preview or scan the screen goes black and I get..."could not start ksmserver" followed by an Okay button.

Once I click ok, I'm kicked out of KDE.

Searching on similar issues, people in Ubuntu had a similar issue and had to install debian packages and it was fixed. They installed extra packages for xsane and sane like "sane-utils" and "libsane-extras" but I can't seem to find those anywhere for Slackware, but I think they are just included with sane.

Any ideas?

JamesGT 02-12-2010 10:17 PM

I tried a different window manager, but it just crashes the program and leaves xfce still running.

The scanner works fine in Windows with the OEM software from Umax.

JamesGT 02-12-2010 10:30 PM

I tried running "scanimage" from command line, and the scanner goes through the same procedure, then scanimage gives an "out of memory" error.

Checking free, I don't see how...

total used free shared buffers cached
Mem: 3083676 1348268 1735408 0 153176 403304
-/+ buffers/cache: 791788 2291888
Swap: 8193140 0 8193140


JamesGT 06-27-2010 11:46 PM

I finally got around to making this work. Apparently in the umax.conf file in /etc/sane.d the following lines are commented out.

option scsi-buffer-size-min 65536
option scsi-buffer-size-max 131072

For sane/xsane to work with my Umax PowerLook 2100XL SCSI scanner, they have to be there.

All times are GMT -5. The time now is 06:03 PM.