-   Slackware (
-   -   xrandr reports HDMI1 being disconnected when it's connected (

flokofcgulls 10-03-2013 08:59 PM

xrandr reports HDMI1 being disconnected when it's connected
My main desktop died recently, so my laptop running Slackware 64 14.0 multilib is now my only option to work on. I'm trying to setup a pseudo-docking station at my desk, and everything is working except hooking it up to my 27" LED monitor.

This is my first experience with multi-monitor support in Linux, so I started by running xrandr and get the following output:


Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
  1920x1080      60.0*+  40.0 
  1400x1050      60.0 
  1280x1024      60.0 
  1280x960      60.0 
  1024x768      60.0 
  800x600        60.3    56.2 
  640x480        59.9 
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

It seems that when I plug in the monitor via HDMI, it just doesn't see it there at all. When I first plug it in, I see the power light change colors on the monitor, so there's some kind of activity there. I also booted over to my Windows partition just for testing, and it works just fine, so that rules out any hardware problems. I have a brand new Monster HDMI cable on it as well.

I tried searching around the forums, and the web at large, but couldn't find anyone describing this issue. Seems like most people can get the display to detect automatically, and all the posts I found about it were dealing with sound and not video.

If anyone could shed some light on this, it would be greatly appreciated!

*EDIT* I forgot to mention one other detail last night. I have also tried the Fn-F1 key combination to switch between displays, but the key doesn't do anything. All my other Fn key combinations are working, and I see the dell_laptop and dell_wmi modules loaded.

flokofcgulls 10-04-2013 10:33 AM

OK, I figured out what was going on.

The problem was caused by my Optimus/Bumblebee setup. I finally stumbled across this wiki article explaining the issue.

To fix it, I had to completely remove all the bumblebee packages (they were all marked with bbsb to make it easy), remove the nouveau-blacklist package, then reinstall mesa and mesa-compat32. After a reboot, my HDMI was working automatically, and immediately on starting X.

It seems a choice must be made between nVidia binary blob performance, or HDMI support. Since I think the blame for this problem falls on nVidia for not releasing proper documentation for their hardware, I'm reverting to the nouveau driver. We'll show them! ;)

tilosag 12-15-2013 06:35 AM

I have Asus U36JC with GeForce 310M and I was struggling with a proper HDMI1 configuration for past 2 days. xrandr reported HDMI1 not connected at all times.

Solution for people who prefer to follow pareto rule:
  1. Have your monitor connected to HDMI1.
  2. Code:

  3. Code:

    apt-get purge bumblebee*
  4. Code:

    apt-get purge nvidia*
  5. Go to
  6. Pick a proper driver for linux.
  7. Download it.
  8. Shutdown X so you work in terminal only now. You can do it by just logging off in Xfce or by booting in rescue mode (I guess).
  9. Code:

    chmod +x
  10. Code:

  11. Code:

  12. and Xfce welcomes me on HDMI1 screen asking which one to pick as main display (or have a clone).

and now you have:

xxx@x:~$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 8192 x 8192
VGA-0 connected primary (normal left inverted right x axis y axis)
  640x480        59.9 +
  320x240        60.1 
HDMI-0 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
  1920x1200      60.0*+
  1920x1080      60.0    59.9    50.0    24.0    60.1    60.0    50.0 
  1600x1200      60.0 
  1280x1024      75.0    60.0 
  1280x720      60.0    59.9    50.0 
  1152x864      75.0 
  1024x768      75.0    60.0 
  800x600        75.0    60.3 
  720x576        50.0    50.1 
  720x480        59.9    60.1 
  640x480        75.0    59.9    59.9

All times are GMT -5. The time now is 10:55 PM.