-   Slackware (
-   -   xrandr problem (

jmpz 12-09-2012 02:08 PM

xrandr problem
Hi, all,

I use a laptop with slackware (the version now I use is 14) for a long time but there is an issue I never figure out.

When I connect the laptop with a VGA monitor, I use xrandr to set up the displays.

First, I close the monitor on the laptop:

xrandr --output LVDS1 --off
Then, I set up the VGA monitor:

xrandr --output VGA1 --mode 1280x1024
Finally, I keep this setting till I shutdown the computer, which means I shutdown the computer using the VGA monitor.

Then, if you reboot the laptop using the laptop monitor only, everything is OK until the screen resolution is changing (I don't know whether this description is enough or not). The screen will turn into total black. However, the boot process is still running.

My temporary solution is that: instead of booting slackware, I boot into windows first. Once I get the login interface of windows, I reboot the laptop and choose slackware in lilo. Then the problem can be fixed.

Is there a direct solution or setting for this problem?

I didn't have this problem in the same laptop on debian. So I think it may be related with slackware. Any ideas?


camorri 12-11-2012 11:00 AM

I did some testing with my HP netbook and an external monitor, Slack 14 32 bit system.

I can turn on the external monitor with

xrandr --output VGA1 --mode 1024x768
without problems.

I can then turn off the netbook display with

xrandr --output LVDS1 --off
. So far so good.

I shutdown the netbook through the gui, I run XFCE. I booted, with the external monitor connected. I see what you describe, the messages from the lilo boot screen to the first mode change appear only on the internal monitor. Once the modes set happens, ( font size changes ), I see the rest of the boot messages on both screens. The KDM screen shows up, I can log in. ( Still visible on both monitors), I log in, both monitors show the desktop. I can turn off the netbook monitor, either by the command line, or through the 'Display' app in the Settings menu.

What is a little strange, ( at least to me ) is the internal monitor is not in the correct mode. It normally runs in 1024x600 ( a 16x9 format ) and the external ( a 4x3 format ) is 1024x768. The bottom 1/3'rd of the screen is cut off on the internal monitor.

Now, if I try to turn the internal monitor back on, either with xrandr, or the Display app, I can not turn in on.

If I run shutdown, both work on reboot. I did get into a situation, once where I had both external and internal blank. I have not figured out how I did that though. I ssh'ed into the netbook, and ran shutdown.

So, in summary, it appears if both monitors are attached, on boot, the mode is picked for the external monitor. Don't know if you have another system to ssh to your system, if you do, that may be another way to gain control.

Not sure if the fact I can not turn the internal back on is a bug or not.

Hope this sheds a little light...

jmpz 12-11-2012 02:57 PM

Thanks for your reply. However, I notice that you reboot your laptop with the external monitor connected:


Originally Posted by camorri (Post 4847054)
I shutdown the netbook through the gui, I run XFCE. I booted, with the external monitor connected.

Could you do another experiment that you reboot you laptop without the external monitor? (all the previous steps are same as you did in the last experiment)

If after rebooting your laptop monitor turns off when the font size is changing, I think you may face the same situation as I have.

Also, what's your display card? Mine is Intel 945 mobile (I think).

camorri 12-11-2012 05:17 PM

No problem. First of all, the VGA controller.


00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (prog-if 00 [VGA controller])
Subsystem: Hewlett-Packard Company Device 3660
Flags: bus master, fast devsel, latency 0, IRQ 45
Memory at 58180000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 60c0 [size=8]
Memory at 40000000 (32-bit, prefetchable) [size=256M]
Memory at 58000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Kernel driver in use: i915
Kernel modules: i915
I'll run the test and post again.

camorri 12-11-2012 05:28 PM

I booted the system, connected the external monitor, ran the 2 xrandar commands as before; and shutdown with the external monitor running. Once shut down, disconnected he external monitor; and booted.

All was normal. The netbook monitor came up it 1024 x 600, as it should.

jmpz 12-11-2012 05:51 PM

Thanks a lot! It seems you don't face my problem.

Do you know what are the possible issues there? It troubles me much.


camorri 12-11-2012 07:27 PM


Do you know what are the possible issues there?
Sorry, no. You do have different video hardware, so there is a possibility it is hardware, or BIOS related. You could look to see if there are any BIOS updates for your system.

Once you power down, nothing should be left in memory or hardware registers that is not reset. So, it is a mystery why your system boots with some in-useable video mode, that you can reset with a windoze boot.

Can you switch back to the system monitor after having the external monitor on? This is the one thing that does not work for me.

allend 12-13-2012 06:45 AM

My netbook has a LVDS with a native resolution of 1024x600. The output from '/sbin/lspci' shows

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
I include a 'video=1024x600' option in the append line in my /etc/lilo.conf. I have not seen any problems with video on reboot after using an external monitor.

append = " vt.default_utf8=1 resume=/dev/sda6 video=1024x600"
To use the external monitor I generally use

xrandr --output LVDS1 --auto --output VGA1 --auto --left-of LVDS1
To turn off the external monitor I use

xrandr --output VGA1 --off; xrandr --fb 1024x600
I recently posted about patching xorg-server for use with the scale and panning options to xrandr here.

All times are GMT -5. The time now is 06:45 PM.