-   Slackware (
-   -   Xorg-server update causes buggy mouse operations (

w1k0 07-02-2008 03:32 PM

Xorg-server update causes buggy mouse operations
*** The problem solved by shadowsnipes and Hangdog42 ***

Yesterday I updated my Slackware's 12.1 xorg-server, xorg-server-xvfb, and xorg-server-xnest from the version to the version 1.4.2. Then I noticed the TrackPoint and left mouse button in my ThinkPad T41 started to work improperly.

When I tried to scroll the content in Firefox window up or down the mouse cursor moved slowly until the lower or the upper edge of the application window. When it reached the edge of the window it stopped to scroll the content so I needed to move back the cursor up or down and to continue the scrolling until the cursor reached the edge of the window and so on. (In the normal situation mouse cursor should stay in place while scrolling the content of the window.)

Moreover when I tried to click the options in Firefox window (File, Edit, View, etc.) it didn't open the menus.

I tried it with the regular IBM USB mouse as well. It scrolled the content in a proper way but it didn't open the menus in Firefox.

With Konqueror both embedded ThinkPad's mouse and regular USB mouse didn't work -- they neither could open the menus nor could open the folders.

Today I downgraded all xorg-server components from the version 1.4.2 to the version and almost everything started to work properly. With the exception of scrolling the content with USB mouse -- it doesn't work at all.

I noticed the same bug in the past when I installed on a trial basis Slackware 12.0. Because it was tiresome to scroll the content of the windows in that way I gave Slackware 12.0 up and came back to Slackware 11.0.

I'm not sure but it seems to me that I noticed the similar bug with Slackware 11.0 with the kernels from 2.6 series as well as with the kernel 2.4.35 so I used Slackware 11.0 with the kernel 2.4.34.

Xorg-server (summary):

* left mouse button clicking works properly,
* TrackPoint scroll works properly,
* USB mouse scroll doesn't work at all.

Xorg-server 1.4.2 (summary):

* left mouse button clicking doesn't open menus in neither Firefox nor Konqueror and doesn't open folders in Konqueror -- instead of open them it selects them,
* TrackPoint scroll works in a buggy way (as described above),
* USB mouse scroll works properly.

My question is how can I avoid these problems with the current and future releases of the xorg-server. Maybe I can use some option in xorg.conf or I can change something in xorg-server sources and compile it myself.

Have a nice day...



I use Slackware 12.1 with generic smp kernel

Here's an excerpt from my xorg.conf configuration file:


Section "InputDevice"
 Identifier "Mouse1"
 Driver "mouse"
 Option "Protocol" "PS/2"
 Option "Device" "/dev/mouse"
 Option "Emulate3Buttons" "on"
 Option "EmulateWheel" "on"
 Option "EmulateWheelButton" "2"
 Option "YAxisMapping" "4 5"

Section "InputDevice"
 Identifier "Mouse2"
 Driver "mouse"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "IMPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons"

 InputDevice "Mouse1" "CorePointer"
 InputDevice "Mouse2" "AlwaysCore"

Bruce Hill 07-02-2008 08:00 PM

Since those were patches to the stable tree, I'd recommend
contacting Pat V. at Slackware directly. Glad I read your
thread before updating them myself.

slackass 07-02-2008 10:19 PM

I couldn't resist so I updated a separate installation that I use for package testing and all I had to do is reinstall nvidia to get everything working again.
Until I rebooted.
Now it stops in the middle of shutdown an hangs, and will only shutdown the rude way.
So I think I'm guna just black list that stuff on my main box.

Bruce Hill 07-02-2008 11:30 PM

Alien Bob answered this in another thread.

w1k0 07-03-2008 11:12 AM

I reported xorg-server issue directly to Patrick Volkerding. I'm not sure it's right to write in such cases to ``The Man'' but I didn't find on any e-mail address for reporting general issues.

Bruce Hill 07-03-2008 11:15 AM

See the thread I referenced above. It doesn't seem to be an issue
with the Slackware packages; you just needed to reinstall your driver

shadowsnipes 07-03-2008 11:37 AM

Everything is working fine for me. I had originally forgotten to reinstall my Nvidia drivers before starting the ugraded X and my screen savers (particularly those using OpenGL) stopped working properly. I simply went into runlevel 3 (X was shutdown) and ran
nvidia-switch --xorg, and then reinstalled the X updates, and then reinstalled the nvidia drivers package (the runs nvidia-switch --nvidia). I probably could have just ran nvidia-switch --nvidia without doing the rest of the steps, but I figured it was better to be safe.

However, perhaps these mouse issues that the OP is having is a different issue. I think it is probably a configuration issue, though, and not a bug. For instance, I don't understand why you are emulated 3 buttons on your usb mouse when it really has three buttons.

w1k0 07-03-2008 12:09 PM

I don't use closed-source proprietary driver so the advice by Alien Bob mentioned by Bruce Hill doesn't apply to my case.

I removed both Option "Emulate3Buttons" from my xorg.conf. The result is the same -- buggy mouse operations with xorg-server 1.4.2 and no scrolling with regular USB mouse and xorg-server

shadowsnipes 07-03-2008 12:34 PM

On my Thinkpad Laptop I use a USB mouse and the builtin mouse. However, I only specify one mouse in the xorg.conf and everything works fine for me.


Identifier "Mouse0"
Driver    "mouse"
Option    "Protocol" "auto"
Option    "Device" "/dev/input/mice"
Option    "ZAxisMapping" "4 5 6 7"

I should note, however, that that machine is still on Slackware 12.

Hangdog42 07-03-2008 12:44 PM


InputDevice "Mouse1" "CorePointer"
InputDevice "Mouse2" "AlwaysCore"
This is at least part of the problem. The AlwaysCore declaration was deprecated and doesn't work starting with whatever version of X Slackware 12.1 uses. At least on my laptop, the only mouse that would work would be the CorePointer. What does work is to replace AlwaysCore with SendCoreEvents and then add Option "SendCoreEvents" "true" to the Section for that device.

w1k0 07-03-2008 03:44 PM

The problem solved by shadowsnipes and Hangdog42
I'm not sure the option AlwaysCore is deprecated. I inspected sources of xorg-server 1.4.2. ChangeLog mentions fixing AlwaysCore handling by Peter Hutterer in January 29, 2008, and both xf86Xinput.c and xf86Config.c use that option. I checked also man xorg.conf for xorg-server 1.4.2 -- it mentions Option "AlwaysCore" as well.

I tried the configuration suggested above by shadowsnipes with two additional options concerning wheel emulation and without options InputDevice "Mouse1" "CorePointer" and InputDevice "Mouse2" "AlwaysCore" as suggested Hangdog42. Now everything works well with both old and new xorg-server. Now I need to cancel the issue I sent to P. V.

I used that configuration for several years and I was sure it's valid. I was wrong. Below is working configuration for two mouses: embedded and external, and for two methods of scrolling the content: with TrackPoint and with wheel:


Section "InputDevice"
 Identifier "Mouse1"
 Driver "mouse"
 Option "Protocol" "Auto"
 Option "Device" "/dev/input/mice"
 Option "EmulateWheel" "on"
 Option "EmulateWheelButton" "2"
 Option "ZAxisMapping" "4 5 6 7"

Hangdog42 07-03-2008 05:10 PM


I'm not sure the option AlwaysCore is deprecated. I inspected sources of xorg-server 1.4.2. ChangeLog mentions fixing AlwaysCore handling by Peter Hutterer in January 29, 2008, and both xf86Xinput.c and xf86Config.c use that option. I checked also man xorg.conf for xorg-server 1.4.2 -- it mentions Option "AlwaysCore" as well.
I haven't look in any Xorg documents, but according to the Gentoo wiki, AlwaysCore was deprecated in Xorg 7.3. However on further reading it says that it was deprecated for input devices so I suppose it may still be used for other things. At any rate, on my rig AlwaysCore simply stopped working with the upgrade to Slackware 12.1.

All times are GMT -5. The time now is 07:23 PM.