LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   xorg.conf being ignored? (https://www.linuxquestions.org/questions/slackware-14/xorg-conf-being-ignored-436201/)

shame 04-17-2006 09:07 PM

xorg.conf being ignored? [SOLVED]
 
I've been trying to get my mouse wheel to scroll, which seems to be a common problem with slack but no matter what I do in xorg.conf it still won't work.
With other distros the mouse is detected as IMPS/2 but I've tried every protocol and the different devices and with 6 different mice and still no scrolling.
I've also tried adding Option "ZAxisMapping" "4 5" and Option "Buttons" "5"
I'm wondering if the configuration is being taken from somewhere else because a second problem I'm having is with screen resolution.
I wanted to change it to 1152x864 but no matter what, it starts up as 1280x1024. I can change to 1280x960, 1024x768 and 800x600 in kde but the 1152x864 option isn't there.
I changed xorg.conf to only use 1152x864 but it still isn't available and all the others are.

The latest thing I have tried is remove all the resolution lines and all the mouse lines from xorg.conf and the mouse is working (without scrolling) and I'm still stuck at 1280x1024.
It seems xorg.conf is being completely ignored.

shilo 04-17-2006 09:20 PM

Check out /var/log/Xorg.0.log. This will tell you what config file is being used and give you an idea what the issues are.

masonm 04-17-2006 09:21 PM

Odd, I use a scroll mouse and ZAxisMapping works for me. Details about your system?

gilead 04-17-2006 09:25 PM

You can run the following to see which config file is being used:
Code:

grep 'Using config file' /var/log/Xorg.0.log
On my system, the result is:
Code:

(==) Using config file: "/etc/X11/xorg.conf"

shame 04-17-2006 09:37 PM

Output of grep 'Using config file' /var/log/Xorg.0.log is
Code:

Using config file: "//xorg.conf"
I'm not sure what that means, I can't find any other xorg.conf files other than the one in X11.

dennisk 04-18-2006 12:06 AM

What's the output of "ls -l /dev/mouse"? It should point to /dev/input/mice. if it doesn't then go back and rerun the mouse setup under pkgtools. You want the second choice M$ Intellimouse- imp/2.

Also, you can run xorgsetup. It now configures a scroll mouse.

Dennisk

shame 04-18-2006 05:36 PM

Thanks for all the responses, there was nothing wrong with my xorg.conf as it turns out.
The output of grep 'Using config file' /var/log/Xorg.0.log was spot on.
Turns out there was an xorg.conf file in my / directory. I had missed it when I was looking around before and "locate" didn't show it so I reckon the first time I did xorgconfig, to sort the reolution out, I must have saved it to / and so the one in /etc/X11 was indeed being ignored when I was making changes to it.
After removing the one in / and running xorgconfig yet again, my mouse wheel is scrolling properly and I can change the resolution to my desired 1152x864.


All times are GMT -5. The time now is 12:59 PM.