LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-18-2011, 01:24 AM   #1
jheengut
Member
 
Registered: Sep 2006
Location: Providence, Moka Mauritius
Distribution: Slackware, Lubuntu
Posts: 303
Blog Entries: 16

Rep: Reputation: 33
Xorg and problems with evdev


Hi , there slackers.

I'm currently using slackware 13.1 on an lvm parted system.
Everything is working properly except X. I had to fiddle with the xorg.conf file as the server doesn't automatically detect my hardware as it should.
I have also optimized my X server and kde4 is not slow with 256m with both amarok and nepomuk shut down. (to get these two programs not slowing down my desktop I have added another 512m ram to increase it to a total of 768m of RAM).

My mouse is automatically detected, I have removed it from the xorg.conf file. My problem is that I have to log out and again login without killing X or kdm so that the keyboard is working properly (ie all keys are being translated to the correct bindings). I have tested all possible configurations.
When I checked the Xorg.log.1 in /var/log , the evdev module is unloaded since it found a problem. By logging out and logging in , the evdev module (I do not know which one the kernel one or the X evdev module) is automatically reloaded with no problem.

How can I debug this problem ?
 
Old 01-18-2011, 07:37 AM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: Disabled
Hello jheengut,
Quote:
...My problem is that I have to log out and again login without killing X or kdm so that the keyboard is working properly (ie all keys are being translated to the correct bindings). I have tested all possible configurations...
have you tried to restart the hald daemon instead? You may open a terminal and issue the command (as root)
Code:
/etc/rc.d/rc.hald restart
maybe that helps.

Markus
 
Old 01-21-2011, 04:28 AM   #3
jheengut
Member
 
Registered: Sep 2006
Location: Providence, Moka Mauritius
Distribution: Slackware, Lubuntu
Posts: 303

Original Poster
Blog Entries: 16

Rep: Reputation: 33
hald or dbus

As far as I remember hald should be restarted in init 1 .

I shall try it today.
 
Old 02-02-2011, 05:26 AM   #4
jheengut
Member
 
Registered: Sep 2006
Location: Providence, Moka Mauritius
Distribution: Slackware, Lubuntu
Posts: 303

Original Poster
Blog Entries: 16

Rep: Reputation: 33
hal

/etc/rc.d/rc.hald restart

does do any good
 
Old 03-30-2011, 06:24 AM   #5
jheengut
Member
 
Registered: Sep 2006
Location: Providence, Moka Mauritius
Distribution: Slackware, Lubuntu
Posts: 303

Original Poster
Blog Entries: 16

Rep: Reputation: 33
xine

I have just found that when I am using xine the up arrow stops working
 
Old 05-24-2011, 05:03 AM   #6
jheengut
Member
 
Registered: Sep 2006
Location: Providence, Moka Mauritius
Distribution: Slackware, Lubuntu
Posts: 303

Original Poster
Blog Entries: 16

Rep: Reputation: 33
This problem seems to lie only under kde4.4 and kde4.5.5(slackware 13.37 which I AM still testING) and not under other desktop environments

I cannot change the keyboard layout under kde.

the module to change keyboard layouts under systemsettings keeps crashing when clicked and kcmshell refuses to load this module.
 
Old 05-24-2011, 08:23 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: Disabled
If you want to change the keyboardlayout, you'll have to copy the /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf file into the /etc/X11/xorg.conf.d/ directory, edit this file (it is self-explaining) and then restart the X-server. This should work.

Markus
 
Old 05-25-2011, 05:45 AM   #8
jheengut
Member
 
Registered: Sep 2006
Location: Providence, Moka Mauritius
Distribution: Slackware, Lubuntu
Posts: 303

Original Poster
Blog Entries: 16

Rep: Reputation: 33
does this change anything for any evdev device because i cannot get any response for my remote

http://www.linuxquestions.org/questi...aa7134-877128/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard configuration in Xorg: deadkeys, hal, evdev, what? quiescere Slackware 2 12-18-2010 09:07 PM
Xorg 7.3, evdev, and mouse CrEsPo Slackware 1 05-05-2008 04:16 AM
Sid Users - Beware of Xorg 7.3 (xserver-xorg-input-evdev) bug rickh Debian 4 10-24-2007 03:30 AM
Using evdev causes Xorg to restart on keypress Likosin Linux - Software 5 04-03-2006 04:10 PM
evdev with xorg 6.9 ganja_guru Linux - Software 1 12-25-2005 12:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration