-   Slackware (
-   -   xml error building gnome-games for Slackware 12.2 (

wufo 02-05-2009 12:24 PM

xml error building gnome-games for Slackware 12.2
Has anybody built gnome-games-2.24.3 for Slackware 12.2? I have been working on it by downloading all the required software from,configuring and installing. This involved many different gnome packages, gtk-2.0, pygtk, etc. After finally satisfying all the gnome-games dependencies specified by ./configure I ran make and ran into another problem.

The make failed on an xml stylesheet problem. Here is the output:

xsltproc -o aisleriot-C.omf --stringparam db2omf.basename aisleriot --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/local/share/omf" --stringparam db2omf.help_dir "/usr/local/share/gnome/help" --stringparam db2omf.omf_in "/home/user1/src/gnome-games-2.24.3/aisleriot/help/" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/aisleriot.xml || { rm -f "aisleriot-C.omf"; exit 1; }
compilation error: file C/aisleriot.xml line 105 element book
xsltParseStylesheetProcess : document is not a stylesheet
make[3]: *** [aisleriot-C.omf] Error 1

Here is the offending line:
<book id="index" lang="en">

I really know very little on using xml.

Can anybody help me?

I got no replies posting it to gnome mailing list.


Didier Spaier 02-05-2009 01:13 PM


Originally Posted by wufo (Post 3433188)
I got no replies posting it to gnome mailing list

On GSB' home page they say "GSB 2.24.2 available in gsb-testing". But I do not know where it is nor if it works for Slackware 12.2

dugan 02-05-2009 01:16 PM

gsb-current is the 12.2-ready branch of GSB.

wufo 02-05-2009 01:33 PM

I really wasn't looking to install the whole gnome on Slackware, at this time just the games and maybe a couple of other apps. I am using the xfce desktop right now. Using Linux and Slackware is also a learning experience, if something I try to do doesn't work, find out why and fix it.

So, I still want to find out the reason why my build of gnome-games is failing.


gnashley 02-05-2009 02:09 PM

Sometime back I had similar problems with something that was using xsltproc. I think the way i got around it was by editing the Makefile so that the docs would not be built or that they would not be re-generated by xsltproc. the xsltproc author is 'embarassed' because he hasn't founbd a fix for this problem. Can you attach a copy of the Makefile here? Maybe i can sort out the offending line...
Either that, or you look in the and and find where the SUBDIRS are specified, remove the 'docs' or whatever the name of the offending subdir is, then run 'autoreconf -if' and ./configure again before compiling. Fun stuff, Huh?

jong357 02-05-2009 06:26 PM

Just out of curiosity, have you installed the docbook xml/xsl packages?

wufo 02-05-2009 09:12 PM

I assumed that it was installed when I installed the 12.2. I just went ahead and said "install everything" went I did the clean 12.2 install.

But, I guess that is something to check.


wufo 02-05-2009 09:31 PM

Isn't docbook in the linuxdoc-tools-0.9.21-i486-6 package?


gnashley 02-06-2009 02:31 AM

Do you have gnome-doc-utils installed?

Searching for 'xsltParseStylesheetProcess : document is not a stylesheet' truned up lots of hits...

jong357 02-06-2009 10:06 AM


Originally Posted by wufo (Post 3433686)
Isn't docbook in the linuxdoc-tools-0.9.21-i486-6 package?


It's possible. I know gtk-doc is in there. linuxdoc-tools can be a source of problems at times because it's either outdated or incomplete. I always got the impression that package was a bastardized collection of half-apps. I know you'll have problems building Gnome if you rely soley on that package to provide what it's "supposed" to provide, which basically means it's borderline useless for the purpose of building Gnome.

Check all your deps. When building Gnome 2.24.x, I have no problems building gnome-games. Ofcourse that was on Slackware 12.1

And, yea, I'd also make sure gnome-doc-utils is installed.

gnashley 02-06-2009 11:19 AM

The only reference I found to that error specifically related to building gnome-games gave the solution of installing gnome-doc-utils -it was on a frugalware site.
In looking thorugh the for the aisleriot subdir, it seems you might be able to avoid this problematic Makefile rule being run by passing '--disable-scrollkeeper' to configure.

wufo 02-06-2009 01:40 PM

Bingo, gnome-docs solved the problem. In fact, I had already downloaded and untar'ed gnome-docs, but for some reason, got interrupted by wife, etc, I had never installed it. So, in my feeble mind it was done and since the gnome-games configure didn't complain about it, I dismissed it as being a cause of the problem. Duh. Lesson learned.

A very deep thanks to all for their time and help.


All times are GMT -5. The time now is 02:58 PM.