-   Slackware (
-   -   .xinitrc problem (

reddazz 08-12-2004 05:13 AM

.xinitrc problem
Something is baffling me on Slack 10. I recently installed KDE CVS in the home directory of a user called "kdedev". I then wrote an ".xinitrc" file and added the following line "exec /home/kdedev/kde-unstable/bin/startkde" . The problem is that if I run "startx", I'm logged into the old version of KDE. The thing thats confusing me is that if I am logged in as a different user, start a console session and run "startx -- :1" as kdedev, I can log into KDE CVS, but this is a drain on resources since I have to versions of KDE running at the same time.

I don't know if there is a problem with my .xinitrc (it only contains the line I wrote above). Any help will be appreciated.

Cedrik 08-12-2004 05:30 AM

Did you try ' mv /etc/X11/xinit/xinitrc /etc/X11/xinit/xinitrc.bak '

and run startx again ?

reddazz 08-12-2004 06:07 AM

I tried that and it still gives me the same problem. Could there be a script somewhere thats preventing .xinitrc from the users home directories from being read?

Cedrik 08-12-2004 06:41 AM

I am reading the startx script, it is clear for me :

if [ -f $userclientrc ]; then
elif [ -f $sysclientrc ]; then

So logically, if it find your .xinitrc file, it is supposed to execute it instead of /usr/X11R6/lib/X11/xinit/xinitrc which is a link to /etc/X11/xinit/xinitrc.<window manager>

Did you add the line :

at the top of your script and is it executable ?

For me the best to do is :
cp /etc/X11/xinit/xinitrc.kde ~/.xinitrc

And change only the last line to exec your cvs KDE

reddazz 08-12-2004 07:33 AM

I did as you said and aslo found out that I had to add the following line to .xinitrc "source .bash_profile". Now everything works fine and my kdedev user can log into KDE CVS version without any problems.

All times are GMT -5. The time now is 02:47 PM.