LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-17-2003, 05:26 PM   #1
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 888

Rep: Reputation: 30
Xfree Error (EE) module ABI minor version (7) is newer than the server's version (6)


I have recently tried to upgrade my radeon driver for Xfree 4.3.0 so I can enable DRI as I only seem to have the soft rendering... but I get the following error.... its all going a bit over my head but I have been reading everywhere and think I might need to do somthing with using this file I downloaded linux-drm-4.3.0-kernelsource.tar.gz

(II) LoadModule: "radeon"
(II) Loading /usr/X11R6/lib/modules/drivers/radeon_drv.o
(II) Module radeon: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 4.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.5
(EE) module ABI minor version (7) is newer than the server's version (6)
(II) UnloadModule: "radeon"
(II) Unloading /usr/X11R6/lib/modules/drivers/radeon_drv.o
(EE) Failed to load module "radeon" (module requirement mismatch, 0)

Can anyone help me out here I have been trying for like two weeks to get DRI working! I installed drivers from ATI and it worked but it screwed up Xawtv... so I just want the more compatable DRI drivers to work.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newer version of tar? imahdi Linux - Software 1 01-04-2005 08:26 PM
how to compile a module with a newer version of the linux kernel? fvarela Programming 2 07-29-2004 02:00 AM
Can't load module :error kernel version mismatch garv Linux - Software 1 04-05-2004 12:47 PM
Xfree prob radeon.o kernel module version is 1.1.1 but version 1.5.0 or newer needed. jimdaworm Slackware 0 10-01-2003 06:27 PM
Sample Driver Module incompatibility with Kernel version (or gcc version) jvs Linux - General 1 06-07-2002 01:40 AM


All times are GMT -5. The time now is 07:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration