LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-23-2012, 06:45 PM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
XFCE Screensaver and Power Management?


OK, feeling kind of dumb.

I got fed up with KDE 4.6.5 crashing all the time and moved to XFCE. Can't figure out in the documentation how in blazes to set the screen save (or even wake the blasted thing up) and the display power management. Been looking at everything I can find and there doesn't seem to be anything. I don't want a graphic log in, I just want the thing to go dark and shut down the display so I can wake it up (moving the mouse didn't do it, and it kept the power on).

While I'm at it, can the blasted thing turn the Num Lock somehow or other?

Sheesh.
 
Old 02-23-2012, 07:15 PM   #2
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,030

Rep: Reputation: 160Reputation: 160
xfce4-power-manager and xnumlock?

cheers,
 
Old 02-23-2012, 09:14 PM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
On Xfce 4.6.1 ...

Xfce menu -> Settings -> Screensaver -> Display modes

Blank After: <whatever you want>
Lock Screen After: cleared
 
Old 02-24-2012, 06:50 AM   #4
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
I'm getting blinder by the day -- looked through that settings thing and totally missed the word "screensaver." Duh.

Still can't find numlock anywhere but...

It's generally not a good idea to switch environments in the middle of a project, but I just got so fed up with KDE crashing (and didn't want to download the updated versions). Up against the wall ain't a good time to migrate.

Thanks.
 
Old 02-24-2012, 07:10 AM   #5
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Quote:
Originally Posted by tronayne View Post
Still can't find numlock anywhere but...
Some techniques on the ArchWIKI. Not for Xfce but for X so hopefully that will do what you want.
 
Old 02-24-2012, 09:23 AM   #6
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,208

Rep: Reputation: 176Reputation: 176
There is a number lock plug-in that works with Xfce 4.8, but, not, very unfortunately, with 4.6.2.

http://goodies.xfce.org/projects/pan...kbdleds-plugin


There is also, http://slackbuilds.org/repository/13...stem/numlockx/
 
Old 02-24-2012, 12:53 PM   #7
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Holy Toot! I gotta punch a button! Golly, gee, Batman, how 1970's.

OK, no problem, just gotta remember to make that little green light come on.

Thanks
 
Old 02-25-2012, 05:41 PM   #8
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 917

Rep: Reputation: 87
There is also Settings -> Session and Startup where you can define autostarted applications (it may help with numlock if there is a simple command to turn it on).
 
Old 02-26-2012, 10:22 AM   #9
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Quote:
Originally Posted by Ilgar View Post
There is also Settings -> Session and Startup where you can define autostarted applications (it may help with numlock if there is a simple command to turn it on).
Thanks -- I tried that with the package from Slackbuilds.org and it didn't like it.

Won't hurt a bit to simply punch the NumLock key for now.
 
Old 02-26-2012, 11:28 PM   #10
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,208

Rep: Reputation: 176Reputation: 176
When running Xfce 4.8, I found if I left the number lock button "on" then it automatically
was turned on each time I started Xfce 4.8. It might of had some to do with putting a
check mark next to "Save session for future logins" on the logout splash screen, but I really
don't know.

Last edited by cwizardone; 02-27-2012 at 10:23 AM. Reason: Typo.
 
Old 02-27-2012, 12:39 AM   #11
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Quote:
Originally Posted by tronayne View Post
Thanks -- I tried that with the package from Slackbuilds.org and it didn't like it.

Won't hurt a bit to simply punch the NumLock key for now.
If you are interested in solving this problem, please give detail on "didn't like it" (running the same command you entered into the autostart at the command line in a GUI terminal emulator).

If you are not interested then "happy punching"
 
Old 02-27-2012, 05:10 AM   #12
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
"Didn't Like It:" startx failed (and, no, I don't remember the message, alas); I did add the start-ups suggesting the package README from SlackBuilds.org.

I'm in the middle of a big project and, honestly, I just don't have time right now to chase it down. As indicated by cwizadrone, once on it does automagically come back on when XGCE is restarted (yup, the "save session"). I'll try to get back to it when the dust settles.
 
Old 03-01-2012, 11:04 AM   #13
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,208

Rep: Reputation: 176Reputation: 176
I would be interested to know if you encounter any video problems with Xfce 4.8x.
Thanks.
 
Old 03-02-2012, 11:04 PM   #14
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Yet another option (you have to love desktop gnu) The dpms is also an option if you only want the monitor to power off. You could do that in stead of running the screensaver. You can do it on the fly, see 'xset --help' for options or it can be activated in the xorg.conf.d files.
 
Old 03-03-2012, 08:31 AM   #15
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Original Poster
Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
One of the things I've learned to avoid is fancy-schmancy video cards -- my only experience with them has been a few ATI/AMD cards that came with various boxes and much of that experience has been... frustrating, shall we say. So the last couple of boxes bought have been "stock Intel graphics;" I don't do games, I don't do movies, I don't give a hoot as long as the image is viewable. The manufacturers support Microsoft 'case that's where their money is and the rest of us can wait, roll our own or use AMD/ATI proprietary drivers (and that's nice of them to have offered those for free and I don't give another hoot if they are proprietary). I care a lot more about things being stable and working than I do about hairy-edge technology that I have to fiddle with more than once so I can use the blasted thing to do what I need done.

I switched to XFCE simply because KDE 4.6 (that I got from AlienBob, thank you, AlienBob, and installed so that one application that I care about would work when it was upgraded and required a "feature" that wasn't in the stable release that came with Slackware 13.37) and it crashed frequently simply from drawing the mouse down to the task bar or if the wind blew from the wrong direction. I was in the middle of setting up QuickBooks in VirtualBox and those little crashes played hell with Win7 and QuickBooks but the same sort of thing happened with no rhyme or reason just doing work with Linux-only applications. Sheesh.

And, yeah, I could have downloaded and installed the newer, more stable (maybe) KDE versions and tried that; I live in the boonies, I've got HughesNet (satellite service) and I didn't have the hours it would have taken to do do that (again). I may go back to KDE when the next stable Slackware release comes but, nope, not now.

XFCE, at least version 4.6.x that comes with Slackware 13.37, isn't quite up to snuff with KDE. It's OK, but just not quite there yet -- and I don't mean fancy-schmany stuff, just the relatively simple things like power management on the KDE system menu. I did get it working so that the screen saver comes on after idle time then the display turns off sometime later (which is, ya know, what you want it do) and then wakes up with a mouse wiggle. I dug in the X books and the Xorg book to figure some things out and got 'er close the way I want 'er to work (lordy, have I forgotten more stuff that I ever really knew).

And I kind of think that XFCE holds promise -- just as long as it doesn't get so bloated that it becomes unusable (like, uh, KDE and GNOME, methinks maybe?). I just don't have the time right now to really dig in and figure out all the twists and turns; I've gotten spoiled rotten by bloat.

Anyway, onward and upward.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Management not working on embedded MIPS when using /sys/power/state RichardS Programming 1 01-21-2011 07:18 AM
XFCE - How To use both Screensaver and Power Management Erik_FL Slackware 1 09-08-2009 06:57 AM
Screensaver - power management problems raphaelmsx Fedora 2 07-25-2006 06:38 AM
huge problem with power management and screensaver Xavius Slackware 5 01-06-2005 03:38 AM
Enabling power save/power management/cpu freq scaling features for a Debian system zero79 Debian 0 12-19-2004 01:17 PM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration