Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 04-02-2005, 10:50 PM   #1
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Rep: Reputation: 15
xfce / rox desktop question

I use Xfce and I wanted desktop icons. I'v read that you can use Rox to manage the background instead of xfdesktop. To do this I added the line:

"rox -p xfce &"

and commented out "xfdesktop &" in my xinitrc file. However when I restart X the desktop hasnt changed. I dont know which file to actualy edit to change this.

Also I get the error "Failed to create symlink '/home/mike/.icons/ROX':
File exists"

This happens when I type "rox -p xfce &" into a terminal.

That starts the rox desktop however the icons in the filer and on the desktop have no pictures mapped to them they are just questionmarks.

If anyone can help please do.

Old 04-02-2005, 11:29 PM   #2
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Original Poster
Rep: Reputation: 15
Ok. I fixed that error and I now have icons. All I have to do now is make it start automaticly when I issue "startx".
Old 04-03-2005, 08:35 AM   #3
Registered: Aug 2003
Location: NW Scotland
Distribution: Slackware 10
Posts: 169

Rep: Reputation: 30
Some vague memory in the back of my mind suggests you try :

rox --pinboard=xfce

I may be muddled but I have a faint recollection of this working once when -p did not. Also I do not think you need the & - I never use it with rox as the command completion is immediate and if run in a terminal the terminal does not stay open. Whether this makes a diference I do not know.
Old 04-03-2005, 10:58 AM   #4
Registered: Sep 2004
Location: Santiago de Chile
Distribution: Slackware 10.2
Posts: 46

Rep: Reputation: 15
What you have to do is kill xfdesktop and then run the rox desktop. Log out of XFCE, but make sure to save your session. When you log back in, it should be the way you want it to be.


PS: If you don't know how to save your session: go to the XFCE Settings screen, then to "Sessions and Startup". You should see a "Prompt on logout" checkbox. Check it. Then when you log out, check "Save sessions for future logins".

Last edited by lagartoflojo; 04-03-2005 at 11:02 AM.
Old 04-03-2005, 11:43 AM   #5
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Original Poster
Rep: Reputation: 15
I got X so it starts ROX when I type "startx" now. But I still dont understand what file that points to to start my session. I'd like to know what the process is when I issue "startx".



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop icons in xfce4 with rox gaah Linux - Newbie 3 02-13-2011 03:38 AM
udev/hal/ivman, want appearing desktop icons w/rox-filer hedpe Linux - Software 2 11-13-2005 09:35 AM
rox filer question synaptical Linux - Software 2 08-14-2005 04:27 PM
XFCE: Icons on desktop senorsnor Linux - Software 4 08-09-2004 03:42 AM
xfce Desktop Ajentsmith Linux - Software 3 02-18-2002 04:26 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:45 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration