-   Slackware (
-   -   xfce / rox desktop question (

pyschomike15 04-02-2005 11:50 PM

xfce / rox desktop question
I use Xfce and I wanted desktop icons. I'v read that you can use Rox to manage the background instead of xfdesktop. To do this I added the line:

"rox -p xfce &"

and commented out "xfdesktop &" in my xinitrc file. However when I restart X the desktop hasnt changed. I dont know which file to actualy edit to change this.

Also I get the error "Failed to create symlink '/home/mike/.icons/ROX':
File exists"

This happens when I type "rox -p xfce &" into a terminal.

That starts the rox desktop however the icons in the filer and on the desktop have no pictures mapped to them they are just questionmarks.

If anyone can help please do.


pyschomike15 04-03-2005 12:29 AM

Ok. I fixed that error and I now have icons. All I have to do now is make it start automaticly when I issue "startx".

JohnKFT 04-03-2005 09:35 AM

Some vague memory in the back of my mind suggests you try :

rox --pinboard=xfce

I may be muddled but I have a faint recollection of this working once when -p did not. Also I do not think you need the & - I never use it with rox as the command completion is immediate and if run in a terminal the terminal does not stay open. Whether this makes a diference I do not know.

lagartoflojo 04-03-2005 11:58 AM

What you have to do is kill xfdesktop and then run the rox desktop. Log out of XFCE, but make sure to save your session. When you log back in, it should be the way you want it to be.


PS: If you don't know how to save your session: go to the XFCE Settings screen, then to "Sessions and Startup". You should see a "Prompt on logout" checkbox. Check it. Then when you log out, check "Save sessions for future logins".

pyschomike15 04-03-2005 12:43 PM

I got X so it starts ROX when I type "startx" now. But I still dont understand what file that points to to start my session. I'd like to know what the process is when I issue "startx".


All times are GMT -5. The time now is 04:32 AM.