-   Slackware (
-   -   xfce leave gnome-keyring-deamon process on logout (

Celyr 04-22-2013 04:04 AM

xfce leave gnome-keyring-deamon process on logout

I use my slackware desktop in remote via XDMCP, i've configured kdm to accept it. I login with my user and everything works fine.
at the end of the work I log out but not every process get killed:

andrea  17244  0.0  0.1 222000  6576 ?        SLl  Apr21  0:00 /usr/bin/gnome-keyring-daemon --start --foreground --components=secrets
andrea  17626  0.0  0.1 222000  4532 ?        SLl  Apr21  0:00 /usr/bin/gnome-keyring-daemon --start --foreground --components=secrets
andrea  18712  0.0  0.1 222000  4532 ?        SLl  Apr21  0:00 /usr/bin/gnome-keyring-daemon --start --foreground --components=secrets

Those three processes remain sleeping until I manually kill them. Is there any precise reason for that or is it just a bug ?

Thank you.

STDOUBT 04-25-2013 05:55 AM

I find your lack of responses...disturbing.
So, here's a bump and a question for you to clarify something.

This "gnome-keyring-daemon" process is on your remote Slackware machine, yes?
If so, it seems to me that the daemon is just sleeping as it awaits your next login?
I'm not an expert by any stretch, but I have a suspicion that what you're seeing
is kinda normal. That it's a process tied to your user "andrea", would mean it's not
likely a security problem while that user is logged out.

There. Now we can wait for one of the guys with a long string of green boxes to come along
and set us straight ;-)

Celyr 04-25-2013 08:01 AM

I did a bit of research before and after posting this thread and I found this.
It's a bug that is fixed upstream since 2005, I don't know why it pops up now.
Anyway I see no reason to leave it running, it's not a mayor issue since this remote desktop is used by a couple of users (so 6 processes running) but like stated on the bug:

Not sure if gnome-session is the right component, but gnome leaves
atleast gnome-keyring-daemon and bonobo-activation-server running
after a logout.
Seems unnessesary. (Think schools, public libraries etc. filled with
those for every usre logged in.)
it looks like a dbus bug.

Celyr 05-07-2013 11:43 AM

Who said bump ?

STDOUBT 05-11-2013 03:53 AM

We said bump.

Celyr 05-12-2013 04:37 AM

It seems that nobody cares :P
Can someone please confirm the bug ?
I'm going to send an email to Patrick Volkerding on monday.

Celyr 05-21-2013 08:35 AM

Hi, I'm marking this thread as solved since the last update solved this issue.
Those processes are no more left behind.

All times are GMT -5. The time now is 07:59 PM.