-   Slackware (
-   -   xfce flickering problem after 2006-02-10 slack-current upgrade (

firebird 02-14-2006 09:28 AM

xfce flickering problem after 2006-02-10 slack-current upgrade
Hi, everyone,

I just upgraded to slack-current 2006-02-10, and I found a strange flickering problem in xfce. I managed to find a way to replicate the problem reliably:
  1. Launch xfterm4 after xfce4 starts;
  2. Enter something randomly in the terminal. I just hold down one key and let typematic feature do things for me. Let the line wrap in the terminal. After about 5 or 6 lines, short, horizontal lines begin to flashing across the screen randomly. From now on, every key I pressed will bring up the flashing lines once. Such line won't persist on screen, they just flashing by, like something is updating that portion of screen. BTW, you may won't to make the terminal narrower so the problem turns up quicker.
  3. I have other ways to replicate it, such as open a webpage using Firefox, scroll down to the end, and keep pressing page-down, same short, horizontal line will appear. So I'd say it's application independent.

Before this upgrade, I uses slackware-current 2006-01-14, I don't have such problem. I still have one box on slackware-current 2006-01-14, no problem found.

I have tried following steps, none of them make those short lines disappear:
  1. Downgrade xfce- to the previous version (xfce-4.2.2, stock 10.2 one).
  2. Downgrade kde-3.5.1 to the previous version (kde-3.4.2, stock 10.2 one).
  3. Downgrade gtk+2-2.8.11 to the previous one (gtk+2-2.6.10, stock 10.2 one).
  4. Boot with different kernel (Home build and, stock 2.4.32 and
Because X11 has already been upgraded in slackware-current 2006-01-14, this is very unlikely an X11 problem. Does anyone have some idea on this? Do you have the same problem on your system?

Other information that I think might help:
  • I don't use any tool to upgrade the system, I do upgrade manually after I download all packages (and make sure all packages passed checksum).
  • I use nVidia video adaptor (NV15 [GeForce2 GTS/Pro] rev 164), and I did not install any nVidia drivers, just stock X11 stuff. There's also no funny stuff in Xorg.conf, just a default config with mouse and display dimension change. I have not changed it for almost a year.
  • My monitor is an LCD.
Any suggestion before I start massive downgrade to slackware-current 2006-01-14? Maybe I should stay with KDE for a while :)

firebird 04-08-2006 04:51 AM

The problem described in this post has been fixed by slack-current 2006-04-04. I think kde 3.5.2 upgrade fixed the problem. Sorry I don't know what the root cause of the problem is. I have been testing slack-current ever since I reported the problem, slack-current 2006-04-04 is the first one that fixed it.

I'm really glad I can move back to XFCE.

win32sux 04-08-2006 08:38 AM

it's kinda weird that a kde upgrade would fix an xfce problem, no??

All times are GMT -5. The time now is 05:35 AM.