LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-19-2010, 04:57 AM   #1
anti_user
Member
 
Registered: May 2008
Location: Russia, Ural
Distribution: Slackware Current
Posts: 69

Rep: Reputation: 4
XFCE double click in thunar after last nov upgrading


Hello, slackers!

Found the new small bug after November upgrades:
Im using XFCE and now when Thunar showing files and directories in details view, i can one time open folder by double click, then go up to directory and double click wont work anymore, but in compact and in icon view thats work ok.

Earlier this worked Ok from others views. Thinking that is bug.
To XFCE users: try this too after latest updates...
 
Old 11-19-2010, 06:46 AM   #2
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
I see the same problem. I initially thought a fresh install had sorted it, but I wasn't looking hard enough.

Last edited by GazL; 11-22-2010 at 05:15 AM. Reason: incorrect information
 
Old 11-19-2010, 08:37 AM   #3
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Are you using xfce-4.6.1 or 4.6.2? -current still has 4.6.1, but Robby has a 4.6.2 package on his site. Not sure if this will solve your problem, but it's worth a shot.
 
Old 11-19-2010, 10:18 AM   #4
anti_user
Member
 
Registered: May 2008
Location: Russia, Ural
Distribution: Slackware Current
Posts: 69

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by rmjohnso View Post
Are you using xfce-4.6.1 or 4.6.2? -current still has 4.6.1, but Robby has a 4.6.2 package on his site. Not sure if this will solve your problem, but it's worth a shot.
Im using official package from slackware.com 4.6.1. Pat nothing yet to upgrade to 4.6.2 version.
 
Old 11-20-2010, 02:48 PM   #5
ljb643
Member
 
Registered: Nov 2003
Posts: 264

Rep: Reputation: Disabled
You are using slackware-current, aren't you? (Because I don't think that problem is in Slackware 13.1. But it is was also seen in other distros like Xubuntu.)

I think this problem is triggered by gtk+2 libraries, which I see were upgraded in November in Slackware-current. Apparently something changed after Gtk+2-2.18.9 which caused these problems in Thunar. From the bug reports (see below), it looks to me like maybe it has not yet been fixed in gtk+2, but there is a work-around in newer versions of Xfce/Thunar.

http://bugzilla.xfce.org/show_bug.cgi?id=6230
https://bugzilla.gnome.org/show_bug.cgi?id=612802
 
Old 11-21-2010, 08:44 PM   #6
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by ljb643 View Post
You are using slackware-current, aren't you? (Because I don't think that problem is in Slackware 13.1. But it is was also seen in other distros like Xubuntu.)

I think this problem is triggered by gtk+2 libraries, which I see were upgraded in November in Slackware-current. Apparently something changed after Gtk+2-2.18.9 which caused these problems in Thunar. From the bug reports (see below), it looks to me like maybe it has not yet been fixed in gtk+2, but there is a work-around in newer versions of Xfce/Thunar.

http://bugzilla.xfce.org/show_bug.cgi?id=6230
https://bugzilla.gnome.org/show_bug.cgi?id=612802
I'm testing out the prelease of 4.8, and this bug is still present, in case anyone is interested.
 
Old 11-23-2010, 10:52 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Ahh, I see several of us have found the same bug reports. Isn't google wonderful .

Anyway, I've just rebuilt xfce including the exo patch from that bug report and all seem to be ok.
I've dropped Pat a note with a copy of my updated slackbuild and the patchfile. but for anyone who can't wait I've attached a tar.gz containing them here.

LQ won't let you upload a tar.gz so I had to rename it to .txt, but it's just a normal tar.gz.

Last edited by GazL; 04-09-2012 at 03:31 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Single mouse click acts as a double click TheIndependentAquarius Linux - Hardware 9 08-31-2010 01:50 AM
Fedora 9 Core Single Click acts like Double Click. solutionsville Linux - Hardware 10 12-08-2008 10:25 AM
Single-click, double-click icons in KDE Doug Vitale Linux - Newbie 5 07-23-2008 05:08 PM
Gnome 2.6.1: Single Click acts like Double Click Der_tolle_Emil Linux - Software 2 09-13-2004 08:59 AM


All times are GMT -5. The time now is 01:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration