LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-16-2012, 03:18 AM   #1
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Rep: Reputation: 31
xfce does not save my keyboard layouts across suspend-resume


Slackware 14 and whatever xfce comes with it. Thinkpad Edge hardware. I added xfce-kb-plugin from slackbuiulds.org, installed it and added it to the panel.

I can add the keyboard layouts I need and remove the default US layout. I can switch between layouts - all works fine. However when I suspend the laptop and resume I find I have only the default US keyboard back again. I have tried Saving the Session but that does not seem to help.

Does anybody know if there is a config file somewhere that I should make sure contains the right settings before suspending?

Thanks
 
Old 11-16-2012, 12:05 PM   #2
ppencho
LQ Newbie
 
Registered: Jan 2004
Location: Bulgaria
Distribution: Slackware64-current
Posts: 25

Rep: Reputation: 3
http://www.linuxquestions.org/questi...ap-4175433278/

http://docs.slackware.com/howtos:win...eyboard_layout

I also lost my layout settings after restart. So I added the layout in 90-keyboard-layout.conf, this works for me.
 
Old 11-16-2012, 12:12 PM   #3
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 445

Rep: Reputation: 113Reputation: 113
in my case XFCE tends to "forget" the keyboard layout, occasionally...

so, i just copied the config file:

/usr/share/X11/xorg.conf.d/90-keyboard-layout.conf

to

/etc/X11/xorg.conf.d

Opened and edited the layouts to my needs. I also added the option to use ALT+SHIFT for layout switch:

Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle"
 
Old 11-17-2012, 11:37 AM   #4
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Original Poster
Rep: Reputation: 31
Thanks to both replies which pointed to sorting this out at the level of the X config (/etc/X11/xorg.conf/d/90-keyboard-layout.conf) - this solves the problem so I am marking this as SOLVED. Some indication in the replies that it will work through the xfce plugin so long as you can identify your keyboard model correctly and precisely. Looks like if this is not correct in your config then xfce returns to a default keyboard layout.

Look like I should have looked first at docs.slackware.com which of course out of habit I failed to do trying general google searches and searches of the Slackware forum on LQ...

Thanks again for the help.
 
  


Reply

Tags
keyboard, settings, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Why do nVida drivers hose suspend/resume or hibernate/resume? taylorkh Linux - Hardware 3 06-23-2011 01:09 PM
Keyboard layouts in XFCE Lord_Grave Linux - Desktop 4 12-04-2010 06:29 AM
How to add keyboard layouts in xfce? harakanvarpaita Linux - Desktop 0 11-23-2007 01:26 PM
bewildered keyboard layouts in xfce harakanvarpaita Linux - Desktop 0 11-13-2007 12:51 AM
Keyboard layouts and languages in Xfce okok Linux - Newbie 1 05-04-2006 04:04 PM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration