LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-02-2010, 01:48 PM   #1
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,623

Rep: Reputation: Disabled
xfce automount usb drive at startup


I've googled this many times but have not found a solution yet. Can you get external usb hard drives to automount at xfce startup? They automount if I plug them in once xfce is started. If I have them connected at boot I get an icon for the drive which I can then mount. But I wonder if I can get them to automount at startup.

Thanks,
Brian
 
Old 01-02-2010, 02:56 PM   #2
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 673

Rep: Reputation: 94
i don't thing you can do that. as seen by me, you can't tell the xfce to auto mount at the boot.

use fstab to mount them at boot time.
 
Old 01-02-2010, 03:45 PM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
I don't know about xfce mounting the drives but I got an fstab entry and a udev rule to automount an external USB drive on boot up or if plugged in after booting. It unmounts when unplugged.The thread here explains my findings.
 
Old 01-02-2010, 03:48 PM   #4
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 673

Rep: Reputation: 94
fstab overrides udev, hal etc.
 
Old 01-02-2010, 07:00 PM   #5
hartz4ever
LQ Newbie
 
Registered: Nov 2006
Location: Aachen, Germany
Distribution: Slackware64 13.0
Posts: 5

Rep: Reputation: 0
exo-mount --help or http://www.slackwiki.org/Mount_with_...m_command_line
 
Old 12-12-2015, 06:40 AM   #6
hamaryns
LQ Newbie
 
Registered: Dec 2015
Posts: 1

Rep: Reputation: Disabled
There is an option for this (now?)

Hi, just go to disk management in the settings, ensure the disk is plugged in.
Click on the disk and the relevant partition, choose the two cogwheels below the partition overview.
Choose ‘edit mount options’
Turn the automatic options OFF
Check the box ‘mount at startup’.
OK

Cheers, H.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Only root can automount CD drive and USB thumb drive km4hr Red Hat 3 03-25-2009 01:30 PM
automount usb hard drive at startup kutlu Debian 8 01-05-2009 02:31 AM
USB drive won't automount linuxhippy Slackware 25 11-24-2007 11:52 AM
automount of usb drive konramesh Linux - Hardware 1 12-02-2006 11:16 PM
Automount USB disk at startup becho4 Linux - Software 1 07-08-2005 09:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration