-   Slackware (
-   -   XF86Config / startx / display resolution and screen area (

pbhj 12-14-2002 01:43 PM

XF86Config / startx / display resolution and screen area
[Newbie alert!]

So far have got Slackware 8.1 going on my Thinkpad 755cx and can now even 'use' X via startx. Only thing is that something is a miss with the display resolution and I can't see the whole screen area. Everything looks huge, even the login box (if I use xdm) doesn't fit on the screen. How can I correct for this? I've looked everywhere I could think :study:

Alot of posts about X problems say "use the Xconfigurator" is this a RH only app or can I just installpkg the .tgz file?

Everything else seems OK but this. Have tried running xvidtune but can't adjust the sliders with my set up, possibly because I can't get to the OK button (I assume it has one!) on the *Warning*.

Any help gratefully received.


Excalibur 12-14-2002 02:25 PM

LCD panels are often set to display fixed resolutions. If the X config is set for a larger desktop than the display is showing then the rest will be unusable. Sometimes the screen will scroll when you use the mouse, but not very often. Modify the screen display settings in the /etc/X11/XF86Config file. Just start with say 640x480 first get that working and then work up. The vertical refresh rates are also critical on LCD panels. You might also try to work with an external monitor connected and see if that helps any to get the config to working properly.

Good luck.

pbhj 12-14-2002 02:40 PM

Hmm, not much help I'm afraid. I'm currently using only 640x480 as screen mode ... the X cursor is literally as big as my thumbnail and the minimised clock is about 4x3 cm. I can actually see the textured background is 4 pixels for each one of my screens pixels. Anyone?

Excalibur 12-14-2002 02:59 PM

OK, then have you attempted going the other way then, 800x600 or 1024x768 as teh default?

pbhj 12-14-2002 06:44 PM

No, not on top form am I! Have just shut down for the night .. will let you know. Thanks for suggestions Excalibur.


pbhj 12-18-2002 05:45 AM

OK tried all different resolutions with no effect. Even tried xfree86setup - which just produced a blank screen. Also tried all the different configurations with an old SVGA (from an IBM PS/1) monitor but can't get anything.

I keep coming across suggestions for using SuperProbe .. how can I get hold of this for 8.1?


pbhj 12-18-2002 05:50 AM

Oh yeah, I also managed to use xvidtune (once I realised how to resize the windows using the alt key) and it didn't do anything for me.

Aussie 12-18-2002 10:28 AM

You might be able to fine some usefull information about linux on an IBM Thinkpad 755cx here and general linux on laptop info here.

pbhj 12-19-2002 05:45 PM

Thanks Aussie, I'd come across both these sites, however most of the Thinkpad 755cx stuff around seems to be out of date ... theres a couple of XF86config files available but neither seems to have the right bits ... I'll have another longer look (after Christmas) at the "sucks" site and get back here - for more help no doubt.


danu5 01-06-2005 08:17 PM

I was having the same problem (on a gateway laptop) and have just worked out a fix.

I am using minislack .02 but I assume much of the config will be the same.


at console login as root.
then you need to see what the file for your display settings is called so type

ls /usr/bin/X11
hopefully you will see a file

this is the replacement for


IF xorg exists then edit it using vi or whatever you have

vi /usr/bin/X11/xorg.conf
then scroll down for ages until you come to a section on the screen. You should see that there are three or four settings stating

default display XX
find the one that is not # ed out. In my case it was 24.
Then continue scrolling until you find the screen with depth set at 24 (or your number). at the next line it should say

Modes "1024xXXX" "800x600" etc
put a # at the start of this line so that it is commented out.
next write

Mode "800x600"
on a new line. You have now set the default resolution. (You may need a different setting) exit and save in vi ( push : the w <enter> then : q <enter>) and startx

I am recalling all the settings and details from the top of my head so please excuse the lack of complete accuracy. If anything is too complex or whatnot just give me a reply and I will try and copy the exact file contents.

All times are GMT -5. The time now is 05:29 AM.