LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-12-2017, 08:12 AM   #1
martinsch
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
XDM and permissions


I'm using Slackware (at the moment Slackware 14.2) now for several years and this is my first question to the audience:

When I log into X (fluxbox) over XDM (runlevel 4) as normal user and want to start my Scanner (Canon lide 50) there appears a message, that there is no scanner available. If I do this as root, there is no trouble and I can scan.

My workaround at the moment is following, I start using runlevel 3 and get into X (fluxbox) by typing startx and I can use my scanner as normal user.

How can i get it work as normal user and using XDM?

thanks to all replies

Martin

Last edited by martinsch; 11-12-2017 at 08:18 AM. Reason: Update
 
Old 11-12-2017, 08:49 AM   #2
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,571

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
This is probably happening because you didn't add your user to the recommended groups (when using the adduser command, at one point it will prompt you to press "up" to add the user to the recommended groups). Slackware will temporarily add a user to some groups by default if booting to runlevel 3, but it doesn't with runlevel 4.

The recommended groups in Slackware 14.2 are:

Code:
jbhansen@craven-moorhead:~$ groups
users lp floppy audio video cdrom plugdev power netdev scanner
To add yourself to those groups, run the following command as root, replacing $USER with your local username.

Code:
usermod -a -G lp floppy audio video cdrom plugdev power netdev scanner $USER
You may need to log out and log back in for this to take effect.
 
2 members found this post helpful.
Old 11-12-2017, 09:16 AM   #3
martinsch
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Perfect! After adding my user-id to the recommended groups the Scanner works when logging-in over Xdm.

Greets, martin

Last edited by martinsch; 11-12-2017 at 01:50 PM.
 
Old 11-12-2017, 09:50 AM   #4
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,318

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
Quote:
Originally Posted by bassmadrigal View Post
Slackware will temporarily add a user to some groups by default if booting to runlevel 3, but it doesn't with runlevel 4.
Interesting. What's the reasoning behind that?
 
Old 11-12-2017, 05:08 PM   #5
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,571

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
Quote:
Originally Posted by Gerard Lally View Post
Interesting. What's the reasoning behind that?
Alien Bob states that it only applies to users logging into the console (meaning they're physically at the computer, not a remote ssh) allowing them access to local hardware, where graphical logins can be remote and you don't want them to have access to local hardware unless specifically allowed. The default groups are covered in /etc/login.defs

Code:
#
# List of groups to add to the user's supplementary group set
# when logging in on the console (as determined by the CONSOLE
# setting).  Default is none.
#
# Use with caution - it is possible for users to gain permanent
# access to these groups, even when not logged in on the console.
# How to do it is left as an exercise for the reader...
#
# Most of these groups are self-explanatory, but in the case of
# "lp", it is because group lp is needed to use a scanner that
# is part of a multifunction printer.
#
# Note that users are added to these default groups only when
# logging into a shell with /bin/login, not when using a login
# manager such as kdm.  In that case, users who should have
# hardware access must be added to the appropriate groups
# when the user is added with adduser or useradd, or by editing
# /etc/group directly, preferably using "vigr"
#
CONSOLE_GROUPS         floppy:audio:cdrom:video:lp:scanner
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Xtreme Download Manager (XDM) 2015 Released, Amazing Development By Team, Install/Upgrade XDM LXer Syndicated Linux News 2 08-27-2015 08:29 AM
xorg seems to have different permissions depending on if started by xdm or qingy theW Linux - Newbie 2 12-09-2011 11:48 AM
[SOLVED] xdm init script problem - /var/run/xdm.pid is gone ? Vilius Debian 2 09-16-2010 04:06 AM
disabling XDM-AUTHORIZATION-1 in xdm shpenat Linux - Desktop 0 03-18-2009 10:11 AM
XDM opens XDM after login jpbarto Linux - Software 1 01-26-2004 11:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration