-   Slackware (
-   -   xcircuit - Segmentation fault (

brodo 10-14-2013 02:18 PM

xcircuit - Segmentation fault

I compiled several versions of xcircuit using build script from SBo.
Compilation seems to be OK, but invoking program itself gives me nothing but segmentation fault ... :-(

Any ideas to fix it ?

fskmh 10-14-2013 03:07 PM

I also noticed this right after the upgrade on -current to tcl-8.6.0 and tk-8.6.0. I just tried upgrading to xcircuit 3.8.44 and that didn't help.
I upgraded to tcl-8.6.1 and tk-8.6.1 (with modifications made to the slackbuilds using and and now xcircuit works again.

Hope that helps.

briselec 10-15-2013 03:18 AM

It was working fine on my Slackware 14.
Have you tried gschem? Much better design in my opinion with a lot more symbols available.

brodo 10-15-2013 04:42 PM

Upgrading tk and tcl to version 8.6.1 fixed this problem.

As to Gschem - I'll take a look at it !

Thanks :-)

Spect73 10-16-2013 12:39 AM


Originally Posted by brodo (Post 5046407)
Upgrading tk and tcl to version 8.6.1 fixed this problem.

As to Gschem - I'll take a look at it !

Thanks :-)

Glad you solved your problem. Several years ago I needed some circuitry done up that couldn't be done by any of the modern programs. Reason: recreating an ancient machine. Needed the symbology to match the originals. Found the solution on my Slack box. Between gcc and ghostscript, I simply wrote a series of schematic layout tools in C, and some symbol templates in Postscript. The C programs output the Postscript, which I could verify with gv. After everything was in order, I would just print it out. Rather time consuming, yet it has evolved into a fairly general purpose toolset which I use whenever I feel like dabbling with some homebrew circuitry.

Alien Bob 10-16-2013 05:13 AM

Check the latest ChangeLog.txt update of Slackware-current:

Wed Oct 16 05:36:47 UTC 2013
tcl/tcl-8.6.1-x86_64-1.txz: Upgraded.
      Thanks to fskmh.
tcl/tk-8.6.1-x86_64-1.txz: Upgraded.
      Thanks to fskmh.


All times are GMT -5. The time now is 04:11 AM.