-   Slackware (
-   -   Xbox 360 Controller (

fatalerror0x00 11-23-2012 11:34 AM

Xbox 360 Controller
I'm trying to get an xbox 360 controller working on linux. I read somewhere there is a builtin module in the kernel for it and I tried googling about it but I don't find much related to the kernel. I wanna try out the kernel one if it exist still or at all before I move on to a nother program incase the kernel is all i need or want. Also if this module dosn't exisit anymore or I'd have to recompile my kernel just to get it then what are my alternatives I've found some but I would like some user input thank you :)

H_TeXMeX_H 11-23-2012 11:37 AM

It is here:

  ┌───────────────────────── X-Box gamepad support ─────────────────────────┐
  │ CONFIG_JOYSTICK_XPAD:                                                  │ 
  │                                                                        │ 
  │ Say Y here if you want to use the X-Box pad with your computer.        │ 
  │ Make sure to say Y to "Joystick support" (CONFIG_INPUT_JOYDEV)          │ 
  │ and/or "Event interface support" (CONFIG_INPUT_EVDEV) as well.          │ 
  │                                                                        │ 
  │ For information about how to connect the X-Box pad to USB, see          │ 
  │ <file:Documentation/input/xpad.txt>.                                    │ 
  │                                                                        │ 
  │ To compile this driver as a module, choose M here: the                  │ 
  │ module will be called xpad.                                            │ 
  │                                                                        │ 
  │ Symbol: JOYSTICK_XPAD [=m]                                              │ 
  │ Type  : tristate                                                        │ 
  │ Prompt: X-Box gamepad support                                          │ 
  │  Defined at drivers/input/joystick/Kconfig:279                        │ 
  │  Depends on: !S390 && !UML && INPUT [=y] && INPUT_JOYSTICK [=y] && \  │ 
  │ USB_ARCH_HAS_HCD [=y]                                                  │ 
  │  Location:                                                            │ 
  │    -> Device Drivers                                                  │ 
  │      -> Input device support                                          │ 
  │        -> Generic input layer (needed for keyboard, mouse, ...) (INPUT │ 
  │          -> Joysticks/Gamepads (INPUT_JOYSTICK [=y])                  │ 
  │  Selects: USB [=y]                                                    │

Make sure to also select 'X-Box gamepad rumble support' and 'LED Support for Xbox360 controller 'BigX' LED'.

dugan 11-23-2012 11:50 AM

So try the following?


modprobe xpad

fatalerror0x00 11-23-2012 11:57 AM

Maybe I'm just not seeing it but how do I get to that...? Because I don't see any command just instruction and/or some sort of documentation you pasted for me to read that has instructions but no matter whatever this is I have no idea how to run it. Thanks for the reply though much appreciated :)

H_TeXMeX_H 11-23-2012 01:59 PM

Well, when you configure the kernel search for 'CONFIG_JOYSTICK_XPAD'. The module is available on both generic and huge slackware kernels, so run 'modprobe xpad' in a terminal as dugan suggests.

fatalerror0x00 11-23-2012 05:18 PM

k then how do I configure it would I just run the command "xpad" I assume that be correct but I'm trying to figure out what the first post's command is and so I assume at first run it will show me that but don't want to mess with it if I don't have to

manwichmakesameal 11-23-2012 06:31 PM

No. You will not use the "xpad" command. The configuration of the controller is going to depend on the application. In order for anything to be able to use it, you have to have the module loaded. It's probably going to be loaded upon plugging it in, but to do it manually, as root type this:

modprobe xpad
That will load the kernel module.

edit: Oh, yeah,... If this is the charge and play pack, good luck. As far as I know, the only controller to enumerate as a HID is the wired only controller.

speck 11-23-2012 10:48 PM

I have one and it just worked when I installed 14.0 (32 bit), I didn't have to do anything other than configure it inside the various games.

Roberto Neri 11-24-2012 03:19 AM

Hi all,
as an alternative to the xpad kernel module I would like to suggest the xboxdrv-linux utility (SlackBuild available).
I recommend reading the documentation at, there's not just the manpage but also a lot of extra useful information.
Personally I adopted the solution described in the "Using a single controller" paragraph, and it worked like a charm, no kernel rebuilding or other work around has been necessary.
I just would like to add that I have a XBox360 Wireless gamepad, the wireless controller is assigned to /dev/input/js0, while the gamepad itself is assigned to /dev/input/js1, to use the gamepad in DOSBox I had to pass the SDL_JOYSTICK_DEVICE=/dev/input/js1 environment variable, while I didn't have to do so for Wine (again, you'll find more information about potential issues like these in the documentation page).

fatalerror0x00 11-24-2012 05:15 PM

that what you suggested Roberto_Neri is what I was thinnking about using :) just gotta find the time to sit down with the controller to do this :)

All times are GMT -5. The time now is 09:32 PM.