LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-11-2011, 02:37 PM   #1
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Rep: Reputation: 8
xbmc wont start


I'm running slack 64 13.1 and to this point I've been running the latest gnome slack build. I've been trying to install xbmc though, as this box is only going to act as a media center. I downloaded the slackbuild for xbmc and all the required and optional dependencies listed in the slackbuild. Installed all the slackbuilds for the dependencies (optional ones and required ones) with no problems, then installed the xbmc slackbuild with no problems.

First I tried to start xbmc from within gnome (This was my fault for not noticing it was a desktop manager in itself). This killed X which quickly restarted back to the gdm login window. So then I restarted without starting gdm on startup, and tried to run xbmc. Here I can see several errors, which i can't manage to log to a file I tried "xbmc > log", "`xbmc` > log" and even "echo `xbmc` > log" all to no avail, they print nothing in log. Checking the log file for xbmc shows no errors:

Code:
bash-4.1$ cat ~/.xbmc/temp/xbmc.log 
15:20:41 T:140147691894752 M:750964736  NOTICE: -----------------------------------------------------------------------
15:20:41 T:140147691894752 M:750948352  NOTICE: Starting XBMC, Platform: Linux (Slackware 13.1.0, 2.6.33.4 x86_64). Built on Jan 11 2011 (SVN:Unknown)
15:20:41 T:140147691894752 M:750948352  NOTICE: special://xbmc/ is mapped to: /usr/share/xbmc
15:20:41 T:140147691894752 M:750948352  NOTICE: special://xbmcbin/ is mapped to: /usr/lib64/xbmc
15:20:41 T:140147691894752 M:750948352  NOTICE: special://masterprofile/ is mapped to: /home/howard/.xbmc/userdata
15:20:41 T:140147691894752 M:750948352  NOTICE: special://home/ is mapped to: /home/howard/.xbmc
15:20:41 T:140147691894752 M:750948352  NOTICE: special://temp/ is mapped to: /home/howard/.xbmc/temp
15:20:41 T:140147691894752 M:750948352  NOTICE: The executable running is: /usr/lib64/xbmc/xbmc.bin
15:20:41 T:140147691894752 M:750948352  NOTICE: Log File is located: /home/howard/.xbmc/temp/xbmc.log
15:20:41 T:140147691894752 M:750948352  NOTICE: -----------------------------------------------------------------------
15:20:42 T:140147691894752 M:750874624  NOTICE: Setup SDL
So I tried to turn on debuggging via the advancedsettings.xml file:
Code:
bash-4.1$ cat ~/.xbmc/userdata/advancedsettings.xml 
<advancedsettings>
	<loglevel hide="false">2</loglevel>
</advancedsettings>
This doesn't change the log file at all. I also tried to change the session to xbmc from the gdm login manager (right before I enter my user data) Again this just restarts X back to the gdm login manager. Any ideas what's going wrong, or where I can find more info?
 
Old 01-11-2011, 02:43 PM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,316

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
xbmc is not a desktop manager: I launched it inside lxde or kde sessions, it simply run full screen by default.

I guess the problem you got could be probably related to graphics drivers, as xbmc uses sdl/opengl.

Last edited by ponce; 01-11-2011 at 02:52 PM.
 
Old 01-11-2011, 03:01 PM   #3
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by ponce View Post
xbmc is not a desktop manager: I launched it inside lxde or kde sessions, it simply run full screen by default.

The problem you got could be probably related to graphics drivers, as xbmc uses sdl/opengl.
Alright well thanks for the correction there. I'm using the free radeon driver, which does have DRI enabled. SDL is installed, and I even went the extra mile and installed the SDL_* packages on slackbuilds.org. Any thoughts?
 
Old 01-11-2011, 03:14 PM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,316

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
try launching it in a terminal redirecting standard error too
Code:
xbmc > /tmp/xbmc.log 2>&1
so you should have a log after X crash (but have a look also at /var/log/Xorg.0.log after).
 
Old 01-11-2011, 03:46 PM   #5
linuxs64
Member
 
Registered: Jun 2010
Posts: 93

Rep: Reputation: 39
Are you using compiz? I've compiled both xbmc-9.11 and -10.0 yesterday on slackware/gsb-current and launched without problems.

xbmc-9.11 slackbuild
- disable-external-ffmpeg
- disable-external-libraries
 
Old 01-11-2011, 04:32 PM   #6
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by linuxs64 View Post
Are you using compiz? I've compiled both xbmc-9.11 and -10.0 yesterday on slackware/gsb-current and launched without problems.

xbmc-9.11 slackbuild
- disable-external-ffmpeg
- disable-external-libraries
I just installed all the compiz packages from the gsb repos and restarted the comp, then used the compiz-Gnome session when gdm launched. Again tried to run xbmc and the same thing happened once again.

Also I tried "xbmc > /tmp/xbmc.log 2>&1" to find an empty /tmp/xbmc.log file once again.
 
Old 01-11-2011, 04:59 PM   #7
linuxs64
Member
 
Registered: Jun 2010
Posts: 93

Rep: Reputation: 39
Quote:
Originally Posted by TheCrow33 View Post
I just installed all the compiz packages from the gsb repos and restarted the comp, then used the compiz-Gnome session when gdm launched. Again tried to run xbmc and the same thing happened once again.

Also I tried "xbmc > /tmp/xbmc.log 2>&1" to find an empty /tmp/xbmc.log file once again.
Try to run xwmconfig and select 'xinitrc.gnome', which is without compiz.
rename ~/.xbmc and try again.
 
Old 01-11-2011, 05:07 PM   #8
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by linuxs64 View Post
Try to run xwmconfig and select 'xinitrc.gnome', which is without compiz.
rename ~/.xbmc and try again.
same old story, crashes x. This was the window manager I was originally running (before trying compiz gnome).

Don't know if I mentioned this, but Xorg.0.log doesn't give any helpful info about the crash
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: XBMC 10.0 "Dharma" Beta 2 Released, How to Install Latest XBMC Beta in Ubuntu LXer Syndicated Linux News 0 09-15-2010 10:20 PM
X wont start fester2001 Linux - Software 2 09-02-2004 12:12 AM
x wont start! Username[SWE] Debian 5 08-02-2004 04:17 PM
x wont start jsmarshall85 Debian 14 07-22-2004 04:41 PM
X Wont Start Avatar33 Linux - General 3 10-09-2003 04:15 PM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration