-   Slackware (
-   -   Xauth: timeout in locking authority file //.Xauthority (

v@ny@ 12-14-2005 01:49 AM

Xauth: timeout in locking authority file //.Xauthority
I created a new user, so I don't use the computer as root all the time. But I am facing a few problems...:
1- I can login as this user, but when I type 'startx' it takes a long time to load the Xwindow and I get this message:

Xauth: timeout in locking authority file //.Xauthority.

The same message and strange delay appear when shutting down the Xwindow.

2- Even though I used pkgtool and configured KDE as my default Xwindow system, when I am logged in as 'user' and type startx it starts the 'blackbox' and not 'KDE'. If I am logged in as root and type startx it starts 'KDE', no problems...

3- When I am logged in as 'user' I cannot start firefox or any other program! How do I change the authorizaion so I can actually do stuff as user and not 'su' all the time I want to open a program?!

4- When logged in as 'user' I cannot shutdown the computer 'halt' or even 'reboot' the computer. How do I give the 'user' the ability to reboot and shutdown the computer?!

:scratch: :scratch: :scratch:

Toods 12-14-2005 02:59 AM

I have exactly the same problem.

At the console terminal, if logged in as the new user, I cannot chdir to the /home/"new usr" directory. I have tried chmod to give all permissions to everyone but still no success.

I think I hasve a 'beginners problem' here with creating a new user. I tried both 'useradd' and 'addusr'.

It would be really helpful here if an experienced user would give us a simple step-by-step guide to creating this 'new user'.

gbonvehi 12-14-2005 04:04 AM

To add correctly a user, just use (and try to use defaults settings by just pressing enter): adduser

v@ny@: Probably your /home directory is not setted correctly, paste /etc/passwd here. useradd is a tricky command and has to be called carefully, try using adduser (create another user just to test).
2) You can configure each user's default window manager by running xwmconfig as the user.
3) Are you running X as the user?
4) Learn how to configure sudo (man sudo && man sudoers)

v@ny@ 12-15-2005 01:30 AM

2- When I type 'wxmconfig' as the 'user' I get an error saying this command does not exist.
3- I am trying to run as the user but it doesn't work... So rigth now I am using as root.
4- I'll check this out! Thanks!

Here is passwd:

rpc:x:32:32:RPC portmap user:/:/bin/false

v@ny@ 12-15-2005 02:04 AM

I have deleted this user and created a new user following this commands you gave. Now it all works, thanks! When I created the previous user I used the command useradd (as it is shown in the Slackware Handbook). Now I used adduser as you said. I thought they did the same thing but now I see...

gbonvehi 12-15-2005 04:01 AM

Glad to hear that.
Regarding the other stuff...
2) It's xwmconfig not wmxconfig.
3) Mmm, that should work, is it working now with the "new" user?

v@ny@ 12-15-2005 11:16 AM

Yes! It is all working with the new user...
Thanks! And thankyou also for the packages you wrote the links to, to get Cyrilic working (! The other links were down, but those ones you wrote worked and now it is all good! Thank you very much! How did you find those links? I was looking for it but could not find!


Toods 12-17-2005 12:38 PM

Stillnot Working
I had originally the same problem creating a new account as V@NY@.

I have followed the recommended procedure in the thread but still I cannot use my new USER account properly:

1. My /home partition is FAT32.
2. I created new USER, 'bill'( using 'adduser')
3. Logged in as 'bill'.
4. From console, able to change directory to /home/bill.
5. Try to StartX (KDE) and get errors about not being able to write to files in /home/bill
6. Go back to console prompt, logged in as 'bill'. Now very strange - can no longer change directory to /home/bill.

Tried to run 'xwmconfig' but again cannot do as cannot access /home/bill

I am really puzzled by all this and would really appreciate some help.

Many thanks.

gbonvehi 12-17-2005 01:07 PM

Fat32 filesystem doesn't support linux permissions. You could set the correct permissions during mount using the correct parameters, but they will be lost when umount/mount again.

acelere 11-25-2006 02:18 AM

I had the same problem and in my case, what was wrong was permitioning:

My original .Xauthority file was owned by root.
For some reason, I had chown it to another user.
That is when X forwarding stopped working.
All I had to do was chown it back to root and it worked.


cstan 03-27-2007 09:25 AM

I also faced the same problem but i am using red hat 6.0

the following was my situation, hope expert can help me.

I had server in my working company, i tend to remote desktop to that server from my hostel.
I had install SSH client and "Xming" in my laptop (XP platform).

this error msg i get when i connect with SSH client:
/usr/X11R6/bin/xauth: timeout in locking authority file /.Xauthority

I had chmod the permission of the "usr" folder to all (include sub folder)

what should i do for next for me to remote desktop?

thank a lot.

trebek 09-26-2007 02:57 PM

I had this same problem and applied the solution you suggested. That worked because i got X loaded again with the new user. Problem is that i cannot sudo to anything, it doesn't ask me for the root password. At this point, it doesn't even tell me that the new user isn't in the sudoers file, which i get very often.

I got out of X so that i could login as root, but i can't. So there is no way for me to perform changes cause i can't get root privileges.

What to do?

Alien Bob 09-26-2007 03:04 PM

What to do????
Open a new thread and describe your problem clearly, as well as the things you tried to solve it, and how these failed. That will attract people who can help you. With the information you supply here, no one will be able to assist unless they are in possession of a crystal ball.
Please do not ressurrect long-dead threads, they stink.


trebek 09-26-2007 04:52 PM

Well, no need to do that. Some extensive googling and search over at lq did the job.

Thanks anyways.

nehaljwani 11-20-2013 05:52 AM

For those who are still not able to resolve the error after changing permissions, you need to change the mode of selinux from enforcing to permissive. Become root and either edit the file /etc/sysconfig/selinux or just type setenforce 0 for one session.

All times are GMT -5. The time now is 06:01 PM.