LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-11-2019, 12:04 PM   #1
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: Slackware64 current running TWM
Posts: 449

Rep: Reputation: 116Reputation: 116
xauth/.serverauth issue with startx


This is a full install of slackware64-current logging in to TWM.

I always boot to runlevel 3 then startx from there. When I do I always get a delay with the message:

Code:
xauth file /home/rkfb/.serverauth.XXXX does not exist
I can hit Control-C to break it and it'll then load the desktop or if I wait it seems to timeout after a while and then proceed.

Although it was a full install, I did retain my home directory unformatted from the previous slackware64-14.2 install, I don't know if that's relevant at all.

It's not a desperate situation as it's only about a 15 second delay but it's not something I've seen before however and I'm not sure how to resolve it.
 
Old 02-11-2019, 12:30 PM   #2
ericgreenwood123
LQ Newbie
 
Registered: Feb 2019
Distribution: Debian, Voyager GS
Posts: 18

Rep: Reputation: Disabled
Hi, you could try editing your "/usr/bin/startx".

There should be lines in it somewhere which lock like this:
Code:
# create a file with auth information for the server. ':0' is a dummy.
    **xserverauthfile=$HOME/.serverauth.$$**
    trap "rm -f '$xserverauthfile'" HUP INT QUIT ILL TRAP KILL BUS TERM
    xauth -q -f "$xserverauthfile" << EOF
add :$dummy . $mcookie
EOF
and change the line **xserverauthfile=$HOME/.serverauth.$$** to **xserverauthfile= `mktemp -p /tmp serverauth.XXXXXXXXXX`**

hope this helps,
Eric.

PS. the ` signs around `mktemp -p /tmp serverauth.XXXXXXXXXX` are the button usually above Tab, not quotes.

Last edited by ericgreenwood123; 02-11-2019 at 12:33 PM.
 
Old 02-11-2019, 12:34 PM   #3
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 502

Rep: Reputation: 171Reputation: 171
Just how many .serverauth.XXXX do you have? I deleted them all to clear that problem and now there are only 2 and no error
 
Old 02-11-2019, 12:36 PM   #4
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 2,669
Blog Entries: 6

Rep: Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355Reputation: 1355
I don't get this in Slackware 14.2 but I used to get it regularly in Crux. It has something to do with the xauth procedure used in /usr/bin/startx. Maybe it would be worth comparing the startx script between 14.2 and current.

@Gordie. Crux never deleted stale .serverauth files either. I'm sure the two things are connected.

Last edited by hazel; 02-11-2019 at 12:42 PM.
 
1 members found this post helpful.
Old 02-11-2019, 03:50 PM   #5
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: Slackware64 current running TWM
Posts: 449

Original Poster
Rep: Reputation: 116Reputation: 116
ericgreenwood123:
$startx
/usr/bin/startx: line 187: /tmp/serverauth.FGf0NoUClh: Permission denied
xauth: file does not exist
xauth: unable to link to authority file , use -n
xauth: timeout in locking authority file /home/rkfb/.Xauthority

Gordie: I have none. I deleted whatever I had when it first started happening thinking it would just regenerate one, but no .serverauth file has ever re-appeared.

Thanks to you both.
 
Old 02-11-2019, 04:43 PM   #6
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 502

Rep: Reputation: 171Reputation: 171
Well XFCE and KDE both make them so maybe switch to one of them and login and then switch back to TWM and see if that helps?
 
Old 02-12-2019, 03:50 AM   #7
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,694

Rep: Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469Reputation: 3469
You should also check the permissions of /tmp/ to make sure it has the correct permissions. On my 14.2 box, /tmp/ is listed with drwxrwxrwt permissions.
 
Old 02-12-2019, 11:17 AM   #8
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: Slackware64 current running TWM
Posts: 449

Original Poster
Rep: Reputation: 116Reputation: 116
I now have .serverauth.1208 and .serverauth.26614 listed, maybe from logging in to XFCE as suggested. The /tmp permissions match those listed by Bassmadrigal. I still get the error however with a different random number attached each time.

I believe something has gone wrong by me selecting to not format the /home partition during the install (I only formatted / and swap), I was hoping to avoid downloading gigs of files. If I have to I'll just reinstall and format all three, hopefully that should clear it.
 
Old 02-12-2019, 01:58 PM   #9
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 12,009

Rep: Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687Reputation: 3687
no, I do not think formatting may help you.
You may try to use lsof to identify who uses the .serverauth.XXX files.
These files (.serverauth.*) created when you start X, and can be deleted during shutdown (or reboot).
 
Old 02-13-2019, 08:33 AM   #10
ericgreenwood123
LQ Newbie
 
Registered: Feb 2019
Distribution: Debian, Voyager GS
Posts: 18

Rep: Reputation: Disabled
When i made my last post i did not mean typing startx. if you type: sudo nano /usr/bin/startx then it will open the file in the nano text editor and you can edit the lines there.
also what happens if you type sudo startx? because the output text said 'Permission denied.'
Quote:
Hi, you could try editing your "/usr/bin/startx".

There should be lines in it somewhere which lock like this:
Code:
# create a file with auth information for the server. ':0' is a dummy.
    **xserverauthfile=$HOME/.serverauth.$$**
    trap "rm -f '$xserverauthfile'" HUP INT QUIT ILL TRAP KILL BUS TERM
    xauth -q -f "$xserverauthfile" << EOF
add :$dummy . $mcookie
EOF
and change the line **xserverauthfile=$HOME/.serverauth.$$** to **xserverauthfile= `mktemp -p /tmp serverauth.XXXXXXXXXX`**

hope this helps,
Eric.

PS. the ` signs around `mktemp -p /tmp serverauth.XXXXXXXXXX` are the button usually above Tab, not quotes.
 
Old 02-13-2019, 08:41 AM   #11
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,712

Rep: Reputation: Disabled
Maybe files in your $HOME are owned by root. You can find out with these commands:
Code:
cd
find -uid 0
Then, use chown as root to transfer ownership of these to you as regular user.
 
Old Today, 04:00 PM   #12
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: Slackware64 current running TWM
Posts: 449

Original Poster
Rep: Reputation: 116Reputation: 116
ericgreenwood123:
I edited the files in emacs:

Code:
startx
/usr/bin/startx: line 187: /tmp/serverauth.WzWWbSGXAD: Permission denied
xauth: file does not exist
xauth: unable to link authority file , use -n
xauth: timeout in locking authority file /home/rkfb/.Xauthority
Didier Spaier: That returns a blank line, sorry.
 
Old Today, 04:04 PM   #13
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: Slackware64 current running TWM
Posts: 449

Original Poster
Rep: Reputation: 116Reputation: 116
startx as root however has no issues, it's only as a normal user that I get problems,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Xauth file home/user/.serverauth.2348 does not exist - cent os Harshit_24 Linux - Newbie 2 05-12-2018 08:52 AM
xauth: file /home/semoi/.serverauth.2263 does not exist stf92 Slackware 11 03-29-2016 02:23 PM
[SOLVED] Xauth file home/user/.serverauth.1436 does not exist Fibonacchoz Slackware 3 03-29-2016 02:23 PM
startx fail: .serverauth.2571 + fbdev + /dev/tty0 Drone4four Slackware 23 01-18-2012 02:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration