Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 11-15-2003, 02:00 AM   #1
LQ Newbie
Registered: Nov 2003
Location: Germany
Distribution: Slackware 7.0 - 10.0
Posts: 26

Rep: Reputation: 15
X11 Nvidia crash

I got a little problem with my X and maybe the NVIDIA Drivers(I'am using the latest from

X crashes after an uptime of about 1 day and all I get is a lot of funny asciis on my screen and everythings freezed.

All I can do is killing the X from another box connecting with ssh...
Old 11-15-2003, 04:14 AM   #2
Registered: May 2003
Location: Calgary, Canada
Distribution: Arch Linux
Posts: 194

Rep: Reputation: 30
Maybe you can kill the session with Ctl+Alt+Backspace instead of doing it remotely.

I have two machines with Slackware/NVidia FX 5200 and don't have the problem you describe.
Old 11-15-2003, 06:44 AM   #3
Senior Member
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,257

Rep: Reputation: 48
I haven't had that problem. Did you edit your X config per the directions when you installed the drivers?
Old 11-15-2003, 08:02 AM   #4
LQ Newbie
Registered: Nov 2003
Location: Germany
Distribution: Slackware 7.0 - 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
I added Driver "nvidia" to the XF86Config.

Thats what lspci tells me about the card:

01:05.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
Old 11-15-2003, 11:01 AM   #5
Registered: Nov 2003
Location: India
Distribution: Slackware 13.0 32-bit
Posts: 129

Rep: Reputation: 16
apart from changing "nv" (if thats what u had earlier), to "nvidia", u also need to get rid of load "dri" and .... something else.... amn, forgot.... and make sure that load "glx" is uncommented..... Im still a noob, so I cant really help u much more than that... but I have nVidia too, and thats what I did, and its running fine for me... :-)
Old 11-18-2003, 04:16 AM   #6
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Rep: Reputation: 30
If you want the agp enabled you should also add "Option " NvAgp 1" " if your video card support it


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Nvidia & X11 browser Slackware 11 04-18-2005 08:15 AM
X11 Session Manager Crash At Boot lithiumfx Slackware 5 04-07-2005 01:29 AM
nvidia 66.29 driver-xorg-x11-Mesa-libGL conflict yellowtail Linux - Software 3 02-28-2005 08:34 PM
NVidia GeForce FX and vesafb does not restore from X11. Sijaiko Slackware 3 10-06-2004 07:18 AM
nvidia driver = crash!! rooman Linux - Newbie 13 07-08-2003 02:21 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:40 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration