-   Slackware (
-   -   X takes ages and ages to load! (

dcdbutler 03-07-2005 06:31 PM

X takes ages and ages to load!
I have a problem with X. When I do "startx", gnome takes ages and ages to load. The screen looks crap, and I can't access ANY application through the graphical interface. All I can do is exit gnome, which also takes an age.

I get a long list of errors on my console afterwards, all of which are saying basically the same thing:

(gnome-panel:3914): libgnomevfs-WARNING **: Cannot load module '/usr/lib/gnome-vfs-2.0/modules/' ( cannot open shared object file: No such file or directory)

(gnome-panel:3914): libgnomevfs-CRITICAL **: file gnome-vfs-cancellable-ops.c: line 176 (gnome_vfs_get_file_info_uri_cancellable): assertion `uri != NULL' failed

(gnome-panel:3914): libgnomevfs-CRITICAL **: file gnome-vfs-uri.c: line 916 (gnome_vfs_uri_unref): assertion `uri != NULL' failed

There's some other errors about not being able to open desktop panel launchers as well.

Hope someone can help, I'd be happy to post log files, or conf files.

kodon 03-07-2005 08:51 PM

do you have the gnome-vfs- package installed?
double-check that you installed ALL the gnome related packages.

dcdbutler 03-07-2005 09:45 PM

Just to be sure, I went to the 2nd cd, gnome dirctory, and installed every package there. Still no luck. then I did a swaret upgrade. No luck.

pkgtool tells me I have gnome-vfs- AND gnome-vfs-2.8.2 installed (presumably from a swaret upgrage). Should I try to remove 2.8.2?

X loads, very slowly, but seems to get stuck at the part where it's loading nautilus.

Now I'm getting a specific error from nautilus when I go to a virtual console and then try to get back to the console running X (X terminates with the following message):

nautilus: error while loading shared libraries: cannot open shared object file: No such file or directory

This error is not logged in /var/log/Xorg.0.log though, there's just a bunch of warnings from nvidia in there that I'm not too concerned with at the moment.

I've checked, and libcdda is installed.

I'm real stuck here and would love to hear any suggestions.


kodon 03-07-2005 10:26 PM

not sure where you would have gotten gnome-vfs-2.8.2.
swaret should not have installed it because the current tree uses
i'm sure you were told this before you installed swaret,
but make sure you DO NOT use the repositories...
double-check and make sure all the REPOS_ROOT lines are commented out.

just wondering, is this dropline?

dcdbutler 03-07-2005 10:38 PM

hee hee.
nobody told me not to use the repositories, I thought that was what they were there for! anyway, ahem, now the damage is done, what can be done to rescue X do you think?
I don't mind hosing, I'm quite used to it and almost enjoy it by now, if that is the best course of action. I certainly don't want more messed up shkt going on further down the road. I did an --upgrade -a with the repos enabled, so there's god only knows what on my box now.

Not sure who or what dropline is (hope this answers your question).

Thanks for all your help!


kodon 03-07-2005 10:54 PM

dropline is another possible headache.
(at least it was for me)

the safest way would be to use the package browser at
compare what you have installed against the current tree...
uninstall anything that doesn't match and install the correct package.

there are faster ways:
-uninstall all standard packages
-reinstall all packages from cd
-upgrade without repositories enabled
but the risk level is higher
and you would have to edit all your .confs again

movitto 03-22-2005 06:56 PM

Hi, Im having the same problem and was wondering if you found a solution. BTW i dont use swaret, Im a good-ol' fashion manual package installer.

As a side note, this problem started occuring right after my computer shut down due to a power owtage while I was logged in gnome. I was thinking that there is a lock file somewhere that has not been deleted, that I need to delete? Also I should mention that everything in gnome starts up and works just fine. Its just the gnome splash screen freezes and pauses for a good 5 - 10 minutes while on the nautilus icon. I can do everything, its just really annoying. I have tried logging out of gnome and logging back in but that problem is still there.

Thanks alot!

chbin 03-22-2005 07:15 PM

you need the cdparanoia- alpah package in /ap.

dcdbutler 03-23-2005 08:06 AM

I just reinstalled, but my problem was very different to yours

I've had a similar problem with stale locks, not on slackware but on redhat. It was after a power outage as well and seemed to correct itself after a while, not sure why, I was just messing around with the preferences in nautilus one day, then everything was fine again.

I never tried this, but was going to before things righted themselves, but you could try to backup then delete .gnome .gconfd and .nautilus directories of the home account that's giving you the problem then start a new gnome session. Should solve the problem in case cdparanoia doesn't.


movitto 03-23-2005 08:53 AM

Fixed somewhat
I backed up my .gnome, .gnome2, .nautilus, and .gnome_private directories and deleted them. The next time I started gnome the problem was fixed. Im not sure exactly which of the directories caused the problem, but its fixed. The only downside to this method is I had to reset up my panels and icons as the settings for those are in one of the folders I deleted, luckly its not too hard though.

All times are GMT -5. The time now is 04:40 AM.