-   Slackware (
-   -   X keyboard configuration and euro symbol (

derekp 02-23-2004 07:01 AM

X keyboard configuration and euro symbol
First off - Slackware is cool.
Now, within the "/etc/X11/XF86Config". When I specify Option "XkbSymbols" "gb" , I get an error whenever I startx. It tells me that xkbcomp can't load the file "gb" for geometry include (or something along those lines). I thought I should maybe add a specific geometry file to the Options, but no joy... I took a look at the "gb" file in /etc/X11/xkb/symbols and decided to change the option to Option "XkbSymbols" "gb(basic)" but to no avail. The same error message (filename changes, of course).

The reason I'm mucking around with this stuff is because I'm trying to configure my keyboard to show a Euro symbol () whenever I press "AltGr + 4". I know the AltGr key works with the current setup because I get output with various keystrokes. I know the font I'm using has a Euro symbol in it because I edited one into a text file in console and viewed it in X. I did try xmodmap and when I used the option -pke, saw "EuroSign" specified on the correct key, but still no output when I hit the keys.

I've done a search here and through XFree86's documentation, but can't see where I'm going wrong... Maybe I'm barking up the wrong tree altogether. Has anyone else managed to get a Euro symbol in their X session? Any pointers?

jkobrien 02-23-2004 07:32 AM


Here's the relevant section from my XF86Config

Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"


derekp 02-24-2004 05:28 AM

Thanks for the response, John. My XF86Config looked like that before I started messing around with it too(!) I presume you are getting a euro when you hit AltGr + 4? I'm completely baffled at this stage to be honest. I've had to settle for mapping it to Shift+4 with xmodmap and have put the dollar somewhere else... The successful command was xmodmap keycode 13 = 4 currency and not "EuroSign" as I thought it was. Maybe it is something to do with my font after all... what font do you use?

jkobrien 02-27-2004 04:53 AM

Sorry to be slow replying - I had disabled e-mailed notifications without realising it.

It turns out that I'm a bit of a fraud as I don't get a euro symbol in my xterms either - of course I don't need one there - but it works fine in OpenOffice and so on.


All times are GMT -5. The time now is 10:12 AM.