-   Slackware (
-   -   x broken: .serverauth does not exist (

2handband 11-17-2010 07:02 PM

x broken: .serverauth does not exist
I upgraded to qt 4.7.1 and it broke X. So I reverted to the older version of qt, and x is still broken! when I run startx I get the following error:


xauth: file /(user)/.serverauth.2474 does not exist


2handband 11-17-2010 07:49 PM

Update: I must apologize, I was really rushed when I did the above post. I DO get the login screen; whant i posted above is what I get after it crashes and i try to start x. Specifically, it crashes when I attempt to launch KDE... I've discovered since the initial post that I CAN log into XFCE (which is every bit as dreadful as i remember it). I also realized that I did not downgrade to the last version of qt; I downgraded to the one that was in the source tree on my hard drive: specifically the one that came with Slackware 13.1. So right now I'm upgrading to QT 4.6.3 and will check back when I find out how that goes.

But I's still like to know what happened (I really want to upgrade my QT so I can browse with Konqueror. I did this last week and it worked fine; how come QT 4.7.1 is now wrecking my KDE? Right now I can neither log in to KDE or launch any QT-dependant KDE apps from within XFCE. Can anyone help?

2handband 11-17-2010 07:55 PM

Another update: Going back to QT 4.6.3 fixed it; I'm back in KDE now. But what the heck? Why would upgrading QT kill KDE? Is there anything I can do about it? I need QT 4.7.x.

2handband 11-17-2010 10:01 PM

I'm going to mark this thread as solved and create a new one for the QT question.

All times are GMT -5. The time now is 09:15 PM.