-   Slackware (
-   -   X Apps wont load - libgtk not found - on Older Computer with SW 10.2 running FluxBox (

Tim Slackware 02-07-2006 11:17 AM

X Apps wont load - libgtk not found - on Older Computer with SW 10.2 running FluxBox
I have Slackware 10.2 installed on a Pentium 200 mhz with 32 megs of ram. I've gotten FluxBox working in 256 colour mode. When I run a console program or terminal, it works fine, but when I try to run any actual X Application like gaim, firefox, etc. nothing happens. Back in bash they all get the same error every time I try to run them:

gaim: error while loading shared libraries: cannot open shared object file: no such file or directory

(It seems to be having trouble finding the GIMP Toolkit libraries)

I do not have GIMP installed (I have limited HD, and I have another much better computer I use for stuff like that). I did go back to the Slackware CD and installed/reinstalled all of the gtk and glib related libraries, but it didn't change anything.

I've also checked out www-dot-gtk-dot-org/download/, but I could not figure out which glib/gtk I needed. And I figured that I should already have the library I need, it's just in the wrong place or something?

Any help would be greatly appreciated,

win32sux 02-07-2006 01:14 PM

the package that brings that file is called gtk+2-2.6.10-i486-1 (it's on CD1) but the file is actually a link to a file with a longer name... here's what it looks like on my box, make sure you have the gtk+2 package installed and the link set:


bash-3.00# ls -l /usr/lib/
lrwxrwxrwx  1 root root 26 2005-09-30 10:33 /usr/lib/ ->

bash-3.00# ls -l /usr/lib/
-rwxr-xr-x  1 root root 2952484 2005-09-10 14:03 /usr/lib/

just my :twocents:...

MS3FGX 02-07-2006 03:11 PM

Yes, you need the GTK libraries, not GIMP.

What does "ls /var/log/packages/gtk*" show?

Tim Slackware 02-08-2006 05:01 PM

Thanks win32sux! I did not have the link file. I re-installed gtk+2-2.6.10-i486-1, and a couple other libraries I also needed. I don't know why it didnt work the first 2 times I installed them. Works now though.

MS3FGX - It lists that link file with info, so it let's you know if you have the link.


All times are GMT -5. The time now is 05:02 AM.