-   Slackware (
-   -   X and console resolution problem (

hsimah 08-02-2008 11:46 PM

X and console resolution problem

I recently reinstalled Slackware 12.1 on my laptop, removing XP. I have been setting stuff up, and most things are going well.

My laptop has a WXGA resolution of 1366x768. To get my console to near to this I use vga=870 in lilo.conf and I get a nearly fullscreen framebuffer. Sweet.

When I start fluxbox, however, without editing xorg.conf at all, I get a screen resolution of 1360x768 matching my console one perfectly. I tried everything to change this, but nothing worked. So I changed lilo.conf to boot at 1024x768 (as per Slackware default). And lo and behold my X server starts at 1024x768.

So something is stopping X from reading xorg.conf, and I don't have the knowledge to figure out what.

I then started plugging random values into my lilo.conf in the vga=??? line, and upon passing an invalid resolution (vga=873) my console is running at 640x480, but when I run fbset it returns
/dev/fb0 no such file or directory

Where it should return the current resolution. Starting X from this console I get a perfect X resolution of 1366x768!

This confuses me greatly, as my xorg.conf states only 800x600, so it isn't that.

So what I want to know is how I can get a fullscreen console (or 1360x768 is close enough) AND a fullscreen X server (1366x768)


I set my lilo.conf back to vga=872. Then suddenly X would start at 800x600, or whatever other resolution I would tell it to use, so that clears up that.

Now the problem is to get 1366x768 to work in X. I used 915resolution to patch the bios, but that is patching it to 1368x768 unfortunately.

Alien Bob 08-04-2008 09:16 AM

I assume after reading your story that you are still using the VESA driver for X.Org (which is what Slackware puts in xorg.conf by default).
What happens when you run

and let the X server determine the optimal driver for your graphics card?


upon passing an invalid resolution (vga=873) my console is running at 640x480, but when I run fbset it returns
/dev/fb0 no such file or directory
Because of supplying an invalid 'vga' mode, your console will not be running in framebuffer mode but in VGA mode instead. When the console does not use the framebuffer, then X.Org is free do do as it pleases when it uses the VESA driver - and then it is able to run the perfect resolution for your screen. You already noticed that in all cases where you start X from a framebuffer console, your X resolution (using the VESA driver) will always match that of the framebuffer console, regarless of what you configure.

This should change when you switch to X.Org's Intel driver.


rob.rice 08-04-2008 01:02 PM

another option for setting up X is to run
"X -configure " this will write an file
and tell you how to test it if it works you can move it to
I have yet to see it use less than the highest resolution
the screen and adepter can do or not work

frushiyama 03-27-2013 10:28 PM

Old thread but i found this:
vga = 895 #1366x768 resolution
There is a list of hexa values when the vga is a invalid value then i found 37F for 1366x768.
37F = 895 in decimal, which works for my lilo.conf on Slackware64 current.

All times are GMT -5. The time now is 01:43 AM.