LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-20-2004, 09:08 AM   #1
Bothkill
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Rep: Reputation: 0
Wrong soundcards order


I'm very new to Linux and I've tried to solve this problem without success:

Slackware 10.0 detected 2 soundcards:

no.0 - bt878 (TV Tuner), and
no.1 - Audigy2

I suppose KDE uses as default the sound card no.0 since I have no sound.

How can I reverse that order?

Thank you !!!
 
Old 07-20-2004, 09:27 AM   #2
Marsanghas
Member
 
Registered: Sep 2003
Location: Spijkenisse, Netherlands
Posts: 119

Rep: Reputation: 15
First make sure that KDE actually IS using the tuner card. You mentioned being new at this, so maybe you need to run alsamixer first to unmute the sound?
 
Old 07-20-2004, 11:55 AM   #3
SBing
Member
 
Registered: Mar 2004
Posts: 519

Rep: Reputation: 35
Yes, just to extend on what MarsDude said, try

$ alsamixer -c 1

This should bring up the mixer settings for your sound card. Press <spacebar> to unmute the right channels and up and down to change volumes.
 
Old 07-20-2004, 04:37 PM   #4
Bothkill
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your replies .

Using alsamixer was one of the solutions I've tried before posting this subject.

Comparing to Slackware 10.0, the Slackware 9.1 distro assigned the "0" position for my Audigy soundcard and back then the sound was just fine.
Now, Slackware 10.0 reversed the assignments and I ended up with bt787(TV Tuner) being the first card (i.e. "0").

So, using
$ alsamixer -c 1
although I could tune the settings for the Audigy soundcard, it didn't do anything to hear any sound in KDE.

Anyway, today I just pulled out the TV Tuner card trying one last desperate solution.
And it worked !!!
Now Audigy is the no. "0" card and even the 5.1 sound is ok.

So, the problem is rather solved now, but it's annoying to pull out and put the TV Tuner card back in when switching to Windows.

I only imagine that if I could just reverse that soundcard order by modifying some .conf file, the problem will be solved elegantly .
 
Old 07-20-2004, 04:48 PM   #5
kryptobs2000
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 306

Rep: Reputation: 30
I have this same problem, and reading ur post reminded me that I'm having it since I have a tvtuner card in. I had forgotten that I had installed it awhile ago. Is there a way to change the order still tho? I would like to have both in, yet it use my onboard sound by defualt.
 
Old 07-21-2004, 01:15 AM   #6
SBing
Member
 
Registered: Mar 2004
Posts: 519

Rep: Reputation: 35
I don't have any specifics, but I've read it's possible by modifying .asoundrc

Personally, I just don't load the bttv sound module ;)
 
Old 07-21-2004, 05:04 PM   #7
Bothkill
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Unfortunately I couldn't find the ".asoundrc". Was it supposed to be somewhere or should I make it by using a certain command?

And what file should I modify in order not to load the bttv module?
 
Old 07-22-2004, 01:14 AM   #8
SBing
Member
 
Registered: Mar 2004
Posts: 519

Rep: Reputation: 35
.asoundrc is a per user file that you create in your home directory.

To create it, just run your favourite text editor:

vim ~/.asoundrc

Further reading is available on asoundrc
 
Old 07-22-2004, 01:36 AM   #9
phase9
Member
 
Registered: Mar 2004
Location: austria, vienna
Distribution: slackware-10.2
Posts: 89

Rep: Reputation: 15
Hi!

Quote:
Originally posted by Bothkill
Thanks for your replies .

Now, Slackware 10.0 reversed the assignments and I ended up with bt787(TV Tuner) being the first card (i.e. "0").

So, using
$ alsamixer -c 1
although I could tune the settings for the Audigy soundcard, it didn't do anything to hear any sound in KDE.

Anyway, today I just pulled out the TV Tuner card trying one last desperate solution.
And it worked !!!
Now Audigy is the no. "0" card and even the 5.1 sound is ok.

So, the problem is rather solved now, but it's annoying to pull out and put the TV Tuner card back in when switching to Windows.

I only imagine that if I could just reverse that soundcard order by modifying some .conf file, the problem will be solved elegantly .

KDE/Alsa uses /dev/dsp as sound device. It seems /dev/dsp0 is your tv card and /dev/dsp1 your sound card. Normally /dev/dsp is a link to /dev/dsp0. Try to link /dev/dsp to /dev/dsp1 or use in 'KDE Control Center / Sound & Multimedia / Sound-System/ Hardware [Tab] / Override device location' the appropriate device (eg. /dev/dsp1).
 
Old 07-22-2004, 05:13 AM   #10
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
See the answer to my bug report to alsa at: https://bugtrack.alsa-project.org/al...bug_id=0000359
 
Old 07-22-2004, 06:19 AM   #11
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,291

Rep: Reputation: 52
options snd-ens1371 index=0
options snd-bt87x index=1

works for me, many thanks.
 
Old 07-22-2004, 05:10 PM   #12
Bothkill
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Yes!!!!! That was it.

Adding to the "modules.conf":

options snd-emu10k1 index=0
options snd-bt87x index=1

worked for me too.

Thanks to all who posted solutions, especially davidsrsb .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple sound devices -- configured in the wrong order kwr2k Linux - Hardware 2 08-18-2006 02:51 AM
Partitions in wrong order nukey Slackware 5 05-15-2005 05:50 AM
Filenames are sorted in wrong order Simoncifer Linux - Newbie 4 01-07-2005 12:52 AM
CUPS printing in wrong order boyceman Linux - Software 0 11-05-2004 10:12 AM
ALSA Problem: 2 soundcards, wrong order PrivatePanic Linux - Hardware 4 09-04-2003 01:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration