LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-11-2009, 09:00 AM   #1
feurry
LQ Newbie
 
Registered: Dec 2009
Posts: 7

Rep: Reputation: 0
wpa_supplicant not starting on boot, need to manually start wireless


When i start the computer, my wireless network is not being started.
'wpa_cli status' shows that wpa_supplicant is not running. In order to get my network i simply start wpa and then restart my eth1 (wireless) card and it works.
wpa_supplicant -ieth1 -Dwext -c/etc/wpa_supplicant.conf -B
/etc/rc.d/rc.inet1 eth1_restart

I have added 60 second wait time for wpa in /etc/rc.d/rc.inet1.conf but it doesn't solve the problem.

uname -a
Linux repete 2.6.29.6 #2 SMP Mon Aug 17 11:58:18 CDT 2009 x86_64 AMD Turion(tm) 64 X2 TL-60 AuthenticAMD GNU/Linux
Running slackware 13

relevant section of rc.inet1.conf (note that i have not touched rc.wireless.conf)

# Config information for eth1:
#IFNAME[1]=""
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="repete"
WLAN_ESSID[1]=MyNet
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
WLAN_WPAWAIT[1]=60

/etc/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
scan_ssid=0
proto=WPA RSN
key_mgmt=WPA-PSK WPA-EAP
pairwise=CCMP TKIP
group=CCMP TKIP
ssid="MyNet"
#psk="Secret"
psk=a bunch of numbers
}

I have the wl driver for my broadcom card.
The last bit of dmesg

forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x5043 @ 1, addr 00:1d:72:52:36:01
forcedeth 0000:00:0a.0: highdma pwrctl mgmt timirq lnktim msi desc-v3
k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141
wl: module license 'unspecified' taints kernel.
ACPI: PCI Interrupt Link [LK4E] enabled at IRQ 21
wl 0000:04:00.0: PCI INT A -> Link[LK4E] -> GSI 21 (level, low) -> IRQ 21
wl 0000:04:00.0: setting latency timer to 64
eth1 (wl): not using net_device_ops yet
input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio2/input/input12
lib80211_crypt: registered algorithm 'TKIP'
eth1: Broadcom BCM4315 802.11 Wireless Controller 5.10.91.9
ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 20
HDA Intel 0000:00:07.0: PCI INT A -> Link[LAZA] -> GSI 20 (level, low) -> IRQ 20
HDA Intel 0000:00:07.0: setting latency timer to 64
input: HDA NVidia Mic as /devices/pci0000:00/0000:00:07.0/input/input13
input: HDA NVidia Mic as /devices/pci0000:00/0000:00:07.0/input/input14
input: HDA NVidia Headphone as /devices/pci0000:00/0000:00:07.0/input/input15
ACPI: PCI Interrupt Link [LGPU] enabled at IRQ 19
nvidia 0000:00:12.0: PCI INT A -> Link[LGPU] -> GSI 19 (level, low) -> IRQ 19
nvidia 0000:00:12.0: setting latency timer to 64
NVRM: loading NVIDIA UNIX x86_64 Kernel Module 190.42 Tue Oct 20 20:25:42 PDT 2009
Adding 1461872k swap on /dev/sda6. Priority:-1 extents:1 across:1461872k
fuse init (API version 7.11)
isa bounce pool size: 16 pages
scsi 4:0:0:0: Direct-Access TOSHIBA MK2546GSX PQ: 0 ANSI: 2
sd 4:0:0:0: [sdb] 488397168 512-byte hardware sectors: (250 GB/232 GiB)
sd 4:0:0:0: [sdb] Write Protect is off
sd 4:0:0:0: [sdb] Mode Sense: 38 00 00 00
sd 4:0:0:0: [sdb] Assuming drive cache: write through
sd 4:0:0:0: [sdb] 488397168 512-byte hardware sectors: (250 GB/232 GiB)
sd 4:0:0:0: [sdb] Write Protect is off
sd 4:0:0:0: [sdb] Mode Sense: 38 00 00 00
sd 4:0:0:0: [sdb] Assuming drive cache: write through
sdb:<6>EXT4 FS on sda4, internal journal on sda4:8
ppdev: user-space parallel port driver
lp: driver loaded but no devices found
powernow-k8: Found 1 AMD Turion(tm) 64 X2 TL-60 processors (2 cpu cores) (version 2.20.00)
powernow-k8: 0 : fid 0xc (2000 MHz), vid 0x11
powernow-k8: 1 : fid 0xa (1800 MHz), vid 0x12
powernow-k8: 2 : fid 0x8 (1600 MHz), vid 0x13
powernow-k8: 3 : fid 0x0 (800 MHz), vid 0x1e
Clocksource tsc unstable (delta = -225007650 ns)
sdb1
sd 4:0:0:0: [sdb] Attached SCSI disk
sd 4:0:0:0: Attached scsi generic sg1 type 0
usb-storage: device scan complete
EXT4-fs: barriers enabled
kjournald2 starting: pid 3273, dev sda5:8, commit interval 5 seconds
EXT4 FS on sda5, internal journal on sda5:8
EXT4-fs: delayed allocation enabled
EXT4-fs: file extents enabled
EXT4-fs: mballoc enabled
EXT4-fs: mounted filesystem sda5 with ordered data mode
 
Old 12-11-2009, 09:48 AM   #2
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 227

Rep: Reputation: 33
Quote:
Originally Posted by feurry View Post

# Config information for eth1:
#IFNAME[1]=""
You have ifname commented out in the inet1.conf file. You need to specify eth1. Also, you should not have to start wpa before restarting your nic with rc.inet1. This should do it automatically.
 
Old 12-12-2009, 01:36 PM   #3
feurry
LQ Newbie
 
Registered: Dec 2009
Posts: 7

Original Poster
Rep: Reputation: 0
wpa does not appear to be starting when i run rc.inet1, and that's what i think the problem is.

I added IFNAME[1]="eth1" and nothing changed.

if i run /etc/rc.d/rc.inet1 eth1_restart and simultaneously check wpa with wpa_cli status i get
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
until i manually start wpa_supplicant... then everything works fine.
 
Old 12-12-2009, 08:45 PM   #4
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 227

Rep: Reputation: 33
Set DEBUG_ETH_UP="yes" and post the output of rc.inet1 start.
 
Old 12-14-2009, 08:22 AM   #5
feurry
LQ Newbie
 
Registered: Dec 2009
Posts: 7

Original Poster
Rep: Reputation: 0
with debug set

/etc/rc.d/rc.inet1 eth1_start
Polling for DHCP server on interface eth1:
err, eth1: timed out
warn, eth1: using IPV4LL address 169.254.132.45

I have WLAN_WPAWAIT[1]=60 and it is definitely not waiting 60 seconds before giving up.

This was in dmesg. I can't pinpoint when it happened, or if it's relevant.
eth1: no IPv6 routers present
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
Too big adjustment 32
eth1: no IPv6 routers present
 
Old 12-14-2009, 03:41 PM   #6
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 749
Blog Entries: 3

Rep: Reputation: 84
Hello,

wpa_supplicant is started by script /etc/rc.d/rc.wireless. Check that this script is executable otherwise rc.inet1 will skip it.
 
Old 12-16-2009, 09:58 AM   #7
feurry
LQ Newbie
 
Registered: Dec 2009
Posts: 7

Original Poster
Rep: Reputation: 0
# ls -al /etc/rc.d/rc.wireless*
-rwxr-xr-x 1 root root 12494 2009-04-28 12:32 /etc/rc.d/rc.wireless
-rw------- 1 root root 7320 2009-04-28 12:32 /etc/rc.d/rc.wireless.conf

I don't think that is the problem.

I have been using Alien's guide here.
http://alien.slackbook.org/dokuwiki/...ckware:network

He mentions that rc.wireless is not needed at all, and recommends the use of rc.inet1.conf instead.
 
Old 12-16-2009, 03:42 PM   #8
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 749
Blog Entries: 3

Rep: Reputation: 84
Quote:
Originally Posted by feurry View Post
He mentions that rc.wireless is not needed at all, and recommends the use of rc.inet1.conf instead.
No the mention is that rc.wireless.conf is deprecated. rc.wireless is still needed but this is not the cause of your problem.

The issue seems to be a DHCP timeout. I would suggest to add the following parameter in rc.inet1.conf:

Code:
DHCP_TIMEOUT[1]=30
Increase value of timeout as you see fit.

This parameter is used in rc.inet1 to determine DHCP timeout (look in the script for this parameter).
 
Old 12-16-2009, 04:25 PM   #9
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 749
Blog Entries: 3

Rep: Reputation: 84
Quote:
Originally Posted by feurry View Post
with debug set
/etc/rc.d/rc.inet1 eth1_start
Polling for DHCP server on interface eth1:
err, eth1: timed out
warn, eth1: using IPV4LL address 169.254.132.45
Another possible test could be to remove parameter

Code:
DHCP_HOSTNAME[1]="repete"
as it could be that the script is looking for a DHCP server on your machine. I don't use that parameter (only USE_DHCP = "yes").
 
Old 12-17-2009, 09:20 AM   #10
feurry
LQ Newbie
 
Registered: Dec 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gegechris99 View Post
Another possible test could be to remove parameter

Code:
DHCP_HOSTNAME[1]="repete"
Removing it didn't help.

Code:
DHCP_TIMEOUT[1]=30
Already set to 60 as per my 1st post.

Quote:
Originally Posted by gegechris99 View Post
No the mention is that rc.wireless.conf is deprecated.
To me this sounds like it's not needed. From alien's wiki.
"I think there is no good reason to want to keep using rc.wireless.conf. In fact, you can safely delete that entire file!"
 
Old 12-17-2009, 04:53 PM   #11
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 749
Blog Entries: 3

Rep: Reputation: 84
Quote:
Originally Posted by feurry View Post
Already set to 60 as per my 1st post.
Your first post did mention WLAN_WPAWAIT[1]=60 but not DHCP_TIMEOUT[1]=60

Quote:
To me this sounds like it's not needed. From alien's wiki.
"I think there is no good reason to want to keep using rc.wireless.conf. In fact, you can safely delete that entire file!"
rc.wireless.conf can be removed (it's deprecated). I agree. I was saying rc.wireless (anyway that's off topic).
 
Old 12-17-2009, 08:55 PM   #12
Tr1kk
LQ Newbie
 
Registered: Dec 2005
Location: Chi-Town
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
I just did fresh install of Slack 13 and after a few hours with no result I just used 'wicd'
and it works like a charm. Thanks to all here that help
 
Old 12-20-2009, 08:17 AM   #13
feurry
LQ Newbie
 
Registered: Dec 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gegechris99 View Post
Your first post did mention WLAN_WPAWAIT[1]=60 but not DHCP_TIMEOUT[1]=60
My bad. I will give that a try next.
 
Old 07-17-2014, 02:32 PM   #14
konradjr
LQ Newbie
 
Registered: Jul 2014
Posts: 1

Rep: Reputation: Disabled
/etc/rc.inet1 does not start wpa_supplicant

I have the same problem user feurry had. I looked through /etc/rc.d/rc.inet1 script and it seems that it does not actually start wpa_supplicant at any point, whereas it looks like /etc/rc.d/rc.wireless does.
So I was wondering if anybody has this kind of setup (which uses wpa_supplicant) running without the use of rc.wireless.

Adding the line:
Code:
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
in /etc/rc.d/rc.inet1 before the code that deals with dhcp should do the job.
 
Old 07-17-2014, 09:06 PM   #15
mister_b
LQ Newbie
 
Registered: Aug 2013
Location: US
Distribution: Slackware 14.1
Posts: 24

Rep: Reputation: Disabled
Quote:
Originally Posted by konradjr View Post
...So I was wondering if anybody has this kind of setup (which uses wpa_supplicant) running without the use of rc.wireless.

Adding the line:
Code:
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
in /etc/rc.d/rc.inet1 before the code that deals with dhcp should do the job.
There's probably a good reason it's not recommended but I like to choose loopback in netconfig and just use /etc/rc.local for wireless. The only reason is that rc.local was my friend before it was deprecated in a distro I formerly used. It also quickens boot time by an unimportant degree.
Code:
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local startup commands in here.  Also, if you have
# anything that needs to be run at shutdown time you can
# make an /etc/rc.d/rc.local_shutdown script and put those
# commands in there.

wpa_supplicant -B -Dnl80211 -iwlan0 -c /etc/wpa_supplicant.conf
dhcpcd wlan0 &> /dev/null &
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to manually add SATA driver manually when kernel boot? aixilin Linux - Kernel 6 08-15-2008 10:36 AM
service start httpd fails, manually starting with same command works jonboede Linux - General 1 02-19-2008 11:45 AM
Issued manually it works, but not onboot - wpa_supplicant IPW2200 Fedora8 odcheck Linux - Wireless Networking 2 02-05-2008 10:39 AM
How to Starting WPA_Supplicant on boot? SmileZero Linux - Wireless Networking 5 10-01-2005 11:21 PM
starting wpa_supplicant at boot mdj Linux - Wireless Networking 1 03-03-2005 10:41 PM


All times are GMT -5. The time now is 06:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration