LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-25-2015, 07:55 PM   #1
Haythem
Member
 
Registered: Jun 2012
Distribution: Slackware
Posts: 79

Rep: Reputation: Disabled
wpa_supplicant lose connectivity frequently


I'm running slackware 14.1 and use wpa_supplicant ,I notice connect/disconnect to internet frequently.
here is my rc.local:
Code:
root@darkstar:~# cat /etc/rc.d/rc.local 
#!/bin/sh
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
dhcpcd wlan0
here is how wlan0 looks like:
Code:
root@darkstar:~# ifconfig wlan0
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.3  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::2ab2:bdff:fec3:a7a8  prefixlen 64  scopeid 0x20<link>
        inet6 2604:2000:6ae2:d900:2ab2:bdff:fec3:a7a8  prefixlen 64  scopeid 0x0<global>
my phone connects to same router and I dont see these disconnects on phone. any advise?

Thanks.
 
Old 08-25-2015, 08:57 PM   #2
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
Is there a reason for using wpa_supplicant directly instead of network manager or wicd?

Do you have any related messages in your dmesg? What is your wireless device and what drivers are you using?
 
Old 08-25-2015, 11:54 PM   #3
Haythem
Member
 
Registered: Jun 2012
Distribution: Slackware
Posts: 79

Original Poster
Rep: Reputation: Disabled
I use wpa_supplicant because it's easy to configure and use.

here is Wireless info:
Code:
root@darkstar:~# lspci | grep Wireless
03:00.0 Network controller: Intel Corporation Intel(R) Dual Band Wireless-AC 7260 (rev 83)
root@darkstar:~# lsmod | grep wifi
iwlwifi                81693  1 iwlmvm
cfg80211              412299  3 iwlwifi,mac80211,iwlmvm
 
Old 08-26-2015, 04:58 AM   #4
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware -current 32bit!
Posts: 537

Rep: Reputation: 201Reputation: 201Reputation: 201
Haythem,
Does the connectivity go bad when you use your phone near the PC?
The phone's radio may be interfering with the wireless adapter.
Was the connection stable prior to some recent change?
 
Old 08-26-2015, 07:01 AM   #5
eldercitizen
Member
 
Registered: Apr 2015
Distribution: Slackware64-current
Posts: 38

Rep: Reputation: 31
That wifi adapter seems to generally have a bad reputation. At first I'd look for messages from wpa_supplicant (maybe run it with "-d") to see why it disconnects. Then try out different kernel-parameters (see modinfo -p iwlwifi) and look for new firmware-files (e.g. firmware-package from -current)

(As a sidenote: See "man rc.inet1.conf" for proper networking setup )

Last edited by eldercitizen; 08-26-2015 at 07:04 AM.
 
Old 08-26-2015, 12:56 PM   #6
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
If you think wpa_supplicant is easy, you should definitely look into using Network Manager. Just a consideration

eldercitizen does make a good suggestion to run wpa_supplicant in debugging mode. If you want to keep it in rc.local, you could add -f to specify a file location for it to output it's messages, see man wpa_supplicant for more info. Also, as I asked before, does dmesg output any messages about your wireless?
 
Old 08-26-2015, 05:05 PM   #7
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Some tricks you can try with the iwlwifi driver:
https://wiki.archlinux.org/index.php...ration#iwlwifi
http://forums.debian.net/viewtopic.php?f=16&t=121696
 
Old 08-26-2015, 05:38 PM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,685

Rep: Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571
Another link with information on your device. http://askubuntu.com/questions/61611...grade-to-15-04
 
Old 08-26-2015, 10:00 PM   #9
Haythem
Member
 
Registered: Jun 2012
Distribution: Slackware
Posts: 79

Original Poster
Rep: Reputation: Disabled
I setup proper network configuration in rc.inet1.conf, removed wpa_supplicant and dhcpd lines from rc.local,
deleted rc.wireless.conf file and changed the iwlwifi module options as per above links but still have same problem.
(only things I haven't tried yet is to disable bluetooth and move the mobile away from laptop to prevent interference).
here is what I get in "meassages" during connect/disconnect (notice timestamp):

Code:
Aug 26 21:45:05 darkstar dhcpcd[735]: wlan0: carrier acquired
Aug 26 21:45:05 darkstar dhcpcd[735]: wlan0: soliciting an IPv6 router
Aug 26 21:45:05 darkstar dhcpcd[735]: wlan0: rebinding lease of 192.168.0.3
Aug 26 21:45:05 darkstar dhcpcd[735]: wlan0: Router Advertisement from fe80::4270:9ff:fe4f:9f37
Aug 26 21:45:05 darkstar dhcpcd[735]: wlan0: requesting DHCPv6 information
Aug 26 21:45:10 darkstar dhcpcd[735]: wlan0: leased 192.168.0.3 for 3600 seconds
Aug 26 21:45:10 darkstar dhcpcd[735]: wlan0: adding host route to 192.168.0.3 via 127.0.0.1
Aug 26 21:45:10 darkstar dhcpcd[735]: wlan0: adding route to 192.168.0.0/24
Aug 26 21:45:10 darkstar dhcpcd[735]: wlan0: adding default route via 192.168.0.1
Aug 26 21:47:07 darkstar dhcpcd[735]: wlan0: carrier lost
Aug 26 21:47:07 darkstar dhcpcd[735]: wlan0: deleting host route to 192.168.0.3 via 127.0.0.1
Aug 26 21:47:07 darkstar dhcpcd[735]: wlan0: deleting route to 192.168.0.0/24
Aug 26 21:47:07 darkstar dhcpcd[735]: wlan0: deleting default route via 192.168.0.1
Aug 26 21:47:07 darkstar kernel: [ 1677.974694] cfg80211: Calling CRDA to update world regulatory domain
Aug 26 21:47:07 darkstar kernel: [ 1677.976116] cfg80211: World regulatory domain updated:
Aug 26 21:47:07 darkstar kernel: [ 1677.976118] cfg80211:  DFS Master region: unset
Aug 26 21:47:07 darkstar kernel: [ 1677.976119] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:47:07 darkstar kernel: [ 1677.976121] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:07 darkstar kernel: [ 1677.976122] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:07 darkstar kernel: [ 1677.976123] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:07 darkstar kernel: [ 1677.976123] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:07 darkstar kernel: [ 1677.976124] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.034300] wlan0: authenticate with 40:70:09:4f:9f:30
Aug 26 21:47:26 darkstar kernel: [ 1697.039558] wlan0: send auth to 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:47:26 darkstar kernel: [ 1697.042570] wlan0: authenticated
Aug 26 21:47:26 darkstar kernel: [ 1697.042809] wlan0: associate with 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:47:26 darkstar kernel: [ 1697.057285] wlan0: RX AssocResp from 40:70:09:4f:9f:30 (capab=0xc31 status=0 aid=2)
Aug 26 21:47:26 darkstar kernel: [ 1697.061682] wlan0: associated
Aug 26 21:47:26 darkstar kernel: [ 1697.061739] cfg80211: Calling CRDA for country: US
Aug 26 21:47:26 darkstar kernel: [ 1697.063144] cfg80211: Regulatory domain changed to country: US
Aug 26 21:47:26 darkstar kernel: [ 1697.063147] cfg80211:  DFS Master region: unset
Aug 26 21:47:26 darkstar kernel: [ 1697.063148] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:47:26 darkstar kernel: [ 1697.063150] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.063152] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.063153] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.063154] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.063155] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.063156] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Aug 26 21:47:26 darkstar dhcpcd[735]: wlan0: carrier acquired
Aug 26 21:47:26 darkstar dhcpcd[735]: wlan0: soliciting an IPv6 router
Aug 26 21:47:26 darkstar dhcpcd[735]: wlan0: rebinding lease of 192.168.0.3
Aug 26 21:47:26 darkstar dhcpcd[735]: wlan0: Router Advertisement from fe80::4270:9ff:fe4f:9f37
Aug 26 21:47:26 darkstar dhcpcd[735]: wlan0: requesting DHCPv6 information
Aug 26 21:47:26 darkstar kernel: [ 1697.346466] wlan0: Connection to AP 40:70:09:4f:9f:30 lost
Aug 26 21:47:26 darkstar dhcpcd[735]: wlan0: carrier lost
Aug 26 21:47:26 darkstar kernel: [ 1697.361756] cfg80211: Calling CRDA to update world regulatory domain
Aug 26 21:47:26 darkstar kernel: [ 1697.363185] cfg80211: World regulatory domain updated:
Aug 26 21:47:26 darkstar kernel: [ 1697.363188] cfg80211:  DFS Master region: unset
Aug 26 21:47:26 darkstar kernel: [ 1697.363189] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:47:26 darkstar kernel: [ 1697.363191] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.363193] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.363194] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.363195] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:26 darkstar kernel: [ 1697.363196] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:29 darkstar kernel: [ 1700.448347] wlan0: authenticate with 40:70:09:4f:9f:30
Aug 26 21:47:29 darkstar kernel: [ 1700.453448] wlan0: send auth to 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:47:29 darkstar kernel: [ 1700.456019] wlan0: authenticated
Aug 26 21:47:29 darkstar kernel: [ 1700.456571] wlan0: associate with 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:47:29 darkstar kernel: [ 1700.465038] wlan0: RX AssocResp from 40:70:09:4f:9f:30 (capab=0xc31 status=0 aid=2)
Aug 26 21:47:29 darkstar kernel: [ 1700.468486] wlan0: associated
Aug 26 21:47:29 darkstar kernel: [ 1700.468562] cfg80211: Calling CRDA for country: US
Aug 26 21:47:29 darkstar kernel: [ 1700.470234] cfg80211: Regulatory domain changed to country: US
Aug 26 21:47:29 darkstar kernel: [ 1700.470237] cfg80211:  DFS Master region: unset
Aug 26 21:47:29 darkstar kernel: [ 1700.470238] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:47:29 darkstar kernel: [ 1700.470240] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Aug 26 21:47:29 darkstar kernel: [ 1700.470242] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Aug 26 21:47:29 darkstar kernel: [ 1700.470243] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:29 darkstar kernel: [ 1700.470244] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:29 darkstar kernel: [ 1700.470246] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:29 darkstar kernel: [ 1700.470247] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Aug 26 21:47:30 darkstar dhcpcd[735]: wlan0: carrier acquired
Aug 26 21:47:30 darkstar dhcpcd[735]: wlan0: soliciting an IPv6 router
Aug 26 21:47:30 darkstar dhcpcd[735]: wlan0: rebinding lease of 192.168.0.3
Aug 26 21:47:30 darkstar kernel: [ 1700.760091] wlan0: Connection to AP 40:70:09:4f:9f:30 lost
Aug 26 21:47:30 darkstar dhcpcd[735]: wlan0: carrier lost
Aug 26 21:47:30 darkstar kernel: [ 1700.776524] cfg80211: Calling CRDA to update world regulatory domain
Aug 26 21:47:30 darkstar kernel: [ 1700.777927] cfg80211: World regulatory domain updated:
Aug 26 21:47:30 darkstar kernel: [ 1700.777929] cfg80211:  DFS Master region: unset
Aug 26 21:47:30 darkstar kernel: [ 1700.777931] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:47:30 darkstar kernel: [ 1700.777932] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:30 darkstar kernel: [ 1700.777934] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:30 darkstar kernel: [ 1700.777935] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:30 darkstar kernel: [ 1700.777936] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:30 darkstar kernel: [ 1700.777937] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:33 darkstar kernel: [ 1703.861196] wlan0: authenticate with 40:70:09:4f:9f:30
Aug 26 21:47:33 darkstar kernel: [ 1703.866849] wlan0: send auth to 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:47:33 darkstar kernel: [ 1703.871023] wlan0: authenticated
Aug 26 21:47:33 darkstar kernel: [ 1703.871356] wlan0: associate with 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:47:33 darkstar kernel: [ 1703.882272] wlan0: RX AssocResp from 40:70:09:4f:9f:30 (capab=0xc31 status=0 aid=2)
Aug 26 21:47:33 darkstar kernel: [ 1703.884830] wlan0: associated
Aug 26 21:47:33 darkstar kernel: [ 1703.884900] cfg80211: Calling CRDA for country: US
Aug 26 21:47:33 darkstar kernel: [ 1703.886871] cfg80211: Regulatory domain changed to country: US
Aug 26 21:47:33 darkstar kernel: [ 1703.886875] cfg80211:  DFS Master region: unset
Aug 26 21:47:33 darkstar kernel: [ 1703.886877] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:47:33 darkstar kernel: [ 1703.886880] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Aug 26 21:47:33 darkstar kernel: [ 1703.886882] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Aug 26 21:47:33 darkstar kernel: [ 1703.886883] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:33 darkstar kernel: [ 1703.886885] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:33 darkstar kernel: [ 1703.886887] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:47:33 darkstar kernel: [ 1703.886888] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Aug 26 21:47:33 darkstar dhcpcd[735]: wlan0: carrier acquired
Aug 26 21:47:33 darkstar dhcpcd[735]: wlan0: soliciting an IPv6 router
Aug 26 21:47:33 darkstar dhcpcd[735]: wlan0: rebinding lease of 192.168.0.3
Aug 26 21:47:35 darkstar dhcpcd[735]: wlan0: Router Advertisement from fe80::4270:9ff:fe4f:9f37
Aug 26 21:47:35 darkstar dhcpcd[735]: wlan0: requesting DHCPv6 information
Aug 26 21:47:38 darkstar dhcpcd[735]: wlan0: leased 192.168.0.3 for 3600 seconds
Aug 26 21:47:38 darkstar dhcpcd[735]: wlan0: adding host route to 192.168.0.3 via 127.0.0.1
Aug 26 21:47:38 darkstar dhcpcd[735]: wlan0: adding route to 192.168.0.0/24
Aug 26 21:47:38 darkstar dhcpcd[735]: wlan0: adding default route via 192.168.0.1
Aug 26 21:48:23 darkstar dhcpcd[735]: wlan0: carrier lost
Aug 26 21:48:23 darkstar kernel: [ 1753.626401] cfg80211: Calling CRDA to update world regulatory domain
Aug 26 21:48:23 darkstar kernel: [ 1753.628554] cfg80211: World regulatory domain updated:
Aug 26 21:48:23 darkstar kernel: [ 1753.628559] cfg80211:  DFS Master region: unset
Aug 26 21:48:23 darkstar kernel: [ 1753.628561] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:48:23 darkstar kernel: [ 1753.628564] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:23 darkstar kernel: [ 1753.628566] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:23 darkstar kernel: [ 1753.628568] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:23 darkstar kernel: [ 1753.628570] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:23 darkstar kernel: [ 1753.628572] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:23 darkstar dhcpcd[735]: wlan0: deleting host route to 192.168.0.3 via 127.0.0.1
Aug 26 21:48:23 darkstar dhcpcd[735]: wlan0: deleting route to 192.168.0.0/24
Aug 26 21:48:23 darkstar dhcpcd[735]: wlan0: deleting default route via 192.168.0.1
Aug 26 21:48:26 darkstar kernel: [ 1756.709700] wlan0: authenticate with 40:70:09:4f:9f:30
Aug 26 21:48:26 darkstar kernel: [ 1756.714754] wlan0: send auth to 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:48:26 darkstar kernel: [ 1756.717431] wlan0: authenticated
Aug 26 21:48:26 darkstar kernel: [ 1756.718273] wlan0: associate with 40:70:09:4f:9f:30 (try 1/3)
Aug 26 21:48:26 darkstar kernel: [ 1756.725783] wlan0: RX AssocResp from 40:70:09:4f:9f:30 (capab=0xc31 status=0 aid=2)
Aug 26 21:48:26 darkstar kernel: [ 1756.736167] wlan0: associated
Aug 26 21:48:26 darkstar kernel: [ 1756.736256] cfg80211: Calling CRDA for country: US
Aug 26 21:48:26 darkstar kernel: [ 1756.737711] cfg80211: Regulatory domain changed to country: US
Aug 26 21:48:26 darkstar kernel: [ 1756.737714] cfg80211:  DFS Master region: unset
Aug 26 21:48:26 darkstar kernel: [ 1756.737715] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 26 21:48:26 darkstar kernel: [ 1756.737717] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Aug 26 21:48:26 darkstar kernel: [ 1756.737719] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Aug 26 21:48:26 darkstar kernel: [ 1756.737720] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:26 darkstar kernel: [ 1756.737721] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:26 darkstar kernel: [ 1756.737723] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 26 21:48:26 darkstar kernel: [ 1756.737724] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Aug 26 21:48:26 darkstar dhcpcd[735]: wlan0: carrier acquired
Aug 26 21:48:26 darkstar dhcpcd[735]: wlan0: soliciting an IPv6 router
Aug 26 21:48:26 darkstar dhcpcd[735]: wlan0: rebinding lease of 192.168.0.3
Aug 26 21:48:26 darkstar dhcpcd[735]: wlan0: Router Advertisement from fe80::4270:9ff:fe4f:9f37
Aug 26 21:48:26 darkstar dhcpcd[735]: wlan0: requesting DHCPv6 information
Aug 26 21:48:30 darkstar dhcpcd[735]: wlan0: leased 192.168.0.3 for 3600 seconds
Aug 26 21:48:30 darkstar dhcpcd[735]: wlan0: adding host route to 192.168.0.3 via 127.0.0.1
Aug 26 21:48:30 darkstar dhcpcd[735]: wlan0: adding route to 192.168.0.0/24
Aug 26 21:48:30 darkstar dhcpcd[735]: wlan0: adding default route via 192.168.0.1

Last edited by Haythem; 08-27-2015 at 10:46 AM. Reason: Organizing
 
Old 08-27-2015, 04:19 AM   #10
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,685

Rep: Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571
Have you seen this post? http://www.linuxquestions.org/questi...6/#post5402483

PS - When posting a long listing, please include it in code tags, not quote tags, as it preserves formatting and allows easier scrolling.
 
Old 08-28-2015, 01:58 AM   #11
Haythem
Member
 
Registered: Jun 2012
Distribution: Slackware
Posts: 79

Original Poster
Rep: Reputation: Disabled
I disabled power_save on wlan0 interface and things going well so far, connection is stable. I will monitor it for couple more days before to make sure that the issue resolved
Code:
iw wlan0 set power_save off
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lose Connectivity felton57 Linux - Newbie 1 09-27-2011 02:27 AM
Lose Internet Connectivity When VPN'ing via PPTP Temujin_12 Linux - Networking 9 10-17-2010 04:26 AM
LXer: Microsoft, Motorola Patent Battle: A Lose-Lose-Lose Proposition LXer Syndicated Linux News 1 10-05-2010 10:51 PM
I constantly lose wireless connectivity(while torrenting) , im using jaunty 64bit redhand8888 Ubuntu 1 05-19-2009 01:40 PM
Lose connectivity with Konqueror tron_thomas Linux - Networking 9 06-23-2004 01:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration