-   Slackware (
-   -   Wireless, USB Mouse problems with Slackware-current (

Korazail 02-17-2004 06:33 PM

Wireless, USB Mouse problems with Slackware-current
I'm an utter newbie when it comes to linux, but I hope to think I have caught on quickly, however I am having difficulty with a piece of hardware: My USB Mouse.

I have looked all over, and seen many problems dealing with similar issues to mine, but none of the fixes I see ever work.

I'm going to include as much as I think will help, but if I leave anything out let me know.

I installed Slack with the full option, so I should have any/everything I need, assuming what I need came with the distro.

Mouse: I have a Gyration Wireless mouse/keyboard suite that works wonderfully under XP; however, when I boot Slack, I only get the keyboard.
I've tried to cat every mouse/mice/usb/etc in the /dev folder, but never get any results. My receiver is obviously receiving (little lights blink happily when I move the mouse) but nothing seems to make it to the input stream.

excerpt from boot messages

Feb 17 08:40:59 TheSelf kernel: usb.c: registered new driver usbkbd
Feb 17 08:40:59 TheSelf kernel: input0: Gyration GyroPoint RF Technology Receiver on usb3:2.0
Feb 17 08:40:59 TheSelf kernel: usbkbd.c: :USB HID Boot Protocol keyboard driver
Feb 17 08:40:59 TheSelf kernel: usb.c: registered new driver hiddev
Feb 17 08:40:59 TheSelf kernel: usb.c: registered new driver hid
Feb 17 08:40:59 TheSelf kernel: input,hiddev0: USB HID v1.00 Mouse [Gyration GyroPoint RF Technology Receiver] on usb3:2.1
Feb 17 08:40:59 TheSelf kernel: hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <>
Feb 17 08:40:59 TheSelf kernel: hid-core.c: USB HID support drivers
Feb 17 08:40:59 TheSelf kernel: mice: PS/2 mouse device common for all mice
Feb 17 08:40:59 TheSelf kernel: usb.c: registered new driver usbmouse
Feb 17 08:40:59 TheSelf kernel: usbmouse.c: v1.6:USB HID Boot Protocol mouse driver

This is where usb.c seems to find the mouse/keyboard. it looks to me like there should be a usbmouse somewhere in /dev, but there isn't.

I have had luck plugging in another USB mouse, a generic CompUSA usb 2-button mouse, and it works fine, and strangely enough, when it is connected my wireless mouse sends data to /dev/mice
if I start x and move the normal, wired mouse then everything is fine, but if I move the wireless one, I get the symptoms I have seen elsewhere: only up and down motion, with button presses moving the cursor right at different speeds.
I may end up using a wired mouse, if there is no cure, but I'd rather be able to use my fancy wireless one.

Ive talked with several of my <semi>linux competent friends (no one I know actually uses it, they have all just tinkered) and they all tell me I need special drivers. Are they correct? or is it more like I suspect, that the data my mouse is sending just isn't going where I expect it to.

since I see this in many of the other questions, the output from lsmod:

Module                  Size  Used by    Not tainted
snd-pcm-oss            37252  0  (unused)
snd-mixer-oss          11992  0  [snd-pcm-oss]
usbmouse                2008  0  (unused)
keybdev                1952  0  (unused)
mousedev                4244  0
hid                    21156  0  (unused)
usbkbd                  3416  0  (unused)
input                  3200  0  [usbmouse keybdev mousedev hid usbkbd]
b44                    13608  0
tuner                  10272  1  (autoclean)
tda9887                3100  1  (autoclean)
tvaudio                13628  0  (autoclean) (unused)
bttv                  94432  0  (unused)
i2c-algo-bit            6984  1  [bttv]
i2c-core              12740  0  [tuner tda9887 tvaudio bttv i2c-algo-bit]
videodev                5664  2  [bttv]

uhci                  24496  0  (unused)
ehci-hcd              16872  0  (unused)
usbcore                58400  1  [usbmouse hid usbkbd uhci ehci-hcd]
snd-via82xx            11712  0  (unused)
snd-pcm                55904  0  [snd-pcm-oss snd-via82xx]
snd-timer              13252  0  [snd-pcm]
snd-ac97-codec        37240  0  [snd-via82xx]
snd-page-alloc          6004  0  [snd-via82xx snd-pcm]
snd-mpu401-uart        3136  0  [snd-via82xx]
snd-rawmidi            12512  0  [snd-mpu401-uart]
snd-seq-device          3920  0  [snd-rawmidi]
snd                    27460  0  [snd-pcm-oss snd-mixer-oss snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore              3332  4  [bttv snd]
pcmcia_core            40032  0
ide-scsi                9424  0
agpgart                39576  0  (unused)
ntfs                  51040  1  (autoclean)

which I have no clue how to read, so I hope someone does.

Thanks in advance for any help

subekk0 02-17-2004 11:01 PM


some keywords I used when searching google:
gyroscopic mice linux
gyromouse linux
gryation mouse linux

subekk0 02-17-2004 11:02 PM

Oh yeah... after you get it working don't forget to do a HCL so that everyone can share in your glory!

Phathead 02-18-2004 10:55 AM

Have you tried the device /dev/input/mice? I had to make that change yesterday when I changed from a PS/2 mouse to a USB mouse.

Korazail 02-18-2004 10:57 AM

I'm not going to be able to poke at my computer until much later this evening, but at first glance, I don't think that solution is going to work for me.

The mouse is not being misrecognized, or if it is, its definately not as a keyboard.

Judging from the boot messages, *something* knows I have a usbmouse, as usbmouse.c is getting loaded.

I will continue to poke, however, and let everyone know when I get this working.

Phathead 02-18-2004 10:58 AM

Also, I'm not familiar with this mouse/keyboard package. Do they both connect to the same USB port? If so, does it act like a USB hub? Post the output of

I'm certainly no expert on USB devices, but maybe we can get closer to a solution if we know exactly how your system sees everything.

Phathead 02-18-2004 11:03 AM

Another note:

I have a USB intellimouse and I had to remove the usbmouse module from the kernel to get the mouse to work properly in X Windows. Before I removed that, the only motion I could get was vertical motion. I don't know if this only applies to Microsoft USB mice or all USB mice, but later on if you run into that problem, all I did was add

/sbin/rmmod usbmouse
to the end of my /etc/rc.d/rc.local.

BBoy_no_01 12-23-2005 06:24 PM

It's working!
I've had the same problem with my usb mouse...going only up and down and on leftclick...going right!Phathead cured me :).I used his advice ->
go in: /etc/rc.d/rc.local
add new line: /sbin/rmmod usbmouse
That worked for me!
I have a Genius NetScroll+Superior USB mouse.
Before this I tried everything I could, like editing /etc/X11/xorg.conf(XF86Config fore some).I tried all availeble protocols,devices(mice)...and nothing; until I visited this forum :)

All times are GMT -5. The time now is 01:10 AM.