-   Slackware (
-   -   Wireless USB Linksys AE1200 and Slack 13.37 (

gmartin 12-26-2011 09:49 AM

Wireless USB Linksys AE1200 and Slack 13.37
Good morning - I hope you are all enjoying this holiday season.
I have this new wireless-N USB adapter and I'm trying to get it recognized as a network adapter. When I plug it in, I see the following in dmesg:

usb 2-1: new high speed USB device using ehci_hcd and address 5
usb 2-1: New USB device found, idVendor=13b1, idProduct=0039
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-1: Product: Linksys AE1200
usb 2-1: Manufacturer: Cisco
usb 2-1: SerialNumber: 000000000001

lsusb then adds this entry:

Bus 002 Device 006: ID 13b1:0039 Linksys
I have rebooted with the device in place and while the above are noted, no wireless adapter appears to be created. ifconfig still lists only lo0 and eth0

I've read through several LQ posts
on ralink adapters and
the rt2870 driver.
and took the following actions based on them:
Created /etc/modprobe.d/ralink-blacklist.conf containing

#gmartin from:
blacklist rt2800usb
blacklist rt2800lib
blacklist rt2800pci
blacklist rt2x00usb
blacklist rt2x00lib
blacklist rt2x00pci

and created the link

ln -L /lib/firmware/rt2870.bin /lib/firmware/rt3070.bin
and restarted the OS after the changes. I see no reference to rt3070 or rt2870 when I run lsmod

Can you recommend my next troubleshooting step? How can i tell what modprobe and the blacklist are doing?


Peacedog 12-26-2011 10:07 AM

Hi gmartin, have you tried to load the module?


# modprobe rt2870sta
Good luck. ;-)

gmartin 12-26-2011 12:53 PM

Thanks - modprobe -v rt2870sta gave me this output


rt2870sta            433234  0
crc_ccitt              1347  1 rt2870sta

and in dmesg this:

rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
rtusb init --->
usbcore: registered new interface driver rt2870

Should I see a new interface when I run ifconfig? How do I know what interface it is registered as?
FWIW, I added modprobe rt2870sta and modprobe rt2870usb to rc.netdevice, chmod +x rc.netdevice and restarted the OS. The module loaded on restart according to dmesg, but I still don't see a new interface.

Peacedog 12-26-2011 08:12 PM

Now that the module is loaded let's take a look. Please post the result of the following.


# ifconfig -a
# iwconfig

Good luck. ;-)

gmartin 12-26-2011 10:04 PM

Thanks for the help.

ifconfig -a

eth0      Link encap:Ethernet  HWaddr 00:23:ae:6c:80:e2 
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::223:aeff:fe6c:80e2/64 Scope:Link
          RX packets:227809 errors:0 dropped:33 overruns:0 frame:0
          TX packets:320735 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:38919339 (37.1 MiB)  TX bytes:354121864 (337.7 MiB)
          Interrupt:21 Memory:f7ae0000-f7b00000

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3012 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3012 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:187217 (182.8 KiB)  TX bytes:187217 (182.8 KiB)


lo        no wireless extensions.

eth0      no wireless extensions.

tobyl 12-27-2011 03:57 AM

A little searching indicates to me that your wireless chip is a Broadcom BCM43235. There is limited info on this so I could be mistaken. If so, the drivers you have been trying to use will not work.

Support for BCM43235 is in the 'no promises' staging section of the kernel. It is called brcmfmac. I'm not sure which kernel first supported this chipset, but as with any driver in the staging section, later is usually better. So see if you can load this driver, and failing that, you could try compiling a recent kernel if you are happy doing that.


tobyl 12-27-2011 04:34 AM

It appears that the driver I mentioned does not appear in the kernel that comes with 13.37. The nearest you will get to it is the staging driver brcm80211 (this is looking at which is the oldest kernel I have lying around). The driver brcmfmac does not appear until a later kernel. I would definitely recommend a kernel upgrade if possible

edit: is this a netbook or tablet??

gmartin 12-27-2011 07:17 AM

It's a desktop that I want to add to the wireless network.
I followed the link you added above. It referenced a driver here. I downloaded and built the rt3572sta driver and ran modprobe. It inserted the driver, but I found no other change. Added the modprobe to rc.netdevices and restarted with no change in status.

I may try to update the kernel later today.

All times are GMT -5. The time now is 10:56 PM.