LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-15-2016, 03:53 AM   #1
barfq
LQ Newbie
 
Registered: Feb 2016
Posts: 2

Rep: Reputation: Disabled
Wireless times out after being connected awhile


Using 14.1 with wicd, my internet connection is great and then suddenly all websites will start to time out. The only thing that fixes this is to use wicd to disconnect and reconnect to the router. I tried turning off the router's firewall and that didn't make a difference. The wireless also works fine in Windows.

But I'm on a Lenovo Y570 with I think an Intel Link 1000 bgn. Any recommendations? Is there a common way to debug what's going on?
 
Old 02-15-2016, 12:07 PM   #2
Tonus
Member
 
Registered: Jan 2007
Location: Paris, France
Distribution: Slackware-current with grub2
Posts: 393
Blog Entries: 3

Rep: Reputation: 101Reputation: 101
Wireless times out after being connected awhile

What about power saving option for the wireless card ? Try to disable it :
Code:
#iwconfig wlan0 power off
Admitting wlan0 is your wireless card and the command passed as root.

If it works you may want to do this permanently. Let us know.
 
Old 02-15-2016, 08:36 PM   #3
barfq
LQ Newbie
 
Registered: Feb 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Hi, thanks for the suggestion. Didn't seem to help; neither did setting iwconfig wlan0 rate 54M.

I ended up setting the router's wireless channel from 3 to auto and now everything is dandy. Don't really understand why; maybe there was some kind of interference. But weird that it was fine on Windows. Oh well.
 
Old 02-16-2016, 02:57 AM   #4
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 717
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Originally Posted by barfq View Post
Hi, thanks for the suggestion. Didn't seem to help; neither did setting iwconfig wlan0 rate 54M.

I ended up setting the router's wireless channel from 3 to auto and now everything is dandy. Don't really understand why; maybe there was some kind of interference. But weird that it was fine on Windows. Oh well.
I vaguely remember having this same issue a few years ago, where i had "solved it" by setting the router to automatic channel -- although sometimes i would have to reset it as certain channels would drop my connection. Not long after i had read about CRDA regional settings, and after setting this, i have not since experienced the same connection drops when using wicd ever since.

You could try setting it using your country code, eg:
Code:
# iw reg set GB
There are various ways to keep this setting, running the command in /etc/rc.local or making udev rules etc, but i feel it could be worth a try if you haven't set this already.

Just a theory...

You can check what it's currently set to with:
Code:
# iw reg get
If it's not your country code i would recommend setting it before the network comes up.
 
Old 02-16-2016, 07:01 AM   #5
akus
Member
 
Registered: May 2006
Location: Netherlands
Distribution: Slackware64
Posts: 63

Rep: Reputation: 30
Quote:
Originally Posted by barfq View Post
Using 14.1 with wicd, my internet connection is great and then suddenly all websites will start to time out. The only thing that fixes this is to use wicd to disconnect and reconnect to the router.
I have similar issues since I switched internet provider (and the modem with built in wifi) with Slackware 14.1+wicd, and i have
>> Network controller: Broadcom Corporation BCM4331 802.11a/b/g/n (rev 02)

I was wondering how to fix this problem.
I'll try suggestions given in this thread tonight.
 
Old 02-16-2016, 04:32 PM   #6
slac-in-the-box
Member
 
Registered: Mar 2010
Location: oregon
Distribution: slackware64-14.2
Posts: 268

Rep: Reputation: 109Reputation: 109
In the comments near the end of /etc/rc.d/rc.inet1.conf there is a suggestion for changing MTU setting, that can help in some situations; and certainly changing this setting helped resolve my connectivity issues:
Code:
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
 
Old 02-17-2016, 03:23 AM   #7
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.2 64-bit
Posts: 457

Rep: Reputation: 142Reputation: 142
After being disconnected can you check /var/log/wicd/wicd.log and post the error messages here?
 
Old 02-21-2016, 01:36 PM   #8
ryanpcmcquen
Member
 
Registered: Apr 2013
Distribution: DistroWanderer
Posts: 380

Rep: Reputation: Disabled
You could bypass wicd and just use good ol' wpa_supplicant.
I started doing that when I had issues, I automated it with this script so I could easily change networks when I was on the go:

https://github.com/ryanpcmcquen/linu...lackware/wifir

If it helps let me know, you can have it start on boot like so (line numbers may be a bit off):

https://github.com/ryanpcmcquen/conf...T.sh#L675-L681
 
Old 02-23-2016, 12:00 PM   #9
bryan_S
LQ Newbie
 
Registered: Aug 2014
Location: Florida US
Distribution: Linux-from-Scratch, Kaos/Arch
Posts: 12

Rep: Reputation: Disabled
I have same/similar wireless card and had the same issue when i was using slackware. My card is Intel Centrino Wireless-N 1000 802.11b/g/n on a Lenovo edge laptop. That card is well supported in Linux - i have no disconnect/timeout issues with any other distro. That's mainly why i no longer use Slackware - i use wireless to connect to internet approaching 100% of the time so it's important.

I think i did try using plain wpa-supplicant and that didn't solve the problem either. I hope you get it sorted because otherwise Slackware is a great distro (Also, derivatives like Salix have same issue).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network down but wireless connected raphtor Linux - Networking 3 11-08-2011 09:39 PM
Wireless on Slack 12.2 used to work, now DHCPCD times out. thethinker Linux - Networking 5 07-21-2011 09:02 PM
[SOLVED] wireless network times out - will not restart without reboot jludeman Linux - Networking 6 03-07-2011 12:00 PM
how can i view the amount of times each user has connected to my system flea89 Linux - Newbie 7 03-13-2010 11:52 AM
Wireless connected but not ???? RU63 Linux - Wireless Networking 14 01-25-2005 09:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration