LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-27-2013, 03:30 AM   #1
xavi_slacky
Member
 
Registered: Jun 2013
Posts: 104

Rep: Reputation: Disabled
wireless setup question


Hi,

I have a wireless card on laptop:

# lspci | grep "Network controller"
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

And loaded it's driver:

# lsmod | grep iwlwifi
iwlwifi 177785 0
mac80211 203119 3 iwl_legacy,iwl3945,iwlwifi
cfg80211 145334 4 mac80211,iwl_legacy,iwl3945,iwlwifi

The next step I try is:

# iwlist wlan0 scan
wlan0 Interface doesn't support scanning : Network is down

But don't work. I see:

# ifconfig -a
eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 00:16:d4:67:84:01 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 21

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 16 bytes 1152 (1.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 16 bytes 1152 (1.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether 00:18:de:b9:29:c1 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Hhmmm, wlan0 and iwlwifi driver don't talk ?

How I do it ?

Thanks, see you.
 
Old 06-27-2013, 04:40 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,580

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Quote:
Originally Posted by xavi_slacky View Post
Hhmmm, wlan0 and iwlwifi driver don't talk ?.
Yes they do, but only if you brought the wlan0 interface up:
Code:
ifconfig wlan0 up
But don't complicate things, please. If you are running Slackware 14.0, just run as root:
Code:
netconfig
choose NetworkManager and you are all set.

After that and if not already done by your DE, run once (as a regular user) :
Code:
nm-applet
The network manager widget will appear. If that doesn't work run first, as root
Code:
/etc/rc.d/rc.networkmanager start
 
Old 06-27-2013, 08:43 AM   #3
xavi_slacky
Member
 
Registered: Jun 2013
Posts: 104

Original Poster
Rep: Reputation: Disabled
> Old Today, 04:40 AM #2
>
> Didier Spaier

Hi Didier,

>
> Senior Member
>
>
> Registered: Nov 2008
> Location: Paris, France
> Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
> Posts: 2,854
> Rep: Reputation: 543 Reputation: 543 Reputation: 543 Reputation: 543
> Reputation: 543 Reputation: 543
>
> Quote:
> Originally Posted by xavi_slacky View Post
> Hhmmm, wlan0 and iwlwifi driver don't talk ?.
> Yes they do, but only if you brought the wlan0 interface up:
> Code:
> ifconfig wlan0 up
>

I try it before and now:

# ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

For this error I post here with this subject.

> But don't complicate things, please. If you are running Slackware 14.0,
> just run as root:
> Code:
> netconfig
>
>

Hhmmm, I try it following your steps and don't setup any.

I use Linux slackware 14 with generic kernel 3.2.45-smp

More ideas ?

Thanks, see you.
 
Old 06-27-2013, 09:55 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,972

Rep: Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084
Quote:
SIOCSIFFLAGS: Operation not possible due to RF-kill
Your device appears to be blocked, either hard-blocked (hardware switch) or soft-blocked or both.
Run 'rfkill list' to see what is going on.
Run 'rfkill unblock wlan' to toggle a soft block.

This should be handled automatically by NetworkManager when used from a GUI.
 
Old 06-27-2013, 10:53 AM   #5
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 270

Rep: Reputation: 84
I had that as well when I first put slackware on this laptop.

What I had to do was get the rfkill in sync with what the system switches were set to.. so I used the softkey (fn-f2 for me) to turn off all the wireless, then rfkill block all.. soft key again and all was synced for me.

once the rfkill and system were in sync, haven't seen this again.
 
Old 06-28-2013, 02:51 AM   #6
xavi_slacky
Member
 
Registered: Jun 2013
Posts: 104

Original Poster
Rep: Reputation: Disabled
> Old Yesterday, 09:55 AM #4
>
> allend

Hi allend,

>
> Senior Member
>
>
> Registered: Oct 2003
> Location: Melbourne
> Distribution: Slackware-current
> Posts: 2,830
> Rep: Reputation: 622 Reputation: 622 Reputation: 622 Reputation: 622
> Reputation: 622 Reputation: 622
>
> Quote:
> SIOCSIFFLAGS: Operation not possible due to RF-kill
> Your device appears to be blocked, either hard-blocked (hardware
> switch) or soft-blocked or both.
> Run 'rfkill list' to see what is going on.

root@slackware:~# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
root@slackware:~#


> Run 'rfkill unblock wlan' to toggle a soft block.

root@slackware:~# rfkill unblock wlan
root@slackware:~# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
root@slackware:~#

This laptop have hardware switch, but it don't change status if I switched on and off.
In same situation and another OS wireless work right, then the problem is the OS slackware.

I also try:

root@slackware:~# rfkill unblock all
root@slackware:~# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
root@slackware:~#

More ideas ?

Thanks, see you.
 
Old 06-28-2013, 07:32 AM   #7
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 270

Rep: Reputation: 84
Hard blocked means it's a physical switch or bios setting generally... you need to press the enable button if there is one, find the switch, or go into the uefi or bios, whatever the laptop has, and enable it there. The OS can't override a hard block on your wifi card.
 
Old 06-29-2013, 03:23 AM   #8
xavi_slacky
Member
 
Registered: Jun 2013
Posts: 104

Original Poster
Rep: Reputation: Disabled
> Old Yesterday, 07:32 AM #7
>
> WhiteWolf1776

Hi WhiteWolf1776,
>
> Member
>
>
> Registered: Oct 2010
> Location: Pittsburgh, PA
> Distribution: Slackware
> Posts: 65
> Rep: Reputation: 12
>
> Hard blocked means it's a physical switch or bios setting
> generally... you need to press the enable button if there is one,
> find the switch, or go into the uefi or bios, whatever the laptop
> has, and enable it there. The OS can't override a hard block on your
> wifi card.
>
>

Yes, yes, if I totally agree with you with what you say.
But what I am saying is that in the same situation with another OS, Wi-Fi operate perfectly, without having to press the physical button on the Wi-Fi, or touch anything in the BIOS, the laptop has no UEFI.
So I understand that it is solely the configuration of Slackware.

More ideas ?

Thanks, see you.
 
Old 06-29-2013, 03:36 AM   #9
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,580

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
@xavi_slacky: would you mind using the "quote" button instead of copying/pasting the text of messages your are answering? It would make you posts easier to read.
 
1 members found this post helpful.
Old 06-29-2013, 09:40 AM   #10
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 270

Rep: Reputation: 84
just making sure...

rfkill listall

<fn> f2 (or whatever your particular button is)

rfkill listall

and nothing has changed?

Can you put your make and model in here?
 
Old 06-30-2013, 03:08 AM   #11
xavi_slacky
Member
 
Registered: Jun 2013
Posts: 104

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
@xavi_slacky: would you mind using the "quote" button instead of copying/pasting the text of messages your are answering? It would make you posts easier to read.
There are two ways of reading the PCs, graphical mode and text mode.

In graphics mode, and a graphical web browser, for example Firefox, certainly reading through the windows and colors offered by the "quote" of this bulletin board style that is more friendly to use the syntax of answer types of customers use email client as me. However, in my opinion, the answer style used email clients in graphical mode is just as easy reading using windows with different color quote button.

In text mode, there are users who, instead of using the PCs regularly with text mode. This mode has one of the advantages of graphical mode is speed, etc. In this mode, for example if you visualize this forum in one of the most used browsers, such as Lynx, Lynx see the text mode diferencie not correctly quoted text cited text not cited. This provokes a reading that is not easy to use the quote button visulizations text mode.

At the conclusion of this explanation, -it's my opinion-, I hope you will agree, in deference to those users who are viewing this forum in text mode, web browsers of text mode offers easy reading of the quoted text and not quoted, it is advisable not to use the quote button. I use a syntax more or less standard, as is the syntax of answer email clients. However, I must say that I have no objection to using the quote button, and as a courtesy to you, to your replies, so I will. But mostly my opinion is shared, graphical mode and text mode of text citation, you let me that for a good read in text mode, use a syntax quoted text easy to read in both modes.
 
Old 06-30-2013, 03:24 AM   #12
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,580

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
@xavi_slacky: I just launched that page in lynx and still prefer to use Firefox for that, as bloated as it can be.

That said, you stay free to format your messages as you like, of course. Still, if you want to continue using that "mailing-list like" format, I'd suggest that you do not include in your answers quote of previous poster's profile, as that is useless and distract from the topic IMHO.
 
Old 06-30-2013, 03:25 AM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,972

Rep: Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084
Thankyou for starting to use quotes. It is a deference to the majority of graphical browser users that is appreciated.
You do not actually need to use the quote button. Simply wrap your text with [quote]<text>[/quote]
For more about BB codes see here. http://www.linuxquestions.org/questi....php?do=bbcode
 
Old 06-30-2013, 03:27 AM   #14
xavi_slacky
Member
 
Registered: Jun 2013
Posts: 104

Original Poster
Rep: Reputation: Disabled
> Old Yesterday, 09:40 AM #10
>
> WhiteWolf1776


Hi WhiteWolf1776

>
> Member
>
>
> Registered: Oct 2010
> Location: Pittsburgh, PA
> Distribution: Slackware
> Posts: 66
> Rep: Reputation: 12
>
> just making sure...
> rfkill listall
> <fn> f2 (or whatever your particular button is)
> rfkill listall
> and nothing has changed?


root@slackware:~# rfkill listall
Usage: rfkill [options] command
Options:
--version show version (0.4)
Commands:
help
event
list [IDENTIFIER]
block IDENTIFIER
unblock IDENTIFIER
where IDENTIFIER is the index no. of an rfkill switch or one of:
<idx> all wifi wlan bluetooth uwb ultrawideband wimax wwan gps fm
root@slackware:~# rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
root@slackware:~#

root@slackware:~# f2
-bash: f2: command not found
root@slackware:~# rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
root@slackware:~# button switched
-bash: phyfical: command not found
root@slackware:~# rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
root@slackware:~#


> Can you put your make and model in here?

Yes, acer aspire 5634WLMi

Thanks, see you.
 
Old 06-30-2013, 03:34 AM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,972

Rep: Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084
According to the graphic I just looked at ( as you are using Lynx I will not post a link ), the wireless hardware switch is on the front of your PC.
Repeat the exercise flicking that switch rather than using F2. Also just use 'rfkill list'.

Last edited by allend; 06-30-2013 at 03:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need steps on how to setup a wireless access on opensuse 12.1 to a wireless router. Glenn D. Linux - Software 1 11-24-2011 01:50 PM
[SOLVED] Slackware wireless networking setup w/Broadcom Wireless BCM4311 NIC on HP DV9000 astanton Slackware 14 12-30-2010 07:37 PM
[SOLVED] Warning: Dumb Question Here: SlackWare Wireless Setup for Dummies. Bull3t Slackware 9 08-26-2010 08:24 PM
gateway mx8438 laptop integrated wireless setup question treborsitnay Linux - Newbie 2 04-09-2009 10:31 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration