LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Wireless Problems (https://www.linuxquestions.org/questions/slackware-14/wireless-problems-852650/)

nova49 12-27-2010 01:38 PM

Wireless Problems
 
I have a fresh install of Slackware 13.1 on my Samsung N150 plus. I've been fiddling around with it for a couple of days trying to get the wireless to work. Below are the network controllers of my laptop.

05:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller

I included wireless and wired, not sure it would help or not.


After many Google searches on the subject I installed and setup Wicd. I am able to get a wired connection but not a wireless. I can see other networks, I am unable to connect to them though. Also when I installed Slackware I didn't setup the network. The Readme for Wicd said that having a network configured can mess it up. But is having no network set up worse. I know there is easier way to setup wireless networks, I just cant figure it out. Help is appreciated.

*Edit* If I'm missing some information that would help fix this, please tell me. Thanks

mastemmer 12-27-2010 03:00 PM

1) On my slackware system i replaced all the script /etc/rc.d/rc.wireless with just one call to iwconfig:

iwconfig wlan0 essid mywireless key 0123-4567-89

Where "mywireless" is the name of my wireless connection and 0123-4567-89 is the key to WEP-64 encryption.

2) Use pkgtool to set up a DHCP network.

3) Edit /etc/rc.d/rc.inet1.conf:
Replace
USE_DHCP[0]="yes"
with
USE_DHCP[0]=""
Uncomment the lines
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"

4) Reboot the system. See if it can get an IP from wlan0.

nova49 12-27-2010 03:35 PM

What part of the script do I replace. I looked through and didn't see a part that made sense to change. Or do you want me to replace the whole script with iwconfig wlan0 essid mywireless key 0123-4567-89? Im hesitant because the last time I removed a script I caused the computer to not be able to boot.

Also will having Wicd installed mess any thing up?

mastemmer 12-27-2010 03:56 PM

If you don't want to dump all your /etc/rc.d/rc.wireless, just rename it so that you can put it back in place if anything goes wrong. All you need in rc.wireless is that line

iwconfig wlan0 essid mywireless key 0123-4567-89

Don't forget to chmod +x rc.wireless to make it executable.

markush 12-27-2010 04:32 PM

Quote:

Originally Posted by nova49 (Post 4204568)
05:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller

Hi nova49,

I have a Samsung laptop with the same network adapters, both, wired and wireless work out of the box with Slackware 13.1.

Please post the output of (execute as root!)
Code:

iwconfig
Markus

nova49 12-27-2010 06:16 PM

mastemmer
I did what you said and I did get a wireless connection. There are a couple of things I do have problems with though. I wouldn't be able to connect to another wireless internet without having to edit files.

Code:

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0    IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated 
          Tx-Power=20 dBm 
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Encryption key:1F90-3F62-F4
          Power Management:off


markush 12-27-2010 06:20 PM

Well, your wireless adapter is working but you're not authenticated at the accesspoint.
Which encryption does your wireless network use?

Markus

nova49 12-27-2010 06:39 PM

WEP I believe

markush 12-27-2010 06:47 PM

Well, did you configure the key anywhere?
You know, without the apropriate key and the ssid (networkname) you cannot authenticate at the accesspoint.
If you're running wicd there should be an icon anywhere in your Windowmanager, if you click the icon with the righthand button, you'll get some options, when you go onto the "connection" field with the mousepointer, wicd scans for the available wireless networks. You may chose yours and when wicd asks, you'll have to enter your key.

Be sure that wicd is running
Code:

ps -e | grep wicd
if this doesn't show any output you'll have to start wicd as root
Code:

/etc/rc.d/rc.wicd start
This should all work without changing the script rc.inet1.conf

Markus

nova49 12-27-2010 07:37 PM

Wicd runs fine. It doesn't ask me for my WEP key though. I'm using the version I got with the disk. Do you think it might be a bug that is fixed in a future release of it?

markush 12-28-2010 03:03 AM

Well, try it without wicd.

You edit the /etc/rc.d/rc.inet1.conf (it is selfexplaining) and the /etc/wpa_supplicant.conf (there's an examplefile in the /usr/share/wpa_supplicant directory. And uninstall wicd before!

After configuring rc.inet1.conf and wpa_supplicant.conf you can start your wlan0 with
Code:

/etc/rc.d/rc.inet1 wlan0_start
Markus

disturbed1 12-28-2010 04:11 AM

Quote:

Originally Posted by nova49 (Post 4204923)
Wicd runs fine. It doesn't ask me for my WEP key though. I'm using the version I got with the disk. Do you think it might be a bug that is fixed in a future release of it?

You have to configure the options under preferences for that adapter. There's a check mark for using encryption, then a spot to input your key. Wicd does not prompt you encryption keys, you have to put them in manually. Once these preferences are set, they are remembered though.

mastemmer 12-28-2010 09:38 AM

If your wireless router is set with 64 bit WEP encryption, the key is a ten digit hexadecimal number such as 1234-5678-9A. There is also the network ID (ESSID) which is the name of you network connection.
You may use wicd to find the essid of wireless networks in the neighborhood. It won't tell anything about WEP keys because that is intended to be secret.
The command
iwconfig wlan0 essid mywireles key 1234-5678-9A
sets the essid and key so that it can connect to a wireless network.
The script /etc/rc.d/rc.inet1 uses DHCP to get an IP.
OK. The method i recommended is not flexible, but works if you don't
have to change your wireless station frequently.
The original script may be better, automatically detecting the surrounding networks, but did not work for me.

2handband 12-28-2010 09:40 AM

Quote:

Originally Posted by nova49 (Post 4204923)
Wicd runs fine. It doesn't ask me for my WEP key though. I'm using the version I got with the disk. Do you think it might be a bug that is fixed in a future release of it?

Does Wicd detect the wireless network?

nova49 12-30-2010 11:28 PM

Thanks for all of the help guys but I kind of gave up. I installed Debian and it fixed most of my problems. But of course it still doesn't do what I want it to do. I still am unable to view other wireless networks available and switch to them. It picks one network at boot up and sticks to it. Since I hate Debian with a passion I was wondering if there was a better solution with Slackware.


All times are GMT -5. The time now is 05:08 PM.