-   Slackware (
-   -   Wireless not working on Slackware 12 (

Rommeo 05-14-2008 03:29 PM

Wireless not working on Slackware 12

i m using Slackware 12 as my operating system. I tried to use wireless device but could not succeded..
here are some outputs :

Network Controller : Inter Corporation PRO/Wireless 2200BG Connection(rev 05)

lo no wireless extensions.
eth0 no wireless extensions.

eth0: (eth0 proporties.. )
lo : (lo proporties..)

When i was using it with fedora, it was at eth1 and was working. But now i cant use ifconfig command(cause there is no wireless device it says..:( ) and i cant enable wireless device. Can anyone help me?

Thanks in advance.

onebuck 05-14-2008 03:42 PM


Do a 'lspci -vv' and 'ifconfig -a' and post the results.

Rommeo 05-14-2008 05:13 PM


lspci -vv
02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
        Subsystem: Intel Corporation Unknown device 2741
        Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at e0401000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-


ifconfig -a
eth0      Link encap:Ethernet ..other stuffs.

lo        Link encap:Local Loopback..other stuffs.

onebuck 05-14-2008 07:06 PM


You should upgrade your 'pci.ids file'.

You should update your distribution id's periodically if you change pci devices with newer ones or have unknown pci device(s).

Try the 'ipw2200.ko' module for your wireless. it is located;
'/lib/modules/' or '/lib/modules/'.

The location of the module depends on the kernel you are using.

All times are GMT -5. The time now is 01:14 PM.